1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need some help configuring wireless!

Discussion in 'Routing & Switching' started by Stoney, Nov 30, 2007.

  1. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    Hi,

    I'm having issues with the wireless setup on my Cisco 857w.

    I can't seem to get an IP from the router once authenticated, I just get an APIPA for the wireless connection.

    Here's the config:

    Current configuration : 2824 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    no service password-encryption
    service sequence-numbers
    !
    hostname Cisco857w
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 32768 debugging
    logging console critical
    enable secret 5 $1$muaT$EOvESVuaUuSV3Hd1Tx/E/1
    enable password xxxxxxxxxx
    !
    no aaa new-model
    !
    resource policy
    !
    no ip source-route
    no ip gratuitous-arps
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1
    ip dhcp excluded-address 192.168.1.90 192.168.1.99
    !
    ip dhcp pool dpool1
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1 255.255.255.0
    dns-server 194.72.9.38 62.6.40.162
    lease 0 10
    !
    !
    ip cef
    ip tcp synwait-time 10
    no ip domain lookup
    login block-for 60 attempts 3 within 30
    login on-failure log
    login on-success log
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    ip virtual-reassembly
    no atm ilmi-keepalive
    pvc encapsulation 0/38
    ubr 288
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode ansi-dmt
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface Dot11Radio0
    no ip address
    !
    encryption vlan 1 mode ciphers tkip
    !
    ssid CISCO
    vlan 1
    authentication open
    authentication key-management wpa
    wpa-psk ascii 7 124567890abcdef0987654321
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

    rts threshold 2312
    power local cck 20
    power local ofdm 17
    channel 2437
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp chap hostname xxxxxxxx@xxxxxxxxxx
    ppp chap password 0 xxxxxxxxxxxxx
    ppp ipcp dns request
    ppp ipcp route default
    !
    interface BVI1
    no ip address
    !
    !
    no ip http server
    no ip http secure-server
    ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
    ip nat inside source list 1 interface Dialer0 overload
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 15 permit 192.168.1.0 0.0.0.255
    access-list 15 deny any log
    access-list 101 permit ip 192.168.1.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    bridge 1 route ip
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class 15 in
    password xxxxxxxxxx
    login
    !
    scheduler max-task-time 5000
    end


    Is there something glaringly obvious that I am missing??

    Cheers,
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  2. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    Add the following global command:

    bridge 1 protocol ieee

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  3. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    Hey Spice Weasel,

    Thanks for your suggestion, I gave that a go but it didn't help the problem.

    I tried connecting via the Ethernet ports and found that I couldn't obtain an IP from that interface either.

    I have put a new config below, minus some access-lists and security on the wireless (I wanted to make sure that it wasn't one of these that may be causing the problem) but I'm still at a loss as to what the problem may be??


    Current configuration : 2470 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    no service password-encryption
    service sequence-numbers
    !
    hostname Cisco
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 **********************************
    enable password ***************
    !
    no aaa new-model
    !
    resource policy
    !
    no ip source-route
    no ip gratuitous-arps
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.99
    !
    ip dhcp pool dpool1
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1 255.255.255.0
    dns-server 194.72.9.38 62.6.40.162
    lease 0 10
    !
    !
    ip cef
    ip tcp synwait-time 10
    no ip domain lookup
    login block-for 60 attempts 3 within 30
    login on-failure log
    login on-success log
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    ip virtual-reassembly
    no atm ilmi-keepalive
    pvc 0/38
    ubr 288
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode ansi-dmt
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface Dot11Radio0
    no ip address
    !
    ssid 3T-BACKUP
    vlan 1
    authentication open
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
    54.0
    rts threshold 2312
    power local cck 20
    power local ofdm 17
    channel 2437
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp chap hostname *********************
    ppp chap password 0 ***************
    ppp ipcp dns request
    ppp ipcp route default
    !
    interface BVI1
    no ip address
    !
    !
    no ip http server
    no ip http secure-server
    ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
    ip nat inside source list 1 interface Dialer0 overload
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class 15 in
    password **************
    login
    !
    scheduler max-task-time 5000
    end
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  4. MacAllan

    MacAllan Byte Poster

    249
    6
    30
    don't you have to enable the service:

    service dhcp

    ?
     
    Certifications: A+, N+, CCNA
    WIP: CCNP, Linux+
  5. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    You can try the service dhcp command, it is worth a try, but service dhcp is enabled by default. If it is disabled "no service dhcp" will show in the config.

    Run debugs to watch the dhcp process when a client connects to f0 (f1-f3 are shutdown) - that should provide some useful info.

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  6. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    Just a wee update to say I have sorted this problem now.

    The problem was resolved by configuring the BVI1 interface to have the IP address of the router, and setting the VLAN 1 and dot11radio0 interfaces to have no ip address.

    Basically I just passed all the original settings from the VLAN 1 interface on the BVI1 interface.

    Thanks for your input guys :thumbleft


    Below is a copy of the working config in case anyone has a similar problem in the future.


    Building configuration...

    Current configuration : 2626 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    no service password-encryption
    service sequence-numbers
    !
    hostname ***********
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$QozM$ZFY.q451gkbJjaesKTz2I.
    enable password ************
    !
    no aaa new-model
    !
    resource policy
    !
    no ip source-route
    no ip gratuitous-arps
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.99
    ip dhcp excluded-address 192.168.1.254
    !
    ip dhcp pool dpool1
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254 255.255.255.0
    dns-server 194.72.9.38 62.6.40.162
    lease 0 10
    !
    !
    ip cef
    ip tcp synwait-time 10
    no ip domain lookup
    login block-for 60 attempts 3 within 30
    login on-failure log
    login on-success log
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    ip virtual-reassembly
    no atm ilmi-keepalive
    pvc 0/38
    ubr 288
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode ansi-dmt
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    shutdown
    !
    interface FastEthernet2
    shutdown
    !
    interface FastEthernet3
    shutdown
    !
    interface Dot11Radio0
    no ip address
    !
    encryption mode ciphers tkip
    !
    ssid CISCO
    authentication open
    authentication key-management wpa
    wpa-psk ascii 0 ***************
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
    54.0
    rts threshold 2312
    power local cck 20
    power local ofdm 17
    channel 2437
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp chap hostname *********************
    ppp chap password 0 ********************
    ppp ipcp dns request
    ppp ipcp route default
    !
    interface BVI1
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    !
    no ip http server
    no ip http secure-server
    ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
    ip nat inside source list 1 interface Dialer0 overload
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class 15 in
    password **************
    login
    !
    scheduler max-task-time 5000
    end
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270

Share This Page

Loading...