My first lab...

Discussion in 'General Cisco Certifications' started by surfer_rosa, Jan 11, 2007.

  1. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    I've done my ccna intro and i'm halfway through the icnd book and thought it was a good time to try and get my home lab all hooked up.

    Just now i have:

    2501 Router
    2503 Router
    2504 Router

    connected to each other via some very clever cables that have a DCE connector on one end and a DTE connector on the other (DB60 Crossover cables i believe they're called).

    My plan was to link them similarly to so many of the examples in the ciscopress books i'm reading (all routers linked to each other).

    Here is the ip address scheme i used.

    2501 Router (Hostname: Charlie)
    Serial 0 - 192.168.0.246/30 (James)
    Serial 1 - 192.168.0.253/30 (Matt)

    2503 Router (Hostname: Matt)
    Serial 0 - 192.168.0.254/30 (Charlie)
    Serial 1 - 192.168.0.249/30 (James)

    2504 Router (Hostname: James)
    Serial 0 - 192.168.0.250/30 (Matt)
    Serial 1 - 192.168.0.245/30 (Charlie)

    And here are the config files from each router:

    Charlie
    Code:
    Current configuration : 586 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname charlie
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cockarm
    !
    no aaa new-model
    ip subnet-zero
    !
    prompt %h%s%p%s
    !
    !
    !
    interface Ethernet0
     no ip address
     shutdown
    !
    interface Serial0
     description link to james
     ip address 192.168.0.246 255.255.255.252
    !
    interface Serial1
     description link to matt
     ip address 192.168.0.253 255.255.255.252
     clockrate 125000
    !
    no ip http server
    ip classless
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    Matt
    Code:
    Current configuration : 697 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname matt
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cockarm
    !
    no aaa new-model
    ip subnet-zero
    !
    prompt %h%s%p%s
    !
    !
    !
    interface Ethernet0
     no ip address
     shutdown
    !
    interface Serial0
     description link to charlie
     ip address 192.168.0.254 255.255.255.252
    !
    interface Serial1
     description link to james
     ip address 192.168.0.249 255.255.255.252
     clockrate 125000
    !
    interface BRI0
     no ip address
     shutdown
    !
    no ip http server
    ip classless
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    James
    Code:
    Current configuration:
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname james
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    prompt %h%s%p%s
    !
    !
    !
    interface Serial0
     description link to matt
     ip address 192.168.0.250 255.255.255.252
    !
    interface Serial1
     description link to charlie
     ip address 192.168.0.245 255.255.255.252
     clockrate 125000
    !
    interface TokenRing0
     no ip address
     shutdown
    !
    interface BRI0
     no ip address
     shutdown
    !
    ip classless
    no ip http server
    !
    !
    line con 0
     transport input none
    line aux 0
    line vty 0 4
    !
    end
    The Problem

    James reports both serial links as up & up, can ping matt, but not charlie.

    Matt reports its link to james as up & up but reports its link to charlie as up & down. Can ping james, but not charlie.

    Charlie reports both links as up & down and can't ping anyone.


    Can anyone tell my why charlie is behaving this way, or what i've done wrong? Much appreciated 8)


    EDIT: Forgot to mention that matt and james have each other in their cdp neighbor list, but neither has charlie in their list, and charlie has no one in his.
     
    Certifications: None.... yet
    WIP: CCNA
  2. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    Have you tried to reverse the clocking statements on Charlie?
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall
  3. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Cheers for the reply. Just tried that there - serial 0 rejects the command, saying it applies to DCE interfaces only.

    And i've checked the cable - the DCE end is definitely in charlie serial 1.

    Anything else?
     
    Certifications: None.... yet
    WIP: CCNA
  4. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    try setting your clock rates to 64000. I know you can have the clock rate set up to:

    CAC-Riverside-3845-1(config-if)#clock rate ?
    :h:00-4000000> Choose clockrate from list above

    but most of the labs I have seen have usually used 64000 as the clock rate.

    Once you do this do a shut no shut and see what you get. If it is still down can you paste the following output:

    Sh ip int bri
    Sh interface (s0 or s1)

    Also try swapping the known good cable to the interface that isn't coming up. I wonder if it is your back to back serial cable?
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall
  5. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    Clock Rate 64000 worked great. Some clock rates aren't available on certain IOS versions I found out. 125000 was available on one IOS but not on another. On the other 128000 was available. I don't know. BUT 64000 was on all of the IOS that I tried and it worked fine and will be fine for lab use.

    From Charlie:

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    MATT Ser 0 135 R 2620 Ser 1/1
    JAMES Ser 1 144 R 2511 Ser 1

    From James:

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    MATT Ser 0 156 R 2620 Ser 1/3
    CHARLIE Ser 1 130 R 2509 Ser 1

    From Matt:

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    JAMES Ser 1/3 168 R 2511 Ser 0
    CHARLIE Ser 1/1 159 R 2509 Ser 0


    By the way..whats up with your enable password: Cockarm? You strangl'en some chickens? :eek:
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall
  6. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Thanks so much for your help!

    When you mentioned the clocking before i had a go at changing them all to 9600, just to see if that was the problem, but i got the same problem. Just tried 64000 and the same happened.

    And i've just tried using all 3 cables in the link that does work (matt <-> james) and all three report up and up and ping correctly.

    I'll post the outputs you requested later on, but it's looking like charlie is 'busted' (the irony that i named my 3 routers after members in the band busted...)


    Thanks for your help again!
     
    Certifications: None.... yet
    WIP: CCNA
  7. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Here's the output you requested from charlie...

    Code:
    [b]charlie # sh ip int brief[/b]
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0                  unassigned      YES NVRAM  administratively down down    
    Serial0                    192.168.0.246   YES NVRAM  up                    down    
    Serial1                    192.168.0.253   YES NVRAM  up                    down    
    [b]charlie # sh int s0[/b]
    Serial0 is up, line protocol is down 
      Hardware is HD64570
      Description: link to james
      Internet address is 192.168.0.246/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set
      Keepalive set (10 sec)
      Last input never, output 00:00:16, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         39 packets output, 1641 bytes, 0 underruns
         0 output errors, 0 collisions, 15 interface resets
         0 output buffer failures, 0 output buffers swapped out
         46 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    [b]charlie # sh int s1[/b]
    Serial1 is up, line protocol is down 
      Hardware is HD64570
      Description: link to matt
      Internet address is 192.168.0.253/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set
      Keepalive set (10 sec)
      Last input never, output 00:00:01, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1158 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         56 packets output, 3087 bytes, 0 underruns
         0 output errors, 0 collisions, 19 interface resets
         0 output buffer failures, 0 output buffers swapped out
         33 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    If there's anything else that can help then please let me know.

    Thanks!
     
    Certifications: None.... yet
    WIP: CCNA
  8. Headache

    Headache Gigabyte Poster

    1,092
    9
    85
    Hi Surfer Rosa,

    I'm sort of new at this as well, so I could be totally wrong.

    But your ip addresses look a little wierd. Think that could be the problem ?

    192.168 is a class-C address. But the way you set them up are like network i.ps of a class B subnet.

    Try 192.168 dot 1 instead of dot zero and see what happens.

    Another thing you could try is do a sh ver on the malfunctioning Router to see if the config register is right.

    Another thing you can try is to check your cabling. I've found out the hard way that when you plug the DTE end into a port meant for a DCE, then the Router usually doesn't work right. You can check this physically, or if your cables aren't labelled, you can check it on the sh controllers command.

    That's all I can think of right now. Let us know how you get on.

    Cheers.
     
    Certifications: CCNA
    WIP: CCNP
  9. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    Headache,

    The IP Addresses are valid with the subnet mask listed. Here are all the valid subnets for the 192.168.0.x range:

    IP Subnet info for: 192.168.0.0/30 (255.255.255.252)

    All Subnets starting with: 192.168.0.0

    192.168.0.0
    192.168.0.4
    192.168.0.8
    192.168.0.12
    192.168.0.16
    192.168.0.20
    192.168.0.24
    192.168.0.28
    192.168.0.32
    192.168.0.36
    192.168.0.40
    192.168.0.44
    192.168.0.48
    192.168.0.52
    192.168.0.56
    192.168.0.60
    192.168.0.64
    192.168.0.68
    192.168.0.72
    192.168.0.76
    192.168.0.80
    192.168.0.84
    192.168.0.88
    192.168.0.92
    192.168.0.96
    192.168.0.100
    192.168.0.104
    192.168.0.108
    192.168.0.112
    192.168.0.116
    192.168.0.120
    192.168.0.124
    192.168.0.128
    192.168.0.132
    192.168.0.136
    192.168.0.140
    192.168.0.144
    192.168.0.148
    192.168.0.152
    192.168.0.156
    192.168.0.160
    192.168.0.164
    192.168.0.168
    192.168.0.172
    192.168.0.176
    192.168.0.180
    192.168.0.184
    192.168.0.188
    192.168.0.192
    192.168.0.196
    192.168.0.200
    192.168.0.204
    192.168.0.208
    192.168.0.212
    192.168.0.216
    192.168.0.220
    192.168.0.224
    192.168.0.228
    192.168.0.232
    192.168.0.236
    192.168.0.240
    192.168.0.244
    192.168.0.248
    192.168.0.252

    It shouldn't be the config register since he is booting up his IOS fine. He could try upgrading his IOS or checking to see if they are the same versions as the routers that are working...I suppose.

    Honestly I wonder if the port is bad, however the SH INT shows an UP/DOWN status which usually would indicate you have a layer 2 issue. The ecapsulation should default to HDLC so that shouldn't be the problem. The only other other issue could be the clocking...that I can see. He tested the cables on the link that is working...

    Good thoughts though. He could try turning on Debugging to see at what point the link is failing...
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall
  10. Headache

    Headache Gigabyte Poster

    1,092
    9
    85
    My bad with the i.p thing.

    Perhaps Surfer can post readouts from show controllers on all three routers to confirm that the clocking and the connections are up to scratch ?

    Like you say, the port probably isn't the problem. But just for kicks, he might try swopping the connector over to a different port or if he's handy with a screwdriver, remove the module entirely and swop it with a module on one of the good routers.

    I'm probably talking out of my ass at this point. I'll wrack my brains later on and see what else I can come up with.
     
    Certifications: CCNA
    WIP: CCNP
  11. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Cheers for the replys guys. Its good to get some brainstorming on the go.

    I thought the subnets were fine to be honest but i decided to go with a more 'classful' ip address structure just for testings sake.

    Used class C network addresses with the default subnet mask (255.255.255.0 - /24).

    Charlie S0 - 192.168.1.1
    James S1 - 192.168.1.254

    James S0 - 192.168.2.1
    Matt S1 - 192.168.2.254

    Matt S0 - 192.168.3.1
    Charlie S1 - 192.168.3.254

    And again it's the same problem... matt and james linking up fine, with nobody able to reach charlie.

    In terms of the router IOS, charlie and matt are 12.3, james is 12.1 and seeing as charlie is the problem one, i don't think it's the IOS. I backed up the 12.3 IOS image though and was going to transfer it to james, but there isn't enough flash on it :cry:

    As you can see HDLC is being used on charlie and i checked the other 2 - its the same situation.

    I'll post any interesting readouts later. Please post any useful debugging commands as this is my first time using routers so i'm not exactly a seasoned pro :biggrin

    And yeah - i am actually fairly handy with a screwdriver - that idea is definitely worth a go 8)


    Cheers!
     
    Certifications: None.... yet
    WIP: CCNA
  12. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Ok - here's the output of show controllers on all 3 routers. I occured to me that maybe there is a bad port in each of james and matt, and that charlie is totally fine. I'll change the link from James S0 - Matt S1 to James S1 - Matt S0 to check that. Anyway...

    charlie:
    Code:
    charlie # sh cont
    LANCE unit 0, idb 0x24B9D8, ds 0x1CD378, regaddr = 0x2130000, reset_mask 0x2
    IB at 0xE06EA0: mode=0x0000, mcfilter 0000/0000/0100/0000
    station address 00e0.1e3e.7d5e  default station address 00e0.1e3e.7d5e
    buffer size 1524
    RX ring with 16 entries at 0xE06EE8
    Rxhead = 0xE06EE8 (0), Rxp = 0x1CD394 (0)
    00 pak=0x2500B8 ds=0xE0A686 status=0x80 max_size=1524 pak_size=0
    01 pak=0x25039C ds=0xE0AD42 status=0x80 max_size=1524 pak_size=0
    02 pak=0x250680 ds=0xE0B3FE status=0x80 max_size=1524 pak_size=0
    03 pak=0x250964 ds=0xE0BABA status=0x80 max_size=1524 pak_size=0
    04 pak=0x250C48 ds=0xE0C176 status=0x80 max_size=1524 pak_size=0
    05 pak=0x250F2C ds=0xE0C832 status=0x80 max_size=1524 pak_size=0
    06 pak=0x251210 ds=0xE0CEEE status=0x80 max_size=1524 pak_size=0
    07 pak=0x2514F4 ds=0xE0D5AA status=0x80 max_size=1524 pak_size=0
    08 pak=0x2517D8 ds=0xE0DC66 status=0x80 max_size=1524 pak_size=0
    09 pak=0x251ABC ds=0xE0E322 status=0x80 max_size=1524 pak_size=0
    10 pak=0x251DA0 ds=0xE0E9DE status=0x80 max_size=1524 pak_size=0
    11 pak=0x252084 ds=0xE0F09A status=0x80 max_size=1524 pak_size=0
    12 pak=0x252368 ds=0xE0F756 status=0x80 max_size=1524 pak_size=0
    13 pak=0x25264C ds=0xE0FE12 status=0x80 max_size=1524 pak_size=0
    14 pak=0x252930 ds=0xE104CE status=0x80 max_size=1524 pak_size=0
    15 pak=0x252C14 ds=0xE10B8A status=0x80 max_size=1524 pak_size=0
    TX ring with 4 entries at 0xE06FA0, tx_count = 0
    tx_head = 0xE06FA0 (0), head_txp = 0x1CD3E8 (0)
    tx_tail = 0xE06FA0 (0), tail_txp = 0x1CD3E8 (0)
    00 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    02 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    03 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    0 missed datagrams, 0 overruns
    0 transmitter underruns, 0 excessive collisions
    0 single collisions, 0 multiple collisions
    0 dma memory errors, 0 CRC errors
    
    0 alignment errors, 0 runts, 0 giants
    0 tdr, 0 spurious initialization done interrupts
    0 no enp status, 0 buffer errors, 0 overflow errors
    0 tx_buff, 0 throttled, 0 enabled
    Lance csr0 = 0x4
    HD unit 0, idb = 0x249A10, driver structure at 0x24ADF0
    buffer size 1524  HD unit 0, V.35 DTE cable
    cpb = 0xE1, eda = 0x5140, cda = 0x5000
    RX ring with 16 entries at 0xE15000
    00 bd_ptr=0x5000 pak=0x25F1D0 ds=0xE18908 status=80 pak_size=0
    01 bd_ptr=0x5014 pak=0x25F4B4 ds=0xE18FC4 status=80 pak_size=0
    02 bd_ptr=0x5028 pak=0x25F798 ds=0xE19680 status=80 pak_size=0
    03 bd_ptr=0x503C pak=0x25FA7C ds=0xE19D3C status=80 pak_size=0
    04 bd_ptr=0x5050 pak=0x25FD60 ds=0xE1A3F8 status=80 pak_size=0
    05 bd_ptr=0x5064 pak=0x260044 ds=0xE1AAB4 status=80 pak_size=0
    06 bd_ptr=0x5078 pak=0x260328 ds=0xE1B170 status=80 pak_size=0
    07 bd_ptr=0x508C pak=0x26060C ds=0xE1B82C status=80 pak_size=0
    08 bd_ptr=0x50A0 pak=0x2608F0 ds=0xE1BEE8 status=80 pak_size=0
    09 bd_ptr=0x50B4 pak=0x260BD4 ds=0xE1C5A4 status=80 pak_size=0
    10 bd_ptr=0x50C8 pak=0x260EB8 ds=0xE1CC60 status=80 pak_size=0
    11 bd_ptr=0x50DC pak=0x26119C ds=0xE1D31C status=80 pak_size=0
    12 bd_ptr=0x50F0 pak=0x261480 ds=0xE1D9D8 status=80 pak_size=0
    13 bd_ptr=0x5104 pak=0x261764 ds=0xE1E094 status=80 pak_size=0
    14 bd_ptr=0x5118 pak=0x261A48 ds=0xE1E750 status=80 pak_size=0
    15 bd_ptr=0x512C pak=0x261D2C ds=0xE1EE0C status=80 pak_size=0
    16 bd_ptr=0x5140 pak=0x262010 ds=0xE1F4C8 status=80 pak_size=0
    cpb = 0xE1, eda = 0x583C, cda = 0x5814
    TX ring with 4 entries at 0xE15800
    00 bd_ptr=0x5800 pak=0x000000 ds=0xE00C5C status=80 pak_size=22
    01 bd_ptr=0x5814 pak=0x1E69D4 ds=0xE0111C status=80 pak_size=22
    02 bd_ptr=0x5828 pak=0x1E80F4 ds=0xE01A9C status=80 pak_size=22
    03 bd_ptr=0x583C pak=0x000000 ds=0x000000 status=80 pak_size=0
    04 bd_ptr=0x5850 pak=0x000000 ds=0x000000 status=80 pak_size=0
    0 missed datagrams, 0 overruns
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 residual bit errors
    HD unit 1, idb = 0x263730, driver structure at 0x24B0B8
    buffer size 1524  HD unit 1, V.35 DCE cable, clockrate 64000
    cpb = 0xE2, eda = 0x3140, cda = 0x3000
    RX ring with 16 entries at 0xE23000
    00 bd_ptr=0x3000 pak=0x26C4C8 ds=0xE26FC4 status=80 pak_size=0
    01 bd_ptr=0x3014 pak=0x26C7AC ds=0xE27680 status=80 pak_size=0
    02 bd_ptr=0x3028 pak=0x26CA90 ds=0xE27D3C status=80 pak_size=0
    03 bd_ptr=0x303C pak=0x26CD74 ds=0xE283F8 status=80 pak_size=0
    04 bd_ptr=0x3050 pak=0x26D058 ds=0xE28AB4 status=80 pak_size=0
    05 bd_ptr=0x3064 pak=0x26D33C ds=0xE29170 status=80 pak_size=0
    06 bd_ptr=0x3078 pak=0x26D620 ds=0xE2982C status=80 pak_size=0
    07 bd_ptr=0x308C pak=0x26D904 ds=0xE29EE8 status=80 pak_size=0
    08 bd_ptr=0x30A0 pak=0x26DBE8 ds=0xE2A5A4 status=80 pak_size=0
    09 bd_ptr=0x30B4 pak=0x26DECC ds=0xE2AC60 status=80 pak_size=0
    10 bd_ptr=0x30C8 pak=0x26E1B0 ds=0xE2B31C status=80 pak_size=0
    11 bd_ptr=0x30DC pak=0x26E494 ds=0xE2B9D8 status=80 pak_size=0
    12 bd_ptr=0x30F0 pak=0x26E778 ds=0xE2C094 status=80 pak_size=0
    13 bd_ptr=0x3104 pak=0x26EA5C ds=0xE2C750 status=80 pak_size=0
    14 bd_ptr=0x3118 pak=0x26ED40 ds=0xE2CE0C status=80 pak_size=0
    15 bd_ptr=0x312C pak=0x26F024 ds=0xE2D4C8 status=80 pak_size=0
    16 bd_ptr=0x3140 pak=0x26F308 ds=0xE2DB84 status=80 pak_size=0
    cpb = 0xE2, eda = 0x3800, cda = 0x3800
    TX ring with 1 entries at 0xE23800
    00 bd_ptr=0x3800 pak=0x000000 ds=0xE0007C status=80 pak_size=22
    01 bd_ptr=0x3814 pak=0x000000 ds=0xE236A4 status=80 pak_size=22
    0 missed datagrams, 0 overruns
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 residual bit errors
    matt:
    Code:
    matt # sh cont
    BRI unit 0
    D Chan Info:
    Layer 1 is ACTIVATING
    idb 0x2547AC, ds 0x261060, reset_mask 0x8
    buffer size 1524
    RX ring with 2 entries at 0x2101600 : Rxhead 0
    00 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7000 pak_size=0
    TX ring with 2 entries at 0x2101640: tx_count = 0, tx_head = 0, tx_tail = 0
    00 pak=0x000000 ds=0x000000 status=5C00 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7C00 pak_size=0
    0 missed datagrams, 0 overruns, 0 bad frame addresses
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 d channel collisions
    B1 Chan Info:
    Layer 1 is ACTIVATING
    idb 0x257350, ds 0x261138, reset_mask 0x0
    buffer size 1524
    RX ring with 8 entries at 0x2101400 : Rxhead 0
    00 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    02 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    03 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    04 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    05 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    06 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    07 pak=0x000000 ds=0x000000 status=7000 pak_size=0
    TX ring with 2 entries at 0x2101440: tx_count = 0, tx_head = 0, tx_tail = 0
    00 pak=0x000000 ds=0x000000 status=5C00 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7C00 pak_size=0
    0 missed datagrams, 0 overruns, 0 bad frame addresses
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 d channel collisions
    B2 Chan Info:
    Layer 1 is ACTIVATING
    idb 0x25A698, ds 0x261210, reset_mask 0x2
    buffer size 1524
    RX ring with 8 entries at 0x2101500 : Rxhead 0
    00 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    02 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    03 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    04 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    05 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    06 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    07 pak=0x000000 ds=0x000000 status=7000 pak_size=0
    TX ring with 2 entries at 0x2101540: tx_count = 0, tx_head = 0, tx_tail = 0
    00 pak=0x000000 ds=0x000000 status=5C00 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7C00 pak_size=0
    0 missed datagrams, 0 overruns, 0 bad frame addresses
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 d channel collisions
    LANCE unit 0, idb 0x24B9D8, ds 0x1CD378, regaddr = 0x2130000, reset_mask 0x2
    IB at 0xE06EA0: mode=0x0000, mcfilter 0000/0000/0100/0000
    station address 00e0.1ea9.aa8e  default station address 00e0.1ea9.aa8e
    buffer size 1524
    RX ring with 16 entries at 0xE06EE8
    Rxhead = 0xE06EE8 (0), Rxp = 0x1CD394 (0)
    00 pak=0x2500B8 ds=0xE0A686 status=0x80 max_size=1524 pak_size=0
    01 pak=0x25039C ds=0xE0AD42 status=0x80 max_size=1524 pak_size=0
    02 pak=0x250680 ds=0xE0B3FE status=0x80 max_size=1524 pak_size=0
    03 pak=0x250964 ds=0xE0BABA status=0x80 max_size=1524 pak_size=0
    04 pak=0x250C48 ds=0xE0C176 status=0x80 max_size=1524 pak_size=0
    05 pak=0x250F2C ds=0xE0C832 status=0x80 max_size=1524 pak_size=0
    06 pak=0x251210 ds=0xE0CEEE status=0x80 max_size=1524 pak_size=0
    07 pak=0x2514F4 ds=0xE0D5AA status=0x80 max_size=1524 pak_size=0
    08 pak=0x2517D8 ds=0xE0DC66 status=0x80 max_size=1524 pak_size=0
    09 pak=0x251ABC ds=0xE0E322 status=0x80 max_size=1524 pak_size=0
    10 pak=0x251DA0 ds=0xE0E9DE status=0x80 max_size=1524 pak_size=0
    11 pak=0x252084 ds=0xE0F09A status=0x80 max_size=1524 pak_size=0
    12 pak=0x252368 ds=0xE0F756 status=0x80 max_size=1524 pak_size=0
    13 pak=0x25264C ds=0xE0FE12 status=0x80 max_size=1524 pak_size=0
    14 pak=0x252930 ds=0xE104CE status=0x80 max_size=1524 pak_size=0
    15 pak=0x252C14 ds=0xE10B8A status=0x80 max_size=1524 pak_size=0
    TX ring with 4 entries at 0xE06FA0, tx_count = 0
    tx_head = 0xE06FA0 (0), head_txp = 0x1CD3E8 (0)
    tx_tail = 0xE06FA0 (0), tail_txp = 0x1CD3E8 (0)
    00 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    02 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    03 pak=0x000000 ds=0x000000 status=0x03 status2=0x0000 pak_size=0
    0 missed datagrams, 0 overruns
    0 transmitter underruns, 0 excessive collisions
    0 single collisions, 0 multiple collisions
    0 dma memory errors, 0 CRC errors
    
    0 alignment errors, 0 runts, 0 giants
    0 tdr, 0 spurious initialization done interrupts
    0 no enp status, 0 buffer errors, 0 overflow errors
    0 tx_buff, 0 throttled, 0 enabled
    Lance csr0 = 0x4
    HD unit 0, idb = 0x249A10, driver structure at 0x24ADF0
    buffer size 1524  HD unit 0, V.35 DTE cable
    cpb = 0xE2, eda = 0x4140, cda = 0x4000
    RX ring with 16 entries at 0xE24000
    00 bd_ptr=0x4000 pak=0x272C1C ds=0xE27FC4 status=80 pak_size=0
    01 bd_ptr=0x4014 pak=0x272F00 ds=0xE28680 status=80 pak_size=0
    02 bd_ptr=0x4028 pak=0x2731E4 ds=0xE28D3C status=80 pak_size=0
    03 bd_ptr=0x403C pak=0x2734C8 ds=0xE293F8 status=80 pak_size=0
    04 bd_ptr=0x4050 pak=0x2737AC ds=0xE29AB4 status=80 pak_size=0
    05 bd_ptr=0x4064 pak=0x273A90 ds=0xE2A170 status=80 pak_size=0
    06 bd_ptr=0x4078 pak=0x273D74 ds=0xE2A82C status=80 pak_size=0
    07 bd_ptr=0x408C pak=0x274058 ds=0xE2AEE8 status=80 pak_size=0
    08 bd_ptr=0x40A0 pak=0x27433C ds=0xE2B5A4 status=80 pak_size=0
    09 bd_ptr=0x40B4 pak=0x274620 ds=0xE2BC60 status=80 pak_size=0
    10 bd_ptr=0x40C8 pak=0x274904 ds=0xE2C31C status=80 pak_size=0
    11 bd_ptr=0x40DC pak=0x274BE8 ds=0xE2C9D8 status=80 pak_size=0
    12 bd_ptr=0x40F0 pak=0x274ECC ds=0xE2D094 status=80 pak_size=0
    13 bd_ptr=0x4104 pak=0x2751B0 ds=0xE2D750 status=80 pak_size=0
    14 bd_ptr=0x4118 pak=0x275494 ds=0xE2DE0C status=80 pak_size=0
    15 bd_ptr=0x412C pak=0x275778 ds=0xE2E4C8 status=80 pak_size=0
    16 bd_ptr=0x4140 pak=0x275A5C ds=0xE2EB84 status=80 pak_size=0
    cpb = 0xE2, eda = 0x4800, cda = 0x4800
    TX ring with 1 entries at 0xE24800
    00 bd_ptr=0x4800 pak=0x000000 ds=0x000000 status=80 pak_size=0
    01 bd_ptr=0x4814 pak=0x000000 ds=0x000000 status=80 pak_size=0
    0 missed datagrams, 0 overruns
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 residual bit errors
    HD unit 1, idb = 0x27717C, driver structure at 0x24B0B8
    buffer size 1524  HD unit 1, V.35 DCE cable, clockrate 64000
    cpb = 0xE3, eda = 0x28DC, cda = 0x28F0
    RX ring with 16 entries at 0xE32800
    00 bd_ptr=0x2800 pak=0x282D54 ds=0xE3CCC8 status=80 pak_size=287
    01 bd_ptr=0x2814 pak=0x281350 ds=0xE3902C status=80 pak_size=22
    02 bd_ptr=0x2828 pak=0x27FC30 ds=0xE35A4C status=80 pak_size=22
    03 bd_ptr=0x283C pak=0x2801F8 ds=0xE367C4 status=80 pak_size=22
    04 bd_ptr=0x2850 pak=0x27FF14 ds=0xE36108 status=80 pak_size=22
    05 bd_ptr=0x2864 pak=0x2804DC ds=0xE36E80 status=80 pak_size=22
    06 bd_ptr=0x2878 pak=0x2807C0 ds=0xE3753C status=80 pak_size=22
    07 bd_ptr=0x288C pak=0x280D88 ds=0xE382B4 status=80 pak_size=287
    08 bd_ptr=0x28A0 pak=0x28106C ds=0xE38970 status=80 pak_size=22
    09 bd_ptr=0x28B4 pak=0x281634 ds=0xE396E8 status=80 pak_size=22
    10 bd_ptr=0x28C8 pak=0x281918 ds=0xE39DA4 status=80 pak_size=22
    11 bd_ptr=0x28DC pak=0x281BFC ds=0xE3A460 status=80 pak_size=22
    12 bd_ptr=0x28F0 pak=0x2821C4 ds=0xE3B1D8 status=80 pak_size=22
    13 bd_ptr=0x2904 pak=0x2824A8 ds=0xE3B894 status=80 pak_size=22
    14 bd_ptr=0x2918 pak=0x28278C ds=0xE3BF50 status=80 pak_size=22
    15 bd_ptr=0x292C pak=0x280AA4 ds=0xE37BF8 status=80 pak_size=22
    16 bd_ptr=0x2940 pak=0x282A70 ds=0xE3C60C status=80 pak_size=22
    cpb = 0xE3, eda = 0x3000, cda = 0x3000
    TX ring with 1 entries at 0xE33000
    00 bd_ptr=0x3000 pak=0x000000 ds=0xE0682C status=80 pak_size=281
    01 bd_ptr=0x3014 pak=0x000000 ds=0xE329E4 status=80 pak_size=22
    0 missed datagrams, 0 overruns
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 residual bit errors
    james:
    Code:
    james # sh cont
    BRI unit 0
    D Chan Info:
    Layer 1 is ACTIVATING
    idb 0x10C3F0, ds 0x11AFD0, reset_mask 0x8
    buffer size 1524
    RX ring with 2 entries at 0x2101600 : Rxhead 0
    00 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7000 pak_size=0
    TX ring with 2 entries at 0x2101640: tx_count = 0, tx_head = 0, tx_tail = 0
    00 pak=0x000000 ds=0x000000 status=5C00 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7C00 pak_size=0
    0 missed datagrams, 0 overruns, 0 bad frame addresses
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 d channel collisions
    B1 Chan Info:
    Layer 1 is ACTIVATING
    idb 0x10F394, ds 0x11B0A8, reset_mask 0x0
    buffer size 1524
    RX ring with 8 entries at 0x2101400 : Rxhead 0
    00 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    02 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    03 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    04 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    05 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    06 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    07 pak=0x000000 ds=0x000000 status=7000 pak_size=0
    TX ring with 2 entries at 0x2101440: tx_count = 0, tx_head = 0, tx_tail = 0
    00 pak=0x000000 ds=0x000000 status=5C00 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7C00 pak_size=0
    0 missed datagrams, 0 overruns, 0 bad frame addresses
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 d channel collisions
    B2 Chan Info:
    Layer 1 is ACTIVATING
    idb 0x112BA8, ds 0x11B180, reset_mask 0x2
    buffer size 1524
    RX ring with 8 entries at 0x2101500 : Rxhead 0
    00 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    01 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    02 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    03 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    04 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    05 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    06 pak=0x000000 ds=0x000000 status=5000 pak_size=0
    07 pak=0x000000 ds=0x000000 status=7000 pak_size=0
    TX ring with 2 entries at 0x2101540: tx_count = 0, tx_head = 0, tx_tail = 0
    00 pak=0x000000 ds=0x000000 status=5C00 pak_size=0
    01 pak=0x000000 ds=0x000000 status=7C00 pak_size=0
    0 missed datagrams, 0 overruns, 0 bad frame addresses
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 d channel collisions
    HD unit 0, idb = 0x122390, driver structure at 0x129810
    buffer size 1524  HD unit 0, V.35 DTE cable
    cpb = 0xE4, eda = 0xD878, cda = 0xD88C
    RX ring with 16 entries at 0xE4D800
    00 bd_ptr=0xD800 pak=0x12ADE8 ds=0xE517C4 status=80 pak_size=22
    01 bd_ptr=0xD814 pak=0x12AB74 ds=0xE51108 status=80 pak_size=22
    02 bd_ptr=0xD828 pak=0x12D528 ds=0xE58384 status=80 pak_size=22
    03 bd_ptr=0xD83C pak=0x12D040 ds=0xE5760C status=80 pak_size=281
    04 bd_ptr=0xD850 pak=0x12CDCC ds=0xE56F50 status=80 pak_size=22
    05 bd_ptr=0xD864 pak=0x12CB58 ds=0xE56894 status=80 pak_size=22
    06 bd_ptr=0xD878 pak=0x12C8E4 ds=0xE561D8 status=80 pak_size=22
    07 bd_ptr=0xD88C pak=0x12C3FC ds=0xE55460 status=80 pak_size=22
    08 bd_ptr=0xD8A0 pak=0x12BF14 ds=0xE546E8 status=80 pak_size=22
    09 bd_ptr=0xD8B4 pak=0x12C188 ds=0xE54DA4 status=80 pak_size=22
    10 bd_ptr=0xD8C8 pak=0x12BCA0 ds=0xE5402C status=80 pak_size=22
    11 bd_ptr=0xD8DC pak=0x12BA2C ds=0xE53970 status=80 pak_size=22
    12 bd_ptr=0xD8F0 pak=0x12B7B8 ds=0xE532B4 status=80 pak_size=22
    13 bd_ptr=0xD904 pak=0x12B544 ds=0xE52BF8 status=80 pak_size=281
    14 bd_ptr=0xD918 pak=0x12B2D0 ds=0xE5253C status=80 pak_size=22
    15 bd_ptr=0xD92C pak=0x12D2B4 ds=0xE57CC8 status=80 pak_size=22
    16 bd_ptr=0xD940 pak=0x12B05C ds=0xE51E80 status=80 pak_size=22
    cpb = 0xE4, eda = 0xE014, cda = 0xE014
    TX ring with 4 entries at 0xE4E000
    00 bd_ptr=0xE000 pak=0x000000 ds=0xE7EAEC status=80 pak_size=287
    01 bd_ptr=0xE014 pak=0x000000 ds=0xE4D9E4 status=80 pak_size=22
    02 bd_ptr=0xE028 pak=0x000000 ds=0xE4D9E4 status=80 pak_size=22
    03 bd_ptr=0xE03C pak=0x000000 ds=0xE4D9E4 status=80 pak_size=22
    04 bd_ptr=0xE050 pak=0x000000 ds=0xE4D9E4 status=80 pak_size=22
    0 missed datagrams, 0 overruns
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 residual bit errors
    HD unit 1, idb = 0x12E914, driver structure at 0x135D90
    buffer size 1524  HD unit 1, V.35 DCE cable, clockrate 64000
    cpb = 0xE5, eda = 0xC140, cda = 0xC000
    RX ring with 16 entries at 0xE5C000
    00 bd_ptr=0xC000 pak=0x139838 ds=0xE65E0C status=80 pak_size=0
    01 bd_ptr=0xC014 pak=0x1395C4 ds=0xE65750 status=80 pak_size=0
    02 bd_ptr=0xC028 pak=0x139350 ds=0xE65094 status=80 pak_size=0
    03 bd_ptr=0xC03C pak=0x1390DC ds=0xE649D8 status=80 pak_size=0
    04 bd_ptr=0xC050 pak=0x138E68 ds=0xE6431C status=80 pak_size=0
    05 bd_ptr=0xC064 pak=0x138BF4 ds=0xE63C60 status=80 pak_size=0
    06 bd_ptr=0xC078 pak=0x138980 ds=0xE635A4 status=80 pak_size=0
    07 bd_ptr=0xC08C pak=0x13870C ds=0xE62EE8 status=80 pak_size=0
    08 bd_ptr=0xC0A0 pak=0x138498 ds=0xE6282C status=80 pak_size=0
    09 bd_ptr=0xC0B4 pak=0x138224 ds=0xE62170 status=80 pak_size=0
    10 bd_ptr=0xC0C8 pak=0x137FB0 ds=0xE61AB4 status=80 pak_size=0
    11 bd_ptr=0xC0DC pak=0x137D3C ds=0xE613F8 status=80 pak_size=0
    12 bd_ptr=0xC0F0 pak=0x137AC8 ds=0xE60D3C status=80 pak_size=0
    13 bd_ptr=0xC104 pak=0x137854 ds=0xE60680 status=80 pak_size=0
    14 bd_ptr=0xC118 pak=0x1375E0 ds=0xE5FFC4 status=80 pak_size=0
    15 bd_ptr=0xC12C pak=0x13736C ds=0xE5F908 status=80 pak_size=0
    16 bd_ptr=0xC140 pak=0x1370F8 ds=0xE5F24C status=80 pak_size=0
    cpb = 0xE5, eda = 0xC814, cda = 0xC814
    TX ring with 1 entries at 0xE5C800
    00 bd_ptr=0xC800 pak=0x000000 ds=0xE4D9E4 status=80 pak_size=22
    01 bd_ptr=0xC814 pak=0x000000 ds=0xE7F1A8 status=80 pak_size=287
    0 missed datagrams, 0 overruns
    0 bad datagram encapsulations, 0 memory errors
    0 transmitter underruns
    0 residual bit errors
    
    TMS380 unit 0: 0 Kb RAM, state 6, idb 0xFFB88, ds 0x1017C0
      current address: 0008.de7e.bdd4, burned in address: 0008.de7e.bdd4
    
      ssb_ptr 0x0, srb_ptr 0x0, arb_ptr 0x0, stb_ptr 0x0, ipb_ptr 0x0
      bia_addr 0x0, swlev_addr 0x0, address_addr 0x0, parm_addr 0x0
      mac_buff 0x0, ti_ring_speed_ptr 0x0, adapter_ram_ptr 0x0
      adapter_ram 0, ti_ring_speed 0, memory paragraphs 0
      sifsts 0x0000, sifacl 0x00EE, sifadr 0x0000, sifadrx 0x0000
      rx internal buf size 0, rx total buffers avail 0,
      rx buffers in use 0, rx frames lost 0,
    
      Last Ring Status: none
        Stats: soft: 0/0, hard: 0/0, sig loss: 0/0
               tx beacon: 0/0, wire fault 0/0, recovery: 0/0
               only station: 0/0, remote removal: 0/0
      Bridge: local 65535, bnum 0, target 16032
        max_hops 7, target idb: null
      Interface failures: 0 
      Monitor state: (active)
        flags 0x0, code 0x0, reason 0x0
        chip f/w: .........., [bridge capable]
        SMT versions: 0.00 kernel, 0.00 fastmac
        ring mode: 0
        internal functional: 00000000, group: 00000000
        if_state: 0, ints: 0/0, ghosts: 0/0, bad_states: 0/0
        ring: 1, bridge num: 0, target: 59668, max hops: 7
        last open options: (00000000)
    
    
      error log reads 0, error log failures 0
      too big packets 0, full tx buffer errors 0
      receive delimiter error 0, receive implicit errors 0
      receive explicit error 0, receive dma overrun 0
      receive buffer runout 0
        Packet counts:
          receive total:  0/0, small: 0/0, large 0/0
                  runts: 0/0, giants: 0/0
                  local: 0/0, bridged: 0/0, promis: 0/0
                bad rif: 0/0, multiframe: 0/0
          ring num mismatch 0/0, spanning violations 0
          transmit total: 0/0, small: 0/0, large 0/0
                   runts: 0/0, giants: 0/0, errors 0/0
                  bad fs: 0/0, bad ac: 0/0
               congested: 0/0, not present: 0/0
        Unexpected interrupts: 0/0,  last unexp. int: 0
    
        Internal controller counts:
          line errors: 0/0,  internal errors: 0/0
          burst errors: 0/0,  ari/fci errors: 0/0
          abort errors: 0/0, lost frame: 0/0
          copy errors: 0/0, rcvr congestion: 0/0
          token errors: 0/0, frequency errors: 0/0
          dma bus errors: -/-, dma parity errors: -/-
          adapter checks 0, info from last adapter check: 
          status 0x0, parm0 0x0, parm1 0x0, parm2 0x0, intval 0x0
        Internal controller smt state:
          Adapter MAC:     0000.0000.0000, Physical drop:     00000000
          NAUN Address:    0000.0000.0000, NAUN drop:         00000000
          Last source:     0000.0000.0000, Last poll:         0000.0000.0000
          Last MVID:       0000,           Last attn code:    0000
          Txmit priority:  0000,           Auth Class:        0000
          Monitor Error:   0000,           Interface Errors:  0000
          Correlator:      0000,           Soft Error Timer:  0000
          Local Ring:      0000,           Ring Status:       0000
          Beacon rcv type: 0000,           Beacon txmit type: 0000
          Beacon type:     0000,           Beacon NAUN:       0000.0000.0000
          Beacon drop:     0000,           Reserved:          0000
          Reserved2:       0000
     
    Certifications: None.... yet
    WIP: CCNA
  13. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    The serial interfaces on his routers are fixed, at least so I am aware. I could always be wrong...I haven't cracked open a 2500 series router in a long time to see if you can remove the ports from the system board.
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall
  14. Headache

    Headache Gigabyte Poster

    1,092
    9
    85
    Hi Surfer,

    Sorry, I've never worked on a 2500 series before. Is it true the ports are fixed like NetEyeBall says ?

    Anyway if you're still checking for a physical problem, then one way I would do this is to remove one of the good routers from your pod and just test connectivity exclusively between the remaining good one and the bad one. It just makes things more convenient is all. I'll suggest you use one single cable between the two routers, moving it back and forth, from port to port. And while you're doing that make sure you're consoled into the bad router. Every time you move the cable, you do show controllers to check whether the router can tell the difference between being connected and not being connected. If it can tell the difference, then it's probably not a physical problem.

    The only other thing I can suggest is to try one of the routing protocols.I don't know if rip is up to the job, but whichever one you chose, maybe the sh and debug commands can tell you something.

    The show controllers output you posted are a bit tough to figure out. I couldn't tell where one interface began and where the other one left off. When I do the same command on one of my routers, it looks something like this:

    sh controllers
    Interface FastEthernet0/0
    Hardware is AMD Am79c971
    ADDR: 815756DC, FASTSEND: 8002C5C4, MCI_INDEX: 0
    DIST ROUTE ENABLED: 0
    Route Cache Flag: 0
    LADRF=0x0000 0x0100 0x0000 0x0000
    CSR0 =0x00000004, CSR3 =0x00001044, CSR4 =0x00004915, CSR15 =0x00000180
    CSR80 =0x00009900, CSR114=0x00000000, CRDA =0x01B176E0, CXDA =0x01B17B20
    BCR9 =0x00000000

    ..............OMITTED............................

    Interface Serial0/0
    Hardware is PowerQUICC MPC860
    DTE V.11 (X.21) clocks stopped.
    idb at 0x8157B598, driver data structure at 0x815819A4
    SCC Registers:
    General [GSMR]=0x2:0x00000000, Protocol-specific [PSMR]=0x8
    Events [SCCE]=0x0000, Mask [SCCM]=0x0000, Status [SCCS]=0x00

    ............OMITTED..............................

    Interface Serial0/1
    Hardware is PowerQUICC MPC860
    DTE V.11 (X.21) clocks stopped.
    idb at 0x81583184, driver data structure at 0x81589590
    SCC Registers:
    General [GSMR]=0x2:0x00000000, Protocol-specific [PSMR]=0x8
    Events [SCCE]=0x0000, Mask [SCCM]=0x0000, Status [SCCS]=0x00
     
    Certifications: CCNA
    WIP: CCNP
  15. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Well, i don't even know which router is the good one or the bad one now... just did a test between the two routers that i thought were working (james and matt) - here are the results:

    Code:
    Clocking	Receiving	Works?
    
    James Se 0	Matt  Se 0	NO
    James Se 0	Matt  Se 1	NO
    James Se 1	Matt  Se 0	NO
    James Se 1	Matt  Se 1	NO
    Matt  Se 0	James Se 0	YES
    Matt  Se 0	James Se 1	NO
    Matt  Se 1	James Se 0	YES
    Matt  Se 1	James Se 1	NO
    By receiving i mean the device is receiving the clocking.

    I've also been getting alot of errors like this:

    Code:
    00:33:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:33:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:33:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:33:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:34:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:34:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:34:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:34:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:35:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:35:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:35:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:35:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:36:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:36:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:36:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:36:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:37:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:37:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:37:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:37:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:38:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:38:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    00:38:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    00:38:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
    when the devices aren't working. I might research that for a bit, then compare the differences of show ip interface serial 0 / serial 1 on james, to see why serial 0 can be 'clocked' but not serial 1.

    Thanks :(
     
    Certifications: None.... yet
    WIP: CCNA
  16. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Well i'm pretty stumped for the time being. I've done what you said though by making things alot simpler.

    I'm just using 2 routers, and i'm using 1 link that doesn't work to see if i can diagnose the problem. Here are the configs i'm using for the routers:

    Code:
    matt # sh ru
    Building configuration...
    
    Current configuration : 632 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname matt
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    !
    prompt %h%s%p%s
    !
    !
    !
    interface Ethernet0
     no ip address
     shutdown
    !
    interface Serial0
     ip address 192.168.0.249 255.255.255.252
     clockrate 64000
    !
    interface Serial1
     no ip address
     shutdown
    !
    interface BRI0
     no ip address
     shutdown
    !
    no ip http server
    ip classless
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    
    james # sh ru
    Building configuration...
    
    Current configuration:
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname james
    !
    enable password cisco
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    prompt %h%s%p%s
    !
    !
    !
    interface Serial0
     no ip address
     shutdown
     no fair-queue
    !
    interface Serial1
     ip address 192.168.0.250 255.255.255.252
    !
    interface TokenRing0
     no ip address
     shutdown
    !
    interface BRI0
     no ip address
     shutdown
    !
    ip classless
    no ip http server
    !
    !
    line con 0
     transport input none
     line aux 0
    line vty 0 4
     login
    !
    end
    So that's matt se0 to james se1.

    The output of show interfaces on each on is:

    Code:
    [b]matt # sh int se 0[/b]
    Serial0 is up, line protocol is down 
      Hardware is HD64570
      Description: link to charlie
      Internet address is 192.168.0.249/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set
      Keepalive set (10 sec)
      Last input 00:56:28, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
         Conversations  0/3/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1158 kilobits/sec
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         246 packets input, 20356 bytes, 0 no buffer
         Received 198 broadcasts, 0 runts, 0 giants, 0 throttles
         97 input errors, 1 CRC, 0 frame, 0 overrun, 6 ignored, 1 abort
         573 packets output, 24139 bytes, 0 underruns
         0 output errors, 0 collisions, 263 interface resets
         0 output buffer failures, 0 output buffers swapped out
         444 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    The '97 input errors' sounds interesting...

    and

    Code:
    james # sh int se 1
    Serial1 is up, line protocol is up 
      Hardware is HD64570
      Description: link to charlie
      Internet address is 192.168.0.250/30
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation HDLC, loopback not set
      Keepalive set (10 sec)
      Last input 00:00:00, output 00:00:06, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
         Conversations  0/1/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         397 packets input, 11906 bytes, 0 no buffer
         Received 396 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         553 packets output, 36336 bytes, 0 underruns
         0 output errors, 0 collisions, 495 interface resets
         0 output buffer failures, 0 output buffers swapped out
         312 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    If anyone can shine a small amount of light onto this it'd be greatly appreciated. But, if in your opinion these routers are fudged, then also let me know 8)

    Thanks...


    EDIT: Just noticed that when i switch off 'james', matt will notice and change se 0 to down and down - so there must be some sort of comunication going on!
     
    Certifications: None.... yet
    WIP: CCNA
  17. Headache

    Headache Gigabyte Poster

    1,092
    9
    85
    EDIT: Sorry, I posted this before I saw your last post. Maybe this post no longer applies so just ignore it. Damn ! That diagram doesn't look anything like the way I drew it either !
    -------------------------------------------------------------------------------------------------------------------------
    I'm only guessing here, but if you're unable to clock serial 1 then it's probably because that port is connected to the dte end of the cable. You can't clock it.

    When you connect the dte end of any cable to any serial port, the interface that that port belongs to immediately becomes a dte port. When you swop the cable around and plug in the dce end, then that port immediately becomes a dce. You don't clock dte interfaces, only dce interfaces.

    Sometimes the connectors on your cables are labeled DTE on one end and DCE on the other. In such cases it's easy to see what end you are plugging in. Some cables are however unlabelled and the only way to find out what end of the cable you're plugging in is to check sh controllers.

    Maybe you already know this, in which case just ignore me.

    But if you don't, then I suggest you sort out your cabling first and foremost.

    Try the following topology:

    Router1 Router 2 Router 3
    O.............................. O .................................O
    S0 S0 S1 S0
    DTE DCE DTE DCE

    Clock all the dce interfaces at 64000 and then test.

    And while you're at it, check the bandwidth on all your serial interfaces and make sure they're up to scratch. I think the default is 1544 kbit which works okay for me.

    Let us know how it turns out.
     
    Certifications: CCNA
    WIP: CCNP
  18. Headache

    Headache Gigabyte Poster

    1,092
    9
    85
    Just ignore the last post, since it now seems that this is more of a datalink layer problem.

    The 97 errors thing, I don't know what the heck that means !

    I'm clutching at straws here, but maybe you can try debugging with one of the protocols, like rip, for example.

    Boy this is a toughie !
     
    Certifications: CCNA
    WIP: CCNP
  19. surfer_rosa

    surfer_rosa Nibble Poster

    55
    0
    28
    Yeah! And to think i downloaded boson netsim and made a perfect replica of my initial network without any errors in about 10 minutes...

    To be honest i'd feel a bit cocky configuring rip when the basic configuration isn't even working! But i'll give it a go and see what i can come up with.

    Cheers.
     
    Certifications: None.... yet
    WIP: CCNA
  20. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    Configuring a dynamic routing protocol won't fix your issue. Sorry to say. You should have connectivity since they are all directly connected. Directly connected interfaces can talk to each other since they are aware that they exist without need of a routing protocol.

    But you can configure rip if you want...:)
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.