1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Microsoft Virtual PC won't run

Discussion in 'Virtual Computing' started by jo74, Sep 28, 2009.

  1. jo74

    jo74 Byte Poster

    238
    0
    19
    I clicked Start | Programs | Microsoft Virtual PC and the 'splash screen' appears.

    But then all that 'happens' is that Virtual PC console is on the taskbar but when I click it, it disappears altogether!
     
    Certifications: A+, N+, Sec+
    WIP: CCENT, CCNA
  2. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    have you added a machine yet?
     
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  3. jo74

    jo74 Byte Poster

    238
    0
    19
    Er, yes :biggrin

    Two actually, both running XP.
     
    Certifications: A+, N+, Sec+
    WIP: CCENT, CCNA
  4. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    ok well if you can provide us with some information rather trying to guess what is going on, we may be able to help.

    Host operating system
    Edition of software
    User account being used
    software and anti-virus installed
    errors
    what's changed (if anything)
    screen captures....
     
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  5. jo74

    jo74 Byte Poster

    238
    0
    19
    I'm running Windows Vista
    Home premium edition
    I'm logged in as the Adminstrator
    I've got McAffee anti-virus installed
    As for the rest, see my first post.
     
    Certifications: A+, N+, Sec+
    WIP: CCENT, CCNA
  6. pete.grant

    pete.grant Byte Poster

    150
    9
    37
    Have you checked that it's not just opening in your Notification Area?
     
    Certifications: A+ IT Technician, CCENT, CEH, CPTS, CIW Security Analyst, ITIL v3 Foundation, Master CIW Administrator, MCITP (Windows Server 2008:SA), MCSA on Windows Server 2008, MCSA:Security on Windows Server 2003, MCTS (70-648, 70-652), Network+, SCNS, Security+, Server+
  7. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    try reinstalling it
     
  8. GiddyG

    GiddyG Terabyte Poster Gold Member

    2,471
    42
    140
    I take it the video settings wouldn't be causing the issue? I've seen that sort of thing when attempting to run games in the dim and distant past.
     
  9. jo74

    jo74 Byte Poster

    238
    0
    19
    Certifications: A+, N+, Sec+
    WIP: CCENT, CCNA
  10. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    where's the answer?
     
  11. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    You need to google the title of the article then click on the link. If you click on the link in this thread it doesnt display the answers.

    Think its to get folk to sign up or whatever.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  12. Shinigami

    Shinigami Megabyte Poster

    896
    40
    84
    So basically his Virtual PC window appeared off screen... what an interesting bug. Wonder if one could right click the window in the task bar, select move, and then press an arrow key on the keyboard to center the window on the main screen after moving the mouse around a bit, and when reopening the window, keeps it in the same position from thereon rather than editing the XML file.
     
    Certifications: MCSE, MCITP, MCDST, MOS, CIW, Comptia
    WIP: Win7/Lync2010/MCM
  13. jo74

    jo74 Byte Poster

    238
    0
    19
    Oh yeah, that's a bit weird.

    Well here's what it said and it worked :D

    'I also had this happen, the solution is as follows. There are a number of settings for Virtual PC that are stored in our 'Options.XML' file. You can have a look in this file by running 'notepad %appdata%\Microsoft\Virtual PC\Options.xml'.
    it looks like this:-

    <window>
    <console>
    <height type="integer">626</height>
    <left_position type="integer">821</left_position>
    <top_position type="integer">173</top_position>
    <visible type="boolean">true</visible>
    <width type="integer">359</width>
    </console>
    <new_pc>
    <left_position type="integer">429</left_position>
    <top_position type="integer">61</top_position>
    </new_pc>
    <virtual_disk_wizard>
    <left_position type="integer">429</left_position>
    <top_position type="integer">148</top_position>
    </virtual_disk_wizard>
    </window>

    Sometimes the settings for the window position seem to get corrupted and huge values get put in them especially left_position and right_position. if these have got huge numbers in them the window appears off the screen. Change the values and put in a value of 20 or similar.

    Alternativley, just delete the file and it will be recreated with sensible values'
    from:
    http://www.experts-exchange.com/Software/Misc/Q_22593764.html

    When I ran this command, there was a huge number after left position under height type
     
    Certifications: A+, N+, Sec+
    WIP: CCENT, CCNA

Share This Page

Loading...