1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Laptop Screen Problem

Discussion in 'Hardware' started by mojorisin, Mar 28, 2007.

  1. mojorisin

    mojorisin Kilobyte Poster

    395
    14
    41
    Hi Guys

    Got a problem with a laptop screen the laptop is made by Mitac and is a 8575A model

    the problem is concerning the lcd screen when i power the unit on the screen just goes bright white and wont display anything although you can turn the brightness up and down

    Also the external screen works fine when i plug a monitor in

    The chipset in this laptop is based around the SIS650 chipset

    I have read on various website searches that this can be the board sending a signal to the screen and overpowering the screen and making everything white

    I know that the screen and the cables work as i have another laptop the same and i have tried it with the screen and cables and get the same result

    Could this be more to do with the board ?

    Anyone had this problem before ?
     
    WIP: 70-685 http://www.speedtest.net/result/3377759783.png
  2. simongrahamuk
    Honorary Member

    simongrahamuk Hmmmmmmm?

    6,199
    125
    199
    Did you try that other laptops screen on your laptop? What was the outcome?
     
  3. mojorisin

    mojorisin Kilobyte Poster

    395
    14
    41
    Yes tried both screens and cables on faulty laptop and on good laptop and the screens where fine

    So the problem seems to be something on the board of the faulty one but seeing as the graphics are built in then i cant replace the faulty part

    I have seen elsewhere something about voltage causing this on the board not sure if it can be reset though as the screen does get a signal from the laptop just overdoes the power to each pixel as i understand it
     
    WIP: 70-685 http://www.speedtest.net/result/3377759783.png
  4. arionstar35

    arionstar35 New Member

    1
    0
    1
    hi there, i am new to this site. if the laptop is working with your other screen the the problem is not the motherboard but has to be something with in the lcd lid backlight, inverter. since the screen is with then the back light is working and it has to be the inverter.
     
  5. wizard

    wizard Petabyte Poster

    5,763
    35
    174
    Welcome to CF, however this thread is over 6 months old, so I would have thought this issue would have been resolved by now 8)
     
    Certifications: SIA DS Licence
    WIP: A+ 2009
  6. derkit

    derkit Gigabyte Poster

    1,479
    54
    112
    Good shout wizard - I hadn't noticed that at all.... I wonder sometimes how these people got on with their problems.....

    Welcome arionstar35 - enthuasiasm like that will go far here :)
    Come join us more!
     
    Certifications: MBCS, BSc(Hons), Cert(Maths), A+, Net+, MCDST, ITIL-F v3, MCSA
    WIP: 70-293
  7. vjhalai

    vjhalai Banned

    1
    0
    0
    It seems as though there may be a fault on your motherboard. I have found a company who repair laptop motherboards and if they cant fix it they wont charge you a penny, so there is nothing to lose. I have provided a link to there site below.

    Linked removed
     

Share This Page

Loading...