1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Laptop hard drive recognized by disabling SATA in BIOS

Discussion in 'Hardware' started by Professor-Falken, Aug 20, 2008.

  1. Professor-Falken

    Professor-Falken Kilobyte Poster

    393
    2
    37
    I disabled SATA native support and Windows setup found the hard drive, was given this advice from HP Tech and it worked. Even though they agreed that installing SATA driver would also fix the problem.

    Does anyone know why it worked?

    Thanks for your help
     
    Certifications: Comptia A+
    WIP: Comptia Network +
  2. wagnerk
    Highly Decorated Member Award

    wagnerk aka kitkatninja Moderator

    10,831
    357
    341
    I believe by disabling native SATA support in the bios, that kicks in IDE emulation. That's why Windows can pick up the Sata HDD. One thing to note when native SATA support is disabled... performance is slightly reduced.

    -Ken
     
    Certifications: CITP, PGCert, BSc, HNC, LCGI, PTLLS, MCT, MCITP, MCTS, MCSE, MCSA:M, MCSA, MCDST, MCP, MTA, MCAS, MOS (Master), A+, N+, S+, ACA, VCA, etc... & 2nd Degree Black Belt
    WIP: PGDip
  3. fortch

    fortch Kilobyte Poster

    408
    21
    35
    Happens all the time on our Dell/Lenovo laptops -- if you don't have the Intel Matrix SATA driver to load ahead of time, you need to disable AHCI before pushing Vista onto platters.
     
    Certifications: A+,Net+,Sec+,MCSA:Sec,MCSE:Sec,mASE

Share This Page

Loading...