1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IP Address Allocation

Discussion in 'Routing & Switching' started by dewdneys, May 30, 2008.

  1. dewdneys

    dewdneys Bit Poster

    13
    0
    2
    Hi folks

    I have a Cisco 877W running a small home network and sharing a single ADSL connection to the outside world.

    it's been working fine for months now allocating IP addresses from a small DHCP pool (192.168.0.2-192.168.0.6) to two laptops and a wireless printer. Both laptops and printer still work fine.

    problem is a new PC we've got...connects to the router ok, but fails to get allocated an IP address from the DHCP pool. Windows Vista reports connected with limited access (169.254.50.236, 255.255.0.0 - auto assigned). Network is set to obtain IP address automatically (same settings as laptop also running Vista).

    Used SDM manager to check wireless properties:
    Interfaces & Connections:Dot11Radio0:Edit Interface:Edit:Launch Wireless Application​
    Wireless assocation (from menu on left): MAC address of PC shown with IP 0.0.0.0 State associated​

    If click on MAC address get screen with a load of stats and a deauthenticate button at the bottom, clicking this closes the connection on the PC, which then auto-reconnects (still not allocated an IP!)

    Suggestions please

    many thanks
    Simon
     
  2. MacAllan

    MacAllan Byte Poster

    249
    6
    30
    Sorry if I'm being dim: is the new PC connecting via wireless or wired connection?
    When you say it connects to the router okay, what exactly do you mean?
    Forget SDM, let's get down and dirty with the CLI... Post an anonymised config if possible.
     
    Certifications: A+, N+, CCNA
    WIP: CCNP, Linux+
  3. dewdneys

    dewdneys Bit Poster

    13
    0
    2
    PC connecting to router wirelessly.

    On PC, in Network & Sharing Centre, can see various wireless networks; including my network.
    Selecting my network, PC connects to router.
    What doesn't happen is the auto-allocation of IP address from the router's DHCP service.

    Out of interest, if I set the IP address manually, rather than telling to get automatically, PC is on network, router NAT works and get access to internet as anticipated.

    Problem/what i don't get, is why auto allocation of IP address is failing when it works fine on 2 other laptops!

    cheers
    Simoin
     
  4. dewdneys

    dewdneys Bit Poster

    13
    0
    2
    ...sorry, here's the config [file attached]

    btw - how do I transfer a file from the flash memory to my PC? Gave up in CLI and used SDM! :oops:
     

    Attached Files:

  5. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    dewdnys,

    The problem is possibly due to the use of the dhcp broadcast flag in the dhcp discovery packet by Vista. XP does not set the broadcast flag when requesting an address, and Vista apparently does. Because of this the Vista computer is likely not accepting the offer from the router. If you want to confirm this, load wireshark and capture the dhcp packets, or run debug dhcp on the router.

    To correct it edit the registry.

    Here is the MS article:

    http://support.microsoft.com/kb/928233/en-us

    Essentially the broadcast flag tells the dhcp server to respond to the client using a broadcast, instead of unicast response.



    Also, if you can, use wpa instead of wep - much better for your wireless.

    To copy the config from the cli just do a show run and save it to your terminal program's buffer. Then copy it to a file on your pc. Or, tftp the config from your router to your pc.

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  6. dewdneys

    dewdneys Bit Poster

    13
    0
    2
    Good call Spice_Weasel - the support bulletin contained the info to fix Vista.

    Had to do the bit at the end where set registry value according to non-microsoft DHCP server NOT supporting DHCP Broadcast flag. Guess microsoft don't expect quiet networks!

    Weirdly the two laptops that connect fine and used the router DHCP server already had the DhcpConnForceBroadcastFlag value set to 1, setting this to 0 on the desktop enabled it to connect and get an ipaddress. c'est la vie!

    Will try the WPA setting when have some time.

    thanks again
    Simon
     

Share This Page

Loading...