1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet on Cisco ADSL 837 Router

Discussion in 'Routing & Switching' started by sheraz9212, Oct 31, 2010.

  1. sheraz9212

    sheraz9212 New Member

    2
    0
    1
    Hi,

    I have configured my Cisco ADSL 837 router for PPPoA. I am able to ping both inside and outside the network, even using the FQDN like www.google.com etc and IP address as well. I am also able to telnet one of my remote Cisco router in other city using IP address, But i am not able to access internet. My router is using the Static IP address with Static DNS as well. The ISP has assigned me Default Gateway as well but I have not configured it on Cisco router.

    can anybody please guide me how i can access internet and if i am amking any mistake please let me know how i can solve it.


    Thanks
     
  2. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    8,871
    167
    256
    I am not a Cisco person but that Default Gateway omission, doesn't seem logical :rolleyes:
     
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  3. sheraz9212

    sheraz9212 New Member

    2
    0
    1
    I am posting my running configuration for you people. Please let me know if i am making any mistake in configuration. Thanks

    ______________________________________________
    ADSL#show running-config
    Building configuration...

    Current configuration : 2140 bytes
    !
    version 12.3
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    no service password-encryption
    !
    hostname ADSL
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$PSFw$4.cNjo.aGa/ftNxfEOW3o.
    !
    no aaa new-model
    !
    resource policy
    !
    ip subnet-zero
    --More--

    !no ip dhcp use vrf connected
    ip tcp synwait-time 10
    ip cef
    ip domain name lccmsltd.org.uk
    ip name-server 195.8.69.7
    ip name-server 195.8.69.12
    no ip ips deny-action ips-interface
    !
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    ip tcp adjust-mss 1452
    hold-queue 100 out
    !
    interface Ethernet2
    no ip address
    shutdown
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    ip mtu 1452
    ip nat outside
    ip virtual-reassembly
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface ATM0.1 point-to-point
    shutdown
    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    interface Dialer0
    ip address 213.253.42.112 255.255.255.0
    ip mtu 1492
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname username@adsl-2.uk.clara.net
    ppp chap password 0 password
    ppp pap sent-username username@adsl-2.uk.clara.net password 0 password
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    ip nat inside source list 1 interface Dialer0 overload
    !
    !
    ip access-list standard Lccms
    permit 10.0.0.0 0.0.0.255
    !
    control-plane
    !
    !
    line con 0
    password cisco
    login
    no modem enable
    line aux 0
    password cisco
    login
    line vty 0 4
    password cico
    login
    !
    scheduler max-task-time 5000
    end

    ADSL#
    ____________________________________________________
     
  4. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    The problem is that your inside hosts are not being nat'ed. You have ip nat inside and outside staements on the correct interfaces, and a suitable nat rule:

    ip nat inside source list 1 interface Dialer0 overload

    - but you have no access-list 1 which selects what traffic should be nat'ed. Try adding:

    access-list 1 permit 10.0.0.0 0.0.0.255 any

    You should also add a dialer-list:

    dialer-list 1 protocol ip permit

    As well, you should be careful when posting configs, you have listed your password and ip address. I would immediately change the password! Also, you can improve the security of the router, e.g. ios firewall and an external access-list, and other things.

    Spice_Weasel
     
    Last edited: Nov 1, 2010
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE

Share This Page

Loading...