1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing virtualbox for a newbie

Discussion in 'Linux / Unix Discussion' started by twizzle, Dec 4, 2011.

  1. twizzle

    twizzle Gigabyte Poster

    1,838
    33
    104
    Guys, i'm running Virtualbox on Win7 and teh guest OS is Unbuntu 8.04. As an experiment i'm also trying to install Virtual box within this os. I've started terminal and done

    sudo apt-get update
    sudo apt-get install virtualbox-4.1

    however all i get is couldnt find package virtualbox-4.1

    I've tried it with earlier versions as well and get same message. What have i missed? I'm looking at Virtualbox downloads website and thats all it shows to get it. It does suggest sudo apt-get install dkms which i've also done but no luck. Need a Linux guru to suggest why it cant find teh package.
     
    Last edited: Dec 4, 2011
    Certifications: Comptia A+, N+, MS 70-271, 70-272
    WIP: Being a BILB,
  2. twizzle

    twizzle Gigabyte Poster

    1,838
    33
    104
    OK i can get
    sudo apt-get install virtualbox

    to work so its something to do with teh version i want to install?
     
    Certifications: Comptia A+, N+, MS 70-271, 70-272
    WIP: Being a BILB,
  3. dales

    dales Gigabyte Poster

    1,998
    46
    97
    Have you added the repositories to the ubuntu install? You could also just download the packages directly from the website.

    I dont think you'll be able to run any vm's on the ubuntu virtualbox though depends if it passes the intel-VT instruction set through or not.
     
    Certifications: vExpert 2014+2015+2016,VCP-DT,CCE-V, CCE-AD, CCP-AD, CCEE, CCAA XenApp, CCA Netscaler, XenApp 6.5, XenDesktop 5 & Xenserver 6,VCP3+5,VTSP,MCSA MCDST MCP A+ ITIL F
    WIP: Nothing
  4. keconnect sparky

    keconnect sparky Nibble Poster

    78
    5
    34
    Certifications: MCP, CCENT, CCNA, CCNA-S
    WIP: CCNP (ROUTE)
  5. twizzle

    twizzle Gigabyte Poster

    1,838
    33
    104
    Dales, when you say added teh repositories is that this bit?

    deb Index of /virtualbox/debian/ hardy contrib non-free

    or sudo apt-get update?

    I've done teh latter but not the former as that says from version 4 onwards and i cant even get version 3 to work. Only install of Virtualbox that installed for me was sudo apt-get install virtualbox (which is ver 1)
     
    Certifications: Comptia A+, N+, MS 70-271, 70-272
    WIP: Being a BILB,
  6. BB88

    BB88 Kilobyte Poster Gold Member

    370
    11
    76
    8.04 is no longer supported by the repositories, you would have to manually install all the packages from .deb or extract and install from .tar

    10.04 is the earlier supported version.

    Ubuntu (operating system) - Wikipedia, the free encyclopedia

    I would guess that is why you cannot install above 1.0.

    You could try sudo apt-get install virtualbox-ose
     
    Certifications: AS Computing, A+, Network+, 70-680, 70-410
    WIP: MCSA: Server 2012

Share This Page

Loading...