1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing php for IIS

Discussion in 'Web Development & Web Hosting' started by Fergal1982, Sep 18, 2007.

  1. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    Ok, Im trying to set up PHP for IIS, and am having some problems.

    I've extracted the php files into c:\php, set the IIS execute permissions to Scripts and Executeables, added the .php extension into the mappings (pointing to c:\php\php.exe), and added index.php and default.php to the document tab.

    However, Ive added a simple index.php file to a folder called phptest in inetpub\wwwroot and ensured that its active as a site (I had to go into IIS and hit 'create' to set it as a website). Now when I try to run the php app, Im getting an error on the page stating:

    'HTTP 401.3 - Access denied by ACL on resource'

    The IIS page is set for anonymous login, using the standard IIS username and password (automatically populated).

    Im thinking that Im going to need to set the IIS user with access to the c:\php directory to allow it to work. But I also think that thats wrong, since the IIS service should be running as system, and should have access already.

    Can anyone point me in the right direction?

    Thanks
    Fergal
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  2. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    actually, scratch that. Work have decided that its not important for now, so ill leave it for here.

    May well take a look at home, so if i get the same issue ill repost.

    cheers.
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  3. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    It looks like a file permissions problem.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  4. jodsclass

    jodsclass Byte Poster

    170
    3
    39
    Had a similar problem to this in my last job. Have you added the .PHP extension to the extensions allowed for this site in IIS? Also make sure that you point the extension at the correct dll

    I'll try and tell you more when I get back onto my server 2003 box.

    Also, there is a very good php auto installer Here which i often use for installing PHP on IIS
     
    Certifications: BSc IT & Web Development
    WIP: MSc Advanced Computing, Oracle Cert
  5. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    i did do, yes. but its not too important at the moment, since work arent concerned any more. ill come back if i have problems setting it up at home.

    cheers
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present

Share This Page

Loading...