1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IIS SSL Tip

Discussion in 'Network Infrastructure' started by craigie, Feb 22, 2009.

  1. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    I was configuring auto enrolment for both all my servers, clients and users earlier today.

    All was going well until for some reason on Server03, my SSL stopped working for my OWA and Public Folders. So I checked all my settings, they looked correct and it was working on Server04 (second Exchange sever).

    So I thought perhaps it could be a corrupt certificate, so I revoked it and re applied a new one for Web Server, and again it didnt work.

    Next I checked all of the IIS settings, stopped and started the Exchange Information Store and HTTP SSL Services, and IIS website, still nothing.

    The strange thing was everything else was working all my auto enrolments and certificates for:

    VPN Server
    Users
    Exchange
    Print
    Certificate Server
    Computers

    So I revoked every certificate and started from scrath, same thing again everything was working except HTTP SSL on Server03. But if I removed SSL Authentication it worked fine no problemo.

    So I checked every setting against Server04 and both where exactly correct and then I noticed something odd and this is a goldie, thank you Microsoft.

    Even though in my Exchange Website when you checked out the Web Site, it stated TCP Port 80 SSL ort 443 which is correct, the 443 had dropped out of the Web Sites Folders where it says your Web Site Name, Running, IP Address etc, SSL Port was blank even though it was in the config.

    So a quick delete of the SSL number from the Web Sites Properites and entered in 443 and bam it was working again.

    Craigie's top tip for IIS HTTP SSL, check that the SSL Port number is displayed in both the Properties and the Web Sites Folder!

    I want the two hours of my life back figuring this out, :cussing Microsoft!
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  2. dalsoth

    dalsoth Kilobyte Poster

    325
    14
    54
    Your two hours means i don't have to lose two of mine in future too, cheers :p
     
    Certifications: MCSE, MCP, MCDST, MCSA, ITIL v3
    WIP: MCITP EA
  3. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    Haha, no worries, the wierd thing was it just dropped off and I changed the authentication about 5 x and it didn't come back. I had to manually delete the number and close the Properties, re-open Properties and manually type the number 443 and it worked.
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5

Share This Page

Loading...