1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IIS asking for credentials?

Discussion in 'Windows Server 2003 / 2008 / 2012 Exams' started by Kraven, Feb 21, 2007.

  1. Kraven

    Kraven Kilobyte Poster

    297
    3
    49
    Hey, Basically I've got test website running on my server. When I go into IIS Manager and right click on my website and click browse, it asks me for my credentials. Why is this happening?

    (EDIT) Doesn't matter, I fixed it by using "All Unassigned" in the IP Address properties. Hmm however when I go on internet explorer and type in testwebsite.com, this asks me for my credentials. If I put them in it loads my website. Does anyone know how to stop it asking for creds?


    Thanks
    Kraven
     
    Certifications: Network+, MCSA, 70-680
    WIP: A+, 70-685
  2. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    I could be wrong on this but..

    Go into IIS and right-click on your website, select properties.
    Select the Directory Security Tab and click 'Edit'. Then ensure that 'anonymous access' is ticked. The username and password field should already be filled in. Ensure that 'Allow IIS to control password' is ticked.

    Set these changes and try reloading the site. should resolve the issue
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  3. Kraven

    Kraven Kilobyte Poster

    297
    3
    49
    Where is the 'Allow IIS to control password' option located as I can't find it.

    Thanks
    Kraven
     
    Certifications: Network+, MCSA, 70-680
    WIP: A+, 70-685
  4. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    should be directly under the fields for username and password fields in the Edit window.
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  5. Kraven

    Kraven Kilobyte Poster

    297
    3
    49
    Nah it isnt, this is a similar pic to my window.

    [​IMG]

    But says Server1 instead of PC150.

    Thanks
    Kraven
     
    Certifications: Network+, MCSA, 70-680
    WIP: A+, 70-685
  6. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    interesting. could just be a feature in a newer version of IIS. I wouldnt worry too much about it. Is it working with these settings? or were they already set?
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  7. Kraven

    Kraven Kilobyte Poster

    297
    3
    49
    Nah it still asks for creds when I attempt to open the site up in Internet Explorer.

    Thanks
    Kraven
     
    Certifications: Network+, MCSA, 70-680
    WIP: A+, 70-685
  8. wagnerk
    Highly Decorated Member Award

    wagnerk aka kitkatninja Moderator

    10,831
    357
    341
    It could be that the password stored in that windows (Auth Methods) is different from what it actually is. Change the password of IUSR_Server1 in User accounts (AD Users & Computer or the local User Accounts - SAM, depending on where the account is) then type in the new password into the Password textbox of the "Authentication Methods" box.

    -Ken
     
    Certifications: CITP, PGCert, BSc, HNC, LCGI, PTLLS, MCT, MCITP, MCTS, MCSE, MCSA:M, MCSA, MCDST, MCP, MTA, MCAS, MOS (Master), A+, N+, S+, ACA, VCA, etc... & 2nd Degree Black Belt
    WIP: PGDip
  9. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    the IIS password isnt actually stored in AD. its located in the local users area on the machine, its possible that you might need to reset it but i doubt it since its created by IIS at install, and provided you dont actually change the password, IIS should know what it is.

    Beyond this, or something written into the code, im at a loss im afraid.
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  10. Kraven

    Kraven Kilobyte Poster

    297
    3
    49
    It's ok guys thanks for your help, Ill ask the network admin I work with tomorrow as he uses IIS.
     
    Certifications: Network+, MCSA, 70-680
    WIP: A+, 70-685
  11. wagnerk
    Highly Decorated Member Award

    wagnerk aka kitkatninja Moderator

    10,831
    357
    341
    The default username & password is a local user, however that doesn't mean that you have to use that name, it is possible to use a domain account, provided that it has the same access rights as the default IIS account, that should work in the same way.

    Another reason why the default IIS account may not work maybe because the "password never expires" option is un-ticked.

    There maybe 101 reasons why it doesn't work - you have the right idea and ask the Network admin when you see him as he should know why - as you said he works with your set-up there.

    -ken
     
    Certifications: CITP, PGCert, BSc, HNC, LCGI, PTLLS, MCT, MCITP, MCTS, MCSE, MCSA:M, MCSA, MCDST, MCP, MTA, MCAS, MOS (Master), A+, N+, S+, ACA, VCA, etc... & 2nd Degree Black Belt
    WIP: PGDip
  12. Kraven

    Kraven Kilobyte Poster

    297
    3
    49
    I sorted it out :)
    In Internet Explorer - Tools - Internet Options - Security Tab, Then on the internet custom level I changed the User Authentication to "Automatic logon with current user name and password". And this allowed me to access my website without having to insert credentials.

    Kraven
     
    Certifications: Network+, MCSA, 70-680
    WIP: A+, 70-685

Share This Page

Loading...