1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ICS, Pain in the ****

Discussion in 'Networks' started by Nelix, Jul 4, 2003.

  1. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    I have just had to reinstall my server, stupid me did not have a virus scanner on it.

    The problem i now have is that i can't get ICS working again, it worked fine before but now it just does not want to play, heres the set up


    The cable modem is connected via USB to the server
    The NIC in the server is set to 192.168.0.1
    DHCP is not install
    The Cable modem is shared
    All the other machines are set to obtain IP's Automatically

    Everything seems to be set up properly, but i must be missing something, can anyone see what?

    :bluegrab
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  2. Phil
    Honorary Member

    Phil Gigabyte Poster

    1,680
    7
    87
    Hi Nelix,

    I can't think of anything else you need to do off the top of my head. Have you tried the obvious, done ipconfig /all to see whether the other machines have picked up an ip address, can they ping the server? Try setting the ip addresses on the other PC's manually, I know the books say use DHCP on the workstations but this has worked for me in the past.

    Phil
     
    Certifications: MCSE:M & S MCSA:M CCNA CNA
    WIP: 2003 Upgrade, CCNA Upgrade
  3. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    The other machines are picking up 169.x.x.x address

    :bluegrab
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  4. Sandy

    Sandy Ex-Member

    1,091
    2
    65
    They have an APIPA address and not one issued by ICS :!:
     
  5. SimonV

    SimonV Petabyte Poster Administrator

    6,616
    149
    228
    Have you got a firewall running on the server? (like zone alarm) That could be blocking the ip requests.
     
    Certifications: MOS Master 2003, CompTIA A+, MCSA:M, MCSE
    WIP: Keeping CF Alive...
  6. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    No Firewall is installed, McSmoothie how di i get the other machine to pick up IP's from ICS instead of APIPA?

    :bluegrab
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  7. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Have you tried to release and renew the IP addresses

    ipconfig /release (/renew)

    Just a thought

    Andrew
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  8. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    Yes tried release/renew and registerdns but it tells me that they cannot be released, something to do with DHCP, which is strange as i am not running DHCP as you cant run DHCP and ICS at the same time, they comflict.

    :bluegrab
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  9. Phil
    Honorary Member

    Phil Gigabyte Poster

    1,680
    7
    87
    Set the ip address on one of your workstations to 192.168.0.2/24 then try and ping the server, if you don't get a response then it's possibly a cabling or network card driver issue. If you get a response you've ruled out hardware/drivers between the workstation and server. Is there more than one workstation with an apipa address? if so then the problem has to be on the server. Have you tried removing ics and resetting it?
     
    Certifications: MCSE:M & S MCSA:M CCNA CNA
    WIP: 2003 Upgrade, CCNA Upgrade
  10. Jakamoko
    Honorary Member

    Jakamoko On the move again ...

    9,915
    60
    229
    Hi Nelix,

    Is the Default Gateway on the clients set to be the IP of the Server, ie 192.168.0.1 ?

    sorry if that's a bit obvious, but ya gotta ask the dumb questions too ....
     
    Certifications: MCP, A+, Network+
    WIP: Clarity
  11. AndyL

    AndyL Nibble Poster

    92
    0
    21
    Nelix

    You shouldn't set the IP address to 192.168.0.1, you should enable the ICS on the "external" interface and IT will give the "internal" interface the 192.168.0.1 address and hand out addresses to the clients.
     
    Certifications: MCSE 2000,2K3,MCSA:M 2000, MCSA 2K3
    WIP: Painting the doorframes.
  12. brent

    brent Nibble Poster

    66
    0
    6
    totally agree with Phil. This should give you a better idea.
     
  13. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    Managed to get it all sorted

    Thanks for all the advice
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  14. SimonV

    SimonV Petabyte Poster Administrator

    6,616
    149
    228
    What was it in the end nelix?
     
    Certifications: MOS Master 2003, CompTIA A+, MCSA:M, MCSE
    WIP: Keeping CF Alive...
  15. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    A Mixture of DHCP, DNS, ICS, NAT, and RRA (routing and remote access)

    And a little bit of me not being methodical and just trying this and that with no kind of procedure to follow

    But i got there in the end and i now know that if the same thing happens again i will know h ow to put it right straight away


    :bluegrab :borgsmile
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294

Share This Page

Loading...