1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to get Virtual Box to see Workgroup

Discussion in 'The Lounge - Off Topic' started by shadowwebs, Sep 14, 2012.

  1. shadowwebs

    shadowwebs Megabyte Poster Forum Leader

    841
    10
    76
    So... I have got Virtual Box installed on my PC, and I am playing around with Windows PE, which is only command prompt based.

    I want to map a network drive from the VM of Windows PE to a drive on my own host PC. Can someone take me through where I am probably going wrong here, does it require bridging a network connection between my own connection and the Virtual Box Network Adapter?

    For arguments sake, please use the below information:

    PC Name: \\james-pc\
    Workgroup: estoril
     
    Certifications: compTIA A+, Apple Certified Technical Coordinator 10.10 (OS X Yosemite, Server and Support)
  2. SimonD

    SimonD Terabyte Poster Moderator

    3,463
    397
    199
    Ok first things first, are you getting a DHCP address assigned to the PE image or did you manually assign one? Have you configured DNS correctly and can you ping internal network devices?

    In the past when I have played with VMware Player it would create a couple of additional vNIC's to the OS and you would need to bridge between the vNIC and the pNIC to let you share the normal network.

    Usually working with PE it's a simple case of using net use * \\james-pc\sharename /user:james-pc\james * where the first * assigns the next available drive letter and the second * requests you to put the password in.

    I would check the networking configuration you have configured at the moment as that would be my guess.
     
    Certifications: CNA | CNE | CCNA | MCP | MCP+I | MCSE NT4 | MCSA 2003 | Security+ | MCSA:S 2003 | MCSE:S 2003 | MCTS:SCCM 2007 | MCTS:Win 7 | MCITP:EDA7 | MCITP:SA | MCITP:EA | MCTS:Hyper-V | VCP 4 | ITIL v3 Foundation | VCP 5 DCV | VCP 5 Cloud | VCP6 NV | VCP6 DCV | VCAP 5.5 DCA
    WIP: VCP6-CMA, VCAP-DCD and Linux + (and possibly VCIX-NV).
  3. reverb

    reverb Byte Poster

    153
    2
    10
    You need to set your network adaptor to a bridged adaptor in Virtualbox for your VM to "talk" to your host pc.
     
  4. shadowwebs

    shadowwebs Megabyte Poster Forum Leader

    841
    10
    76
    reverb, that is what i thought was the case also... i will attach a screen grab later and you can tell me where i am going wrong, possibly.
     
    Certifications: compTIA A+, Apple Certified Technical Coordinator 10.10 (OS X Yosemite, Server and Support)
  5. shadowwebs

    shadowwebs Megabyte Poster Forum Leader

    841
    10
    76
    as promised, I have attached both my network connections and virtual box network settings. if you need any more info, please say the word and i will send these over.
     

    Attached Files:

    Certifications: compTIA A+, Apple Certified Technical Coordinator 10.10 (OS X Yosemite, Server and Support)
  6. soundian

    soundian Gigabyte Poster

    1,460
    71
    107
    You've bridged your VM with your wired NIC, but seem to be connected to your network through your wireless NIC.

    I'm not sure why you've bridged your other connections in network settings?
     
    Certifications: A+, N+,MCDST,MCTS(680), MCP(270, 271, 272), ITILv3F, CCENT
    WIP: Knuckling down at my new job
  7. shadowwebs

    shadowwebs Megabyte Poster Forum Leader

    841
    10
    76
    in the VM, which setting should it be selected on as i only have the below (attached) options available... i know i am probably missing the obvious here but has been a 'heavy' weekend :)

    - - - Updated - - -

    to add just that little bit extra confusion to the table, one of my VMs can see the network share i have setup through oracle virtualbox, but the other cannot and yet settings are exactly the same across them both...
     

    Attached Files:

    Certifications: compTIA A+, Apple Certified Technical Coordinator 10.10 (OS X Yosemite, Server and Support)
  8. ade1982

    ade1982 Megabyte Poster Forum Leader

    566
    12
    52
    Bridged, i think
     
  9. reverb

    reverb Byte Poster

    153
    2
    10
    This is the answer for you.

    You are using the wrong adaptor. Change it from the Realtek one to the Broadcom one which your are connected to and it should get an IP from your router or dhcp server.

    Btw not sure if you know, but in VirtualBox you can create a shared folder on your host and access it from your VM without even bridging your connections. Just create a folder anymore on your host and browse for that folder under "Shared Folder" in your VM settings.
     
    Last edited: Sep 16, 2012
  10. shadowwebs

    shadowwebs Megabyte Poster Forum Leader

    841
    10
    76
    I have changed the network setting in VirtualBox from Realtek to the other option after selecting Bridge which is MAC Bridge Miniport... I presume this must be the correct case?

    Also, I did find the shared folder on the host settings within VirtualBox which I had already setup, my Server 2008 vm could see this shared folder without a problem and I could map to it, however the Windows-PE couldn't see it and when trying to map said network resource not found.

    - - - Updated - - -

    Just an update to say that I have resolved this, I must have been half asleep for the last few days as it really was quite obvious what the cause was and this morning i have figured it.

    Thanks all
     
    Certifications: compTIA A+, Apple Certified Technical Coordinator 10.10 (OS X Yosemite, Server and Support)
  11. soundian

    soundian Gigabyte Poster

    1,460
    71
    107
    What was it?
     
    Certifications: A+, N+,MCDST,MCTS(680), MCP(270, 271, 272), ITILv3F, CCENT
    WIP: Knuckling down at my new job
  12. shadowwebs

    shadowwebs Megabyte Poster Forum Leader

    841
    10
    76
    Essentially, it was exactly what you guys were saying that I needed to select the other device, which indeed once changed to MAC Bridge Miniport within Virtual Box settings, and ensuring 'cable connected' tick was in place it then worked after rebooting to ensure settings kicked in.

    both VMs and my host pc are now all talking, although I did have another problem where I couldn't write to the folder on the network drive and permissions all appeared to be fine, even administrator could not write to the folder... once again, was just a tick box within folder permissions missing as well as local users & groups settings that i had to adjust.
     
    Certifications: compTIA A+, Apple Certified Technical Coordinator 10.10 (OS X Yosemite, Server and Support)
  13. soundian

    soundian Gigabyte Poster

    1,460
    71
    107
    Easy to miss if you're not sure.
    I still can't figure out why your other settings are bridged, but if it works, job done
     
    Certifications: A+, N+,MCDST,MCTS(680), MCP(270, 271, 272), ITILv3F, CCENT
    WIP: Knuckling down at my new job

Share This Page

Loading...