1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GS748TS & vLan Trunks

Discussion in 'Networks' started by ThomasMc, Apr 6, 2008.

  1. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Anyone got any experience with these as am having some difficulty trying to setup a vlan trunk via there lovely web interface, my web searches haven't turned much up apart from that cisco trunks and netgear trunks are 2 diffrent things

    Thanks in advance
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  2. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    what s/w are you using to set up the virtual Lan?:blink

    oops sorry Thomas, misread that post. I thought you were setting up a vlan with vmware. We use these all the time at work, but I see your referring to that web interface. Which is total pants! I had a simliar problem with netgear and belkin router using their software interface to setup and configure the ports. In the end I used IE.
     
    Certifications: Comptia A+
    WIP: Comptia N+
  3. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    Can you give us some more details, such as error message, screen shots or what exactly your having a problem with? is it the settings, the ports? Or the fact you can't connect??:blink8)
     
    Certifications: Comptia A+
    WIP: Comptia N+
  4. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Sorry UCM ofcource i can, I'm messing about with tagged vlans. The equipment I'm using is a Cisco 877 Sec router and 1 Netgear GS748TS Smart Switch, from my understanding i need to add 1 port(uplink port to router) to all vlan(trunk) and tag the traffic, this is where I'm having the problem as in the GS748TS web interface there is no way that i can see to achive this

    [Edit]
    I suppose i could be getting confused due to my lack of knowledge on vlans

    I can tag port 1(router attached) on all the vlans via the vlan membership configuration page but not sure that this automatically trunks it
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  5. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    Do you know what firmware version you have on the smart switch. :hhhmmm just having a lookie at the specs of the switch I sure the uplink was automatic???

    Netgear GS748TS ProInterfaces:

    GS724TS: 24 10/100/1000 Mbps switching ports
    GS748TS: 48 10/100/1000 Mbps switching ports
    4 Built-in shared SFP Gigabit Ethernet fiber ports for 100/1000 Mbps connectivity
    Auto-sensing and auto-negotiating capabilities for all copper ports
    Auto Uplink™ on all ports to make the right connection Administrative Switch Management:

    IEEE 8021.Q VLAN (128 groups, Static)
    IEEE 802.1p Class of Service (CoS)
    Port-based QoS
    IEEE 802.3ad Static or Dynamic Link Aggregation (LACP)
    IEEE 802.1D Spanning Tree Protocol
    SNMP v1, v2c, v3
    RFC 1213 MIB II
    RFC 1643 Ethernet Interface MIB
    RFC 1493 Bridge MIB
    RFC 2131 DHCP client
    IEEE 802.1x (RADIUS)
    Access Control List (ACL)
    Layer 3 and 4-based Quality of Service (QoS)
    TACACS+
    Port-based security by locked MAC addresses
    Storm control for broadcast, multicast and unknown unicast packets
    Port-based ingress/egress rate limiting
    SNTP
    RMON group 1, 2, 3, 9
    Private Enterprise MIB
    Port Mirroring Support
    Cable test
    Web-based configuration
    Configuration Backup/Restore
    Password Access Control
    Firmware upgradeable
    Safe 48-port Stackable Smart Gigabit Switch W/ 4 x SFP ports

    SOURCE

    Have you seen the review?

    "An intuitive, web-browser interface offers simple switch management, making it a snap to monitor switch performance, configure ports, even set up trunks, VLANs, and prioritization" that bit cracks me:p:biggrin
     
    Certifications: Comptia A+
    WIP: Comptia N+
  6. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    ThomasMc,

    Questions:
    1. How have you determined that you have a problem?
    2. What IOS version is running on the Cisco 877 router?
    3. How did you determine that the Netgear GS748TS Smart Switch supports VLANs?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  7. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    Err it does say in the spec's "IEEE 8021.Q VLAN (128 groups, Static) ":oops:8)

    Although I'm not sure if the cisco router supports 8021.Q???

    Just having a look on google for it?
     
    Certifications: Comptia A+
    WIP: Comptia N+
  8. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Answers:
    1. 3 out of 4 vlans are not being serviced by the routers DHCP, Internet etc etc
      ping tests on the vlans reveal no traffic is passing between vlans.
    2. 12.4 T.
    3. After reading the Data sheet and user manual i determined that vlans where supported, although they mentioned trunking in these documents i have found out that it refers to a Netgear LAG(Link aggregation) port function or Port Teaming.
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  9. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    Certifications: Comptia A+
    WIP: Comptia N+
  10. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    its a
    CISCO877-SEC-K9 -- Cisco 877 ADSL Security Bundle with PLUS Feature Set
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  11. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,190
    296
    319
    Do you not need to create access control lists between the VLANs if they have to talk to each other? Can you get any traffic from a VLAN onto the tinternet?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  12. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Not sure about the ACL, but when i run the vlans native and use a seperate physical interface for all 4 of them on the router without the switch each client on the interface gets the correct ip for that vlan and tinternet is A ok and all vlans can talk(with the same ACL's), when i let cisco handle the trunking but i want to run all the vlans over a single link to the router, so in my understanding the trunking should be done at switch level

    [edit]
    i use SVI's on the cisco vlan config that should pass the traffic as far as the router is concerned
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  13. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    ThomasMc,

    Exactly which version of Cisco IOS, including the number and letter in parenthesis after the 12.4T? Do a "#show version" on the Cisco 877 to find out.
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  14. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    UCHEEKYMONKEY,

    IEEE does not have a "8021.Q" standard. They do have a "802.1q" standard. When you're referring to "spec's," are you talking about the Cisco 877 router or the Netgear GS748TS Smart Switch?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  15. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    It reads 12.4(6)T9, Release Software (fc2)
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  16. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    i thought i would share more info on my setup to see if anyone can spot a problem

    Cisco 877 on Port 1 or 1/g1
    on the Netgear Switch all ports have PVID of 1
    Via the Vlan Mebership page i have added port 1 to all vlans and tagged the port

    Port 2 or 1/g2 is an untagged member of vlan2
    no DHCP traffic is being serviced on vlan2
    from what i have managed to read on the net this should be working :blink so maybe its the router setup thats causing me jip

    Code:
    interface FastEthernet0/0
     switchport mode access
     switchport access vlan 2
    !
    interface FastEthernet0/1
     switchport mode access
     switchport access vlan 3
    !
    interface FastEthernet0/2
     switchport mode access
     switchport access vlan 4
    !
    interface FastEthernet0/3
     switchport mode access
     switchport access vlan 5
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan2
     description NET 2$FW_INSIDE$$ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
     ip address a.b.c.d m.a.s.k
     ip access-group 100 in
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat inside
     ip virtual-reassembly
     ip route-cache flow
     ip tcp adjust-mss 1452
    !
    interface Vlan3
     description NET 3$FW_INSIDE$
     ip address a.b.c.d m.a.s.k
     ip access-group 101 in
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat inside
     ip virtual-reassembly
     ip route-cache flow
    !
    interface Vlan4
     description NET 4
     ip address a.b.c.d m.a.s.k
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip route-cache flow
    !
    interface Vlan5
     description NET 5$FW_INSIDE$
     ip address a.b.c.d m.a.s.k
     ip access-group 102 in
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat inside
     ip virtual-reassembly
     ip route-cache flow
    !
    
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  17. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    after looking at my last post i noticed set my subinterfaces wrong :oops: (note to self "/" physical "." sub), will test in the morning and report back
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  18. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    nope that didn't work, shyzer :( tryed something along the lines of

    Code:
    interface FastEthernet0
     no shutdown
    !
    interface FastEthernet0.1
     switchport mode access
     switchport access vlan 2
    !
    interface FastEthernet0.2
     switchport mode access
     switchport access vlan 3
    !
    interface FastEthernet0.3
     switchport mode access
     switchport access vlan 4
    !
    interface FastEthernet0.3
     switchport mode access
     switchport access vlan 5
    !
    
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  19. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    Try creating a trunk from one of the switchports, e.g.:

    int f0
    switch mode trunk
    switch trunk encap dot1q
    switch trunk allow vlan all

    Set the ip address for each vlan on the vlan interface. You may have a problem with the number of vlans as the advanced security image only supports a measly 2 vlans, I think. Advanced ip services is the image you'll need.

    Also, make sure the native vlan is the same on both the switch and the 877.

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  20. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Thanks for the reply Spicey, will try this in the morning :biggrin.

    Its a CISCO877-SEC-K9(28/128 although i was thinking about getting a 16mb flash upgarde) : Cisco 877 Security Bundle with Advanced IP Services(would i be correct in saying that it can have a max of 4 vlans?)
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)

Share This Page

Loading...