1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Group Policy in Longhorn

Discussion in 'Software' started by noelg24, May 7, 2007.

  1. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    I have installed Longhorn on Virtual PC (and may I say its really good). I have created a domain along with AD and DNS. But now I am trying to create a user and when I enter the password and go to click finish, it tells me the password does not meet the requirements.

    I have added the GPO but I am unable to edit anything within it. Furthermore in AD itself, when I go to the properties of the domain, it doesnt have the Group Policy tab therefore I can do nothing.

    Does anyone know of a way to a. change the number of characters needed for a password, b. how to get the group policies enabled and c. well just get this thing working.

    This is my very first attempt at creating a domain and using a server operating system. What I will say is, I have been RDPing to the server from my machine and boy it rocks :biggrin

    Thanks in advance...if I have missed anything out please ask...now im going to kick my flatmate out of my bed so I can sleep in it (havent been to bed yet!!!)
     
    Certifications: A+
    WIP: my life
  2. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    Hmm not sure about Virtual PC, I found that VMWare had more flexiability than Virtual PC. :blink

    What settings did you use when you setup the virtual environment?

    Also have you seen this website??

    What works and What doesn't work on Virtual PC
     
    Certifications: Comptia A+
    WIP: Comptia N+
  3. UCHEEKYMONKEY
    Honorary Member

    UCHEEKYMONKEY R.I.P - gone but never forgotten. Gold Member

    4,140
    58
    214
    Which version of longhorn are you using and what are the specs of your PC?
     
    Certifications: Comptia A+
    WIP: Comptia N+
  4. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    Password Complexity never used Longhorn, but in win2k3 its changed int domain secuirty settings
     
  5. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Yup, there should be a 'default domain policy' which may have password complexity enabled. If you type CertForums123!$ as the password that should be complex enough. :biggrin

    In regard to group policy tab not being there is this feature enabled in the beta version? Furthermore in the first release on Windows Server 2003 you had to install Group Policy Management console which added to the existing GP tools. This is now bundled in R2.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  6. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    UCM its not to do with whether im using VMW or VPC...this is within Longhorn itself...and I am using Beta 3 of Longhorn 32 bit Enterprise edition. And my pc spec is in my sig...again nothing wrong there...

    But Mr Cheeks and Sparky have answered my question (I hope hehe), perhaps ur right tho Sparky maybe its not enabled so will look further into this and get back to you all. Thank you all so far :biggrin
     
    Certifications: A+
    WIP: my life
  7. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    It is enabled - hence that you have to type a password that meets the requirements, uppercase lowercase, numeric and characters... best thing to do, if its in a lab environment is to disable it..
     
  8. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Yes that worked :D I just used the password u put up and it worked...I have now created a new user...now where can I get Exchange 2007 from? hmmm
     
    Certifications: A+
    WIP: my life
  9. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Well thats just it...how do I disable it?
     
    Certifications: A+
    WIP: my life
  10. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    not sure in longhorn, but in 2k3, double click on Password Complexity in Domain Security Settings, and select Disable.

    should be something similar...
     
  11. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Ok im downloading Exchange server 2007 so we'll be adding email addresses soon hehe...I tell ya this whole server is rather easy (well not that easy) but learning the simple things first then getting onto the bigger stuff...its great :biggrin
     
    Certifications: A+
    WIP: my life
  12. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Ok I shall have a look...
     
    Certifications: A+
    WIP: my life
  13. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Right...another thing...it was asking me earlier on would I like to set up a static IP...I told it no cos I dont know how to do that hehe...so its set to DHCP right now...but if I was to set this up...how do I go about it? Also, how can I allow for remote connection to my server from another location (as in will I need an external IP address for this) cos I can RDP to my server from my own PC because they are on the same router/network so its using the 192.168.x.x address...again thanks for help :biggrin
     
    Certifications: A+
    WIP: my life
  14. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    I found out the reason I couldnt do the Group Policy in the first place is cos I didnt install it as a feature to begin with (duh!!) but this has now been installed, I have now snapped in the Group Policy and have been to modify the Password Policy...woohoo...
     
    Certifications: A+
    WIP: my life
  15. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    if its gonna be an AD, then you will need give it a static ip add. right click network places > properties > right click lan connection > properties > select tcp/ip > properties and use following ip details, and bang in your details...

    or something along that lines... hope that helps

    for remote connections, im assuming your planning to connect over the net, again you will need an static wan ip add, go to dyndns.com and signup, they will give you a domain to use which will be rooted to your ip address, if you feel that this changes quite often, and you are constanly updating dyndns, use their client, which is will automatically update their database automatically... and ofcouse its free...

    you'll have to configure your firewall settings / portforwarding aswell
     
  16. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Lovely thank you...but how do I know what my static IP is? Or can I set this up myself? Will it be from my ISP? lol too many questions being asked here hehe...

    As for remote connections...its connected to the Internet no problem, but I mean if I was say in London and I wanted to see how my server was doing or make changes, will I use the static IP I set up or do I need a seperate IP address altogether...that dyndns.com sounds like a good bet so will give that a look at too...

    Then the final move...adding my machine to my newly created domain...I have tried twice and failed miserably lol...I have created the user to the user of my machine so I hope I am on the right track...
     
    Certifications: A+
    WIP: my life
  17. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    Lovely thank you...but how do I know what my static IP is? Or can I set this up myself? Will it be from my ISP? lol too many questions being asked here hehe...

    for your AD... Its going to be an internal 192.168.254.XX
    this is upto you, you input ther details in yourself, if you dont make it static, then it will be assigned by DHCP.

    Remote over the net, its your external wan ip, which should be dynamic, although, this changes as rarely, but then it may change often. the ip should be like 82.54.245.75, use dyndns to mask it to a domain...


    As for remote connections...its connected to the Internet no problem, but I mean if I was say in London and I wanted to see how my server was doing or make changes, will I use the static IP I set up or do I need a seperate IP address altogether...that dyndns.com sounds like a good bet so will give that a look at too...

    ok

    Then the final move...adding my machine to my newly created domain...I have tried twice and failed miserably lol...I have created the user to the user of my machine so I hope I am on the right track...


    whats the client , XP/2K? when joining the domain, make sure that the details you are uising to join the domain are someone within the administrators users group (you should get a pop up box)

    also, make sure you have added the computer to the computers list within computers and directories within the server
     
  18. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    Ok the static IP has been entered...I just used its own IP that was assigned by DHCP before...and its working fine...and yes I know what you mean with the external IP now...that will the one from my ISP.

    As for the client joining the domain its actually Vista hehe...which is where I am running Longhorn from VPC...as I said I have added my user on their...so now I just need to add the computer and we'll go from there...thank you so much for this :biggrin
     
    Certifications: A+
    WIP: my life
  19. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    so is vista your physical machine, and you're gonna join a domain to a virtual machine which is hosted within your physical machine?
     
  20. noelg24

    noelg24 Terabyte Poster

    3,334
    26
    139
    thats correct...lol
     
    Certifications: A+
    WIP: my life

Share This Page

Loading...