1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

External Connection Issue

Discussion in 'Networks' started by Fergal1982, Sep 27, 2006.

  1. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    Since setting my server1 as a DHCP and DNS server last night my laptop is having some problems connecting to the outside world. It seems to work fine for a time, then drops out, although i can still access the internal network.

    When checking ipconfig, my default gateway is 192.168.1.254 (this is the bt home hub - my wireless router).

    [Background: I have a netgear wired router (192.168.1.1) acting as my gateway to the external world. My bt Home Hub (192.168.253/254 - presumably one for wired, and one for wireless) is physically plugged into this, providing my wireless connection]

    This has only started since i set server1 as DHCP and DNS (i reserved IP's for server1, server2, and the netgear (although these should query the DHCP for it as they have been statically assigned it within their settings).

    If i /release /renew the ip on the laptop (wirelessly connected) it seems to resolve the default gateway back to the netgear, but this reverts after a time. The laptop has server1 set as its primary DNS server.

    Im thinking that the bt home hub is hijaking the DHCP and setting itself as the default gateway regardless of the fact that it has no direct connection to the network.

    Is there a way to tell the laptop to get its DHCP from a specific location (ie server1), or is there another way to resolve this?

    Fergal


    Further Update: While posting this i had issues connecting out. i went into DHCP on server1, and set two ips on the forwarding tab (i got to the forwarding section in a weird way - i double-clicked on 'root hints' and navigated to the forwardesr tab). in the forwarders section, i selected 'all other DNS domains' and set 192.168.1.1 (my netgear) into the IP address list, i also set 62.6.40.178 (i got this ip from the netgear frontpage under the DNS setting on the ADSL port). This seems to have connected me to the outside world. Have i set all this up correctly???
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  2. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Perhaps give your laptop a static I.P if it has problem connecting to the DHCP server through the wireless connection.

    Also make sure the only DHCP source on your network is the server when you are testing. 8)
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  3. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    its not that it cant connect to the DHCP server i set up. it can definately reach it (i can ping it and release/renew works properly). its just that, for some reason, its the hub is setting itself up as a default gateway.
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  4. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    so the gateway is changing on the laptop without you doing anything? :blink
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  5. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    thats about the gist of it. when i check the ipconfig settings at these times, it lists two default gateways - 192.168.1.1 and 192.168.1.254.

    Firstly, i need to be 100% sure ive set up the dhcp forwarding for external addresses correctly (and the netgear is set up ok to do this right). once ive done that i think i need to figure out how to disable DHCP and DNS on the bt home hub (ive emailed bt about this, but i can all but guarantee that they will refuse to answer).

    Any suggestions?
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  6. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    When you do ipconfig do you have two gateways listed for the same network adaptor? For example if I do an ipconfig on my laptop I have two gateways as I have a wireless connection (to get onto the internet) and I am also patched into to my test LAN through the physical network port.

    As for the forwarding if you open up DNS on the server, right click on the listed DNS server and then go to the forwarders tab you can put the I.P in there. Your Netgear router will be responsible for NAT so your LAN can communicate with external resources (websites etc.)


    Could you post the results of an ipconfig /all ?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  7. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    Fergal,

    Forgive me, i have had a few beers but you seem to have two gateways. From a very quick look through 290 material i think you can specify alternate gateways but this isn't mentioned in your post.
    If, your network is set up as i imagine it, you should knock of DHCP on the Netgear; let the Server deal with this.

    Si
     
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  8. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    8,871
    167
    256
    You should only have your ISPs DNS server ie 62.6.40.178 in the forwarders tab not the local 192.168.1.1 address.

    You must not have two DHCP servers on your LAN, only use the Servers scope and disable the BT hub one way or the other. As DHCP servers are located by broadcasting a discover packet any DHCP server in the local segment can respond with an offer. This is known as having a rogue DHCP server and as you realise is a bad idea!
     
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)

Share This Page

Loading...