1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exchange server issue

Discussion in 'Exchange Exams' started by gosh1976, Dec 9, 2010.

  1. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    I was bored of studying last night so I thought I would install an instance of Win server 2008 r2 running exchange server 2010. I got it installed and integrated with AD on the DC and everything looked fine. The issue is that when I try to pull up the owa page I just get a blank page. I've tried all the fixes I can find online but nothing seems to work. Anybody have any suggestions before I kill the VM and start over?
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  2. LukeP

    LukeP Gigabyte Poster

    1,194
    41
    90
    Not sure what it is but isn't it the whole purpose of testing in the lab and lots of fun where something doesn't work and you make it work.

    Not always you have the opportunity to start over.
     
    WIP: Uhmm... not sure
  3. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Did you access it on the Exchange Server itself or from another machine?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  4. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    I tried it from the DC and from the exchange server with the same results. Those are the only two machines in the Domain right now!

    I'm not sure what I did but now when I try to start IIS I get "Cannot start service W3SVC on computer" I think I'll try an un-install and re-install with IIS and see what happens. Not sure how long I'll play around with it before I decide to start over from the beginning!
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  5. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    check you dont have something listening on port 80

    I have seen cases where IIS wont start because of a binding problem

    although, generally IIS will start now but the website wont start, atleast thats what i thought its current style was


    netstat -a
    should tell you the listening ports, if your listening on 80 or 443 with IIS off something else is using the default ports exchange wants, i've seen this before on R2 boxes but never narrowed it down closer than the standard generic windows process stealing themeeee
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  6. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    Thanks for the suggestions. I decided to throw in the towel and re-install the OS. I'm just doing the exchange perquisites now lets see if I have any more luck this time!

    If nothing else I learned a few things today...
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  7. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    well I reinstalled but I have the same issue with owa!! I'm not sure what else to try. I get the blank page in firefox and ie - and also on the dc...
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  8. LukeP

    LukeP Gigabyte Poster

    1,194
    41
    90
    Have you configured SSL binding to OWA website in IIS?
    I believe OWA in Exchange 2010 can't work over HTTP traffic and needs SSL. It created self-signed Exchange certificate during the installation but I think I had to configure bindings in IIS.

    Other thing is that you may have missed some of the IIS pre-reqs for Exchange so worth checking that out too.

    Actually now I remember and I'm sure it was the latter I had to do.

    Check out the pre-reqs
     
    Last edited: Dec 10, 2010
    WIP: Uhmm... not sure
  9. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    you can force it to use HTTP, its just HTTPS by default
    that said, EX bindings shouldn't be causing IIS to not start

    What does the event log say in the Service Control messages for when IIS fails to start?
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  10. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    The issue with IIS not starting is fixed that isn't happening anymore.

    I red-did the powershell script for the pre-req's and it showed they were all installed...

    IIS shows https in bindings for the default web site that is where I would check for the binding correct?

    The event logs don't show any errors or warnings since I got everything re-installed and the updates installed.
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  11. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  12. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    not much to see in the screenshot... the url redirects to: https://exchangeserver.test.local/o...tps://exchangeserver.test.local/owa/&reason=0

    the page is blank but if I get this if I veiw the page source:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <!-- Copyright (c) 2006 Microsoft Corporation.  All rights reserved. -->
    <!-- OwaPage = ASP.auth_logon_aspx -->
     
    <!-- {57A118C6-2DA9-419d-BE9A-F92B0F9A418B} --> 
     
    <html>
    <head>
    <link rel="shortcut icon" href="/owa/14.0.702.0/themes/base/favicon.ico" type="image/x-icon">
    <link type="text/css" rel="stylesheet" href="/owa/14.0.702.0/themes/base/logon.css">
    <link type="text/css" rel="stylesheet" href="/owa/14.0.702.0/themes/base/owafont.css">
    <script type="text/javascript" src="/owa/14.0.702.0/scripts/premium/flogon.js"></script>
    <script type="text/javascript"> 
    	<!--
    	var a_fRC = 0;
    	var a_sUrl = "&url=https%3a%2f%2fexchangeserver.test.local%2fowa%2f";
    	var a_sCW = "https:\/\/exchangeserver.test.local\/owa\/?ae=Dialog&t=CloseWindow&exsvurl=1";
    	var a_sLgn = "logon.aspx?replaceCurrent=1";
    	-->
    </script>
    </head>
    <body class="owaLgnBdy">
    <noscript>
    	<div id="dvErr">
    		<table cellpadding="0" cellspacing="0">
    		<tr>
    			<td><img src="/owa/14.0.702.0/themes/base/warn.png"></td>
    			<td style="width:100%">To use Outlook Web App, browser settings must allow scripts to run. For information about how to allow scripts, consult the Help for your browser. If your browser doesn't support scripts, you can download <a href="http://www.microsoft.com/windows/ie/downloads/default.mspx">Windows Internet Explorer</a> for access to Outlook Web App.</td>
    		</tr>
    		</table>
    	</div>
    </noscript>
    </body>
    </html>
    
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  13. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    make sure you add the URL to the IE trusted sites setting
    servers dont like running scripts and stuff, did you not get the standard 'this site isnt trusted' box?
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  14. Darkfunnyguy

    Darkfunnyguy Byte Poster

    195
    3
    22
    Certifications: A+, N+, MCP, MCDST, MCSA 2003
    WIP: Server+, Vista,
  15. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    /exchange is depreciated and only there for legacy purposes

    you generally point to /owa for Outlook Web Access or /ecp for managing exchange organization settings via the web


    Exchange 2010 is very simple with the self signed cert, it will automatically create it for the name you configured during install, generally the server name, and it does it during install because it doesnt enable HTTP by default

    the source code posted above actually tells us the problem, basically the browser is not running scripts and OWA needs them to run :)
     
    Last edited: Dec 10, 2010
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  16. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    I had already turned off IE ESC and imported the certificate so I wasn't getting any warnings or pop-ups and I've added the url to the trusted sites with no change.
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  17. LukeP

    LukeP Gigabyte Poster

    1,194
    41
    90
    Where did you get the PowerShell script that install the pre-reqs? I remember having the same exact issue and I checked the prerequesites manually and there was 1 missing.

    Give that a go maybe. Try to manually check if all the required IIS components have been installed.
     
    WIP: Uhmm... not sure
  18. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    I got it off of technet it wasn't really a script I guess more like a few commands... everything I could find to install has been done I even installed a bunch of stuff I know I don't need just to be thorough...
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  19. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    Actually after re-reading the source code its probably just the catchall text :)


    In ESM goto Server configuration and Client Access
    check the OWA site properties there, and the authentication ones
    anything look out of order?

    not getting a page to display even though there is source code does seem client related though
    the HTML is obviously there because you can view the source

    try and alternate browser?
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  20. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    same results with firefox...

    when I go into IIS manager and go to basic settings for owa and click test settings it passes authentication but for authorization I get can not verify access to path (c:\program files.............
    this is what it says in details:

    The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.

    I'm guessing that might be the problem but I'm not sure how to resolve it!
     
    Last edited: Dec 10, 2010
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA

Share This Page

Loading...