1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EPOS system become progrssively slow throughout the day

Discussion in 'Software' started by matqda, Oct 27, 2011.

  1. matqda

    matqda New Member

    2
    0
    1
    Hello all. If anyone could give some advice on the below problem it would be appreciated.

    I am a shop.

    I have a server in the office running Win 7 64bit and our Epos software NCompass Advanced Retail 8.20a

    In the shop are two tills both running Win XP Pro, Ncompass and Windows Securtity Essentials.

    The server is less than a year old.

    The tills PCs have 2.8GHz celerons and 1GB RAM each, with 80GB HDs (60GB free space)

    The tills connect to the server via a switch that also has our BB router connected.

    The problem is this...

    Windows runs fine, internet runs fine on the tills. We can happily stream radio and films to the tills from both the server and the net with no problems.

    But NCompass runs progressively slower throughout the day until it has to be shut down and restarted (Just NCompass NOT windows). After that is is fine again. To my knowlegde all the tills need to talk to the server for are the product database and customer database. The till software is installed on each till.

    The tech support guys have tried to sort this for about 2 years now. In that time we have upgraded RAM, bought a new server, upgraded the switch and tried many setups of different firewalls on the tills all to no avail. Currently ALL till firewalls are disabled and the till is running AVG Pro.

    They now say the problem is the tills themselves being too old and the RAM is too slow at refreshing and we need to buy new tills. I do not agree because to my mind if my till can stream and playback a hi-res film from the server with no problem, fetching a name and address or from the server should not be a problem?

    If anyone could give any thoughts on this I would be very grateful.
     
  2. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    My first thought is get new tech support guys!

    How much memory does the application use on startup...and how much is it using when it gets slow enough you feel you need to restart the app? Do you have to restart it on the tills and the server?

    I'm sure someone with a lot better questions/suggestions will be along also!
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  3. Notes_Bloke

    Notes_Bloke Terabyte Poster

    3,230
    54
    146
    Sounds to me like a memory leak in the NCompass software.

    As danielno8 has suggested - check the memory usage (in Task manager) when the software is running slow.

    NB
     
    Certifications: 70-210, 70-215, A+,N+, Security+
    WIP: MCSA
  4. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    8,871
    167
    256
    My BS meter is at high on their diagnosis.

    Why not give the company a call..
    Contact Us
     
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  5. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Having supported various EPOS systems over the years I would suggest only running the EPOS software on a clean build PC. Add anything else to it and there is always hassle.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  6. matqda

    matqda New Member

    2
    0
    1
    We have done this to no avail.

    Blurinse, it is FindEsolutions that are struggling to find a solution!?

    As for the RAM, at startup it runs at 50,000k, this increases and tops out at around 200,000k depending on what we are doing.

    Thanks all for the input so far.
     

Share This Page

Loading...