1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DNS question

Discussion in 'Windows Server 2003 / 2008 / 2012 Exams' started by Theprof, Dec 27, 2007.

  1. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    So I've finally setup my virtual lab to practice for the 290 exam. Everything is going well except a minor issue which is bugging me.

    I have DHCP and DNS installed on the AD VM and all is well the clients get their DNS and DHCP address from the server, however when I open IE and browse to a website, the DNS IP changes to the router IP. I would then do an ipconfig release, then renew and everything goes back to normal (back to the proper DNS server IP). After that when I use IE again the DNS remains as it should.

    Could it be a setting in the router maybe? or is there something I need to configure in DNS.

    Note. all my pc's in the virtual lab are on DHCP, even after rebooting everything is normal it's just when I open the web browser for the first time after a reboot that it does this.

    I looked at my router setup and I noticed that under DHCP server it says WAN and I can also set it to LAN or WLAN which makes a lot of sense. However I don't really want to set it to LAN because my other physical computers are not on the domain that I created and are not receiving the IP address from my DHCP server, instead it's from the router which is how I want it to be, because I turn off the vm's when I really have no use for them.

    Btw I am using the DD-WRT firmware on my Linksys router.


    Thanks.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  2. zebulebu

    zebulebu Terabyte Poster

    3,748
    330
    187
    Hi Prof

    Just to summarise, your DNS setup should probably look something like this:

    PC - Pointing to your internal DNS server for all name resolution
    DC - Pointing to itself for DNS, with a forwarder configured pointing to your router
    Router - Using the DNS servers provided by your ISP (these should be provided by your ISP when you lease your IP address - either by RRAS, PPPOA or DHCP)

    Make sure you don't allow unsolicited zone transfers from your internal DNS server (inbound TCP port 53 should be blocked by your router anyway, but you should NEVER allow unsolicited zone transfers as good practice) and you're good to go.

    Easiest way to check all this is to look at the properties of the NIC on your workstations - they should point to the DC for name resolution - then check under DNS settings on the DC and make sure the entry for 'all other domains' points to your router. That will make the DC authoritative only for your domain, with the DC configured to forward all queries for resources 'outside' to the router.
     
    Certifications: A few
    WIP: None - f*** 'em
  3. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196

    Thanks for the reply zeb so here it goes.

    Doing some checking here's how things are setup:

    PC- In the properties of the nic, it's set to DHCP, now I looked at the advanced settings under the DNS servers tab and there is nothing there, which I would assume makes sense since it's on DHCP. Also I am not sure exactly what you mean by that. If it means that by default thats how it should be then I thats how it probably is since it's getting the proper DNS address from the get go.

    DC-is pointing to itself for the DNS with a 127.0.0.1

    Router-same thing like you said, its using PPPOE.

    Zone transfers are deselected and the forwarder is correctly pointing to the router IP address.

    Let me know if I am missing anything.:rolleyes:
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  4. zebulebu

    zebulebu Terabyte Poster

    3,748
    330
    187
    Have you set the DNS Server address under DHCP options? If you assign the address under option 6 on the DHCP server, then run an ipconfig /release /renew on the client it should pick up the correct nameserver address (you can confirm this by running an ipconfig /all after you've renewed the lease on the client).

    It sounds like the rest is all OK - being in North America, you would naturally use PPPOE instead of PPPOA like we do in the UK. It might be worth you using the actual IP address of the server in its DNS properties instead of pointing to itself via the loopback address - though both should work the same, it just makes things neater.
     
    Certifications: A few
    WIP: None - f*** 'em
  5. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Zeb, thanks a lot!!

    That DHCP option for the DNS was it. It fixed the problem now the DNS does not change to the router IP which is what I wanted.


    Thanks again:biggrin
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  6. zebulebu

    zebulebu Terabyte Poster

    3,748
    330
    187
    No worries - now, if I have resolved Jack's problem by spotting a typo that will make me two for two today :biggrin

    Off to bed now - have to be up in the morning as I'm back to work :(
     
    Certifications: A few
    WIP: None - f*** 'em
  7. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Ouch! back to work eh? Good thing I get this whole week off.:twisted:
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA

Share This Page

Loading...