1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Coniguration CISCO 877W problem

Discussion in 'Networks' started by shadowex, Aug 27, 2012.

  1. shadowex

    shadowex New Member

    4
    0
    1
    Hi.
    I have a little problem with CISCO router. I am amateur in this subject so please help.
    I have internet provided by Virgin and I am using their modem. Now I want use CISCO 877W fow Wireless and LAN network. I can not use ADSL port to connect WAN from Virgin modem so, I suspect, I need to use one of the FE (Fe 0) port and configured like pppoe and NAT outside and next 3 ports (Fe 1-3) and Wireless like internal network with NAT inside.

    Below you can find my configuration:

    Current configuration : 2238 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname homeEN
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret password
    enable password password
    !
    no aaa new-model
    !
    dot11 ssid cisco.g
    max-associations 10
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 password
    !
    no ip source-route
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp binding cleanup interval 10
    ip dhcp excluded-address 192.168.0.1
    !
    ip dhcp pool CLIENT
    import all
    network 192.168.0.0 255.255.255.0
    dns-server 194.168.4.100
    default-router 192.168.0.1
    lease infinite
    !
    !
    no ip domain lookup
    !
    multilink bundle-name authenticated
    vpdn enable
    !
    vpdn-group 1
    ! Default PPTP VPDN group
    accept-dialin
    protocol pptp
    virtual-template 1
    !
    !
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    !
    interface Loopback0
    ip address 192.168.70.1 255.255.255.0
    no ip proxy-arp
    ip nat inside
    ip nat enable
    ip virtual-reassembly
    !
    interface ATM0
    no ip address
    logging event subif-link-status
    load-interval 30
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    dsl enable-training-log showtime
    !
    interface FastEthernet0
    switchport access vlan 2
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    shutdown
    !
    encryption mode ciphers tkip
    !
    ssid cisco.ginger
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    channel 2452
    station-role root
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    ip virtual-reassembly
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface BVI1
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    control-plane
    !
    bridge 1 route ip
    !
    line con 0
    no modem enable
    line aux 0
    password password
    line vty 0 4
    password password
    login
    !
    scheduler max-task-time 5000
    end


    Please help
     
  2. Barryw

    Barryw New Member

    5
    0
    1
    Here is my config. This works.

    First reset your router to default then use the console cable to configure.

    This will get the internet going, the wireless will still need to be configured.

    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service compress-config
    !
    hostname Awehness
    !
    boot-start-marker
    boot-end-marker
    !
    !
    aaa new-model
    !
    !
    !
    aaa session-id common
    !
    !
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool sdm-pool1
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    !
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    description Telkom
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 10.10.10.1 255.255.255.0
    ip directed-broadcast
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer1
    description ADSL
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname <username here do not include < >
    ppp chap password <password here do not include < >
    ppp ipcp dns request
    ppp ipcp address accept
    ppp pap sent-username <username here do not include < > password 0 <password here do not include < >
    ppp ipcp route default
    !
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    access-list 1 remark Internet Access
    access-list 1 permit 10.10.10.0 0.0.0.255
    access-list 1 deny any
    !
     
    Last edited: Aug 28, 2012
  3. shadowex

    shadowex New Member

    4
    0
    1
    Hi Barryw,

    Thanks for your respond but I think You do not understand me properly or maybe I missed somethink. From your configuration where do You connected Internet cable ? About chap hostname and chap password... I need to include that data in my coniguration ? I want to use that CISCO like internal LAN and wireless. When I was using any other router (like Netgear or D-Link) I do not need to configure any hostname and password for access to the Internet. That configuration is in modem from virgin. But the Netgear and D-Link have port (WLAN) where I connected cable from virgin modem. Now I want to use CISCO router in place Netgear (for example). I can not connect cable from virgin modem to the CISCO ADSL port so I think I need to use one of the FastEthernet port like WLAN port. In that way I need to configure that port like pppoe, but I need to configure any password ? or hostname?
    Please update and thanks.
     
    Last edited: Aug 30, 2012
  4. Barryw

    Barryw New Member

    5
    0
    1
    Hi there, with my configuration the cisco will be your main router, so you will connect the internet phone line to the ADSL pots port.

    but I see what you require now, you only want to use the cisco for lan and wlan and your virgin router as the main router?

    What you will have to do is configure the cisco in the same ip range as the virgin router. If the virgin router has an ip address of 10.0.0.1 make your cisco 10.0.0.2, and then add a default route on the cisco to the virgin router.

    And the virgin router will be your main dhcp provider. So the cisco dhcp service would have to be disabled.

    Provide me with the ip settings of your virgin router. Thanks.
     
  5. shadowex

    shadowex New Member

    4
    0
    1
    Hi Barryw,
    Problem is... I have delivered Internet from Virgin by coaxial cable so I can not use CISCO like a main router. Virgin modem is like converter from coaxial cable to the Ethernet Cable. I do not know what settings have virgin modem because Internet is on my roommate and she should now all settings but she can't find. I need only to use the Cisco like internal LAN and use one of the FastEthernet ports like WLAN connected to the Virgin Modem. It is possible ?
     
  6. Barryw

    Barryw New Member

    5
    0
    1
    Yes it is but you would have to make the cisco act as a switch to extend the existing network.

    Problem is that you would have to know the ip settings of the virgin router so that you could configure the cisco in the same range and add a route for your devices to be able to access the net.

    Sorry without the settings I cannot help
     
  7. shadowex

    shadowex New Member

    4
    0
    1
    Ok, but I think my virgin router have dynamic IP. Before when we used belkin I assign IP 192.168.2.1 and it was my gateway. Next we are using D-Link and assign IP with IP 192.168.0.1 for D-Link and like gateway. It wasn't work if I will configure one port like WAN with NAT outside (virgin will not have private IP), and rest of the ports like NAT inside? My CISCO will be like DHCP router. It will work ?
     

Share This Page

Loading...