1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Configuring an 877 ADSL router for BT Business ADSL

Discussion in 'Routing & Switching' started by Metafour Stephen, Dec 7, 2010.

  1. Metafour Stephen

    Metafour Stephen New Member

    5
    0
    1
    Hi,

    It is worth saying first of all that although I am fairly proficient in networking I have found out that configuring Cisco boxes akin to the dark side!! I have got nowhere very fast.

    We have BT Business Broadband and have 13 static IP addresses from BT. I need to be able to configure this 877 router so that:
    • The router has an IP address of 81.xxx.xxx.238 (as prescribed by BT)
    • That the 13 static IP addresses are made available to the firewall/router that sits behind this box. All traffic should, by default, route to the firewall.
    • I guess I need to be able to alter the configuration in the future so I would need an interface set up to be able to do that.

    The problem that I have is that I do not really know where to start. My Cisco 877 is about to take flying lessons unless I can come up with a solution soon.

    I hope some can help me and my sanity.

    Thanks in eager anticipation,
    Stephen Westrip
     
  2. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Not done this on a Cisco but do you not need to:

    a) Give the WAN interface on the Cisco the stand-alone IP
    b) Put the first usable IP from the range on the LAN interface
    c) Remove NAT andy any Firewall config (if any)
    d) On the firewall configure the WAN interface with the second usable IP (use the first usable as a gateway which is on the Cisco)
    e) Put in any NAT\FW rules for published devices.

    Something like that anyways.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  3. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    OK, you want a Cisco 877 in not NAT mode, it's pretty straight forward, below is a config which uses BT for ADSL and is very basic.

    Step 1 - Basic Config

    Telnet onto the device and then we need to configure some usernames, passwords and SSH access in future.

    - Conf t
    - enable secret xxxxxx
    - username admin priviledge 15 secret xxxxxx
    - hostname (router name)
    - aaa new-model
    - crypto key generate rsa (press return) choose 1024 bit
    - line vty 0 4
    - priviledge level 15
    - transport input ssh
    - password xxxxx
    - no access-classs 23 in (this removes the default IP addresses allowed access)
    - write mem

    At this point connect another session via SSH, I recommend using Putty which can be downloaded from http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html and make sure that you can connect via SSH.

    Step 2 - ADSL Config

    - Conf t
    - Interface ATM0
    - no ip address
    - atm vc-per-vp 128
    - no atm ilmi-keepalive
    - pvc 0/38
    - encapsulation aal5mux ppp dialer
    - dialer pool-member 1

    - Conf t
    - interface Dialer1
    - ip unnumbered Vlan1
    - encapsulation ppp
    - dialer pool 1
    - dialer-group 1
    - no cdp enable
    - ppp chap hostname ADSL Username
    - ppp chap password ADSL Password
    - ppp pap sent-username ADSL Username password ADSL Password
    - ppp ipcp address accept
    - hold-queue 224 in

    We tell the Dialer 1 interface to use the IP Address that we will specify on VLAN 1.

    - conf t
    - interface VLAN1
    - ip address 83.x.x.x 255.255.255.x
    - no shutdown

    Step 3 - Routing

    - conf t
    - ip route 0.0.0.0 0.0.0.0 Dialer1

    This sends all traffic to the Dialer1 interface and then out.

    As long as your firewall and Cisco 877 are on the same subnet then traffic will reach you.
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  4. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    I'm going to call you Cisco Cragie from now on. :biggrin
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  5. Metafour Stephen

    Metafour Stephen New Member

    5
    0
    1
    Thanks Craigie for this. It looks great but I do have a couple of questions.

    The box needs a complete reset to get all my previous attempts removed and to give me a clean start. How can I do this?

    I noticed that you mentioned SSH'ing to the 877, which I would be more than comfortable doing, but it does not seem to recognise the default IP address of 10.10.10.1. This has more than likely been changed by me (inadvertently) but I cannot seem to configure the FastEthernet ports with an IP address. It throws an error message stating that IP address cannot be added to L2 Fast Ethernetx.

    Sorry for the further questions.
     
  6. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    LOL, done 6 of these in the last week alone, all with different config.

    Pretty much spend most of my time on networking right now.
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  7. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    No problem mate, following this link and it will show you how to do it, http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_tech_note09186a00802017a1.shtml

    You do however need to be connected via the console cable, again use Putty for this.
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  8. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  9. Metafour Stephen

    Metafour Stephen New Member

    5
    0
    1
    I have tried the reset button but I am not convinced by it. It seems a bit woolly and is not reassuring in the least.
     
  10. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Try this

    1. power off
    2. depress button and power on
    3. hold for say 20 seconds(all lights will come on)

    always worked when I done it, has been a while since I've had to do it though :D
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  11. Metafour Stephen

    Metafour Stephen New Member

    5
    0
    1
    Thank you for your help with this. I have only managed today to try this for the first time.

    I do not get any CD light, but I know the line is working as I am using another device at the moment. To my layman's eyes it seems that when the VLAN kicks in the CD light goes off. Any clues?
     

Share This Page

Loading...