1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco Modular 1721 keeps loosing internet connection.

Discussion in 'Networks' started by albertc30, Oct 11, 2008.

  1. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello you guys.

    Here I am again. My settings in my router worked just fine untill a few days ago.
    While I am surfing online every now and again it just won't respond to my internet requests. There is no lights flashing from the ADSL WIC card and with (sh ip int bri) I can see that the Dialer1 interface as got no IP address and the interface is UP but the line protocol is down and then after a few seconds ( maybe 30 sec) it comes back up to line protocol up.
    Is there a way to make this internet connection an always on connection like any other regular router?
    Here's my router configuration.
    Do not mind the IP address as they have been changed but everything is in the same subnetwork.

    ############################################################


    Interface IP-Address OK? Method Status Protocol
    ATM0 unassigned YES NVRAM up up
    Dialer1 86.162.160.100 YES IPCP up up
    FastEthernet0 192.168.28.14 YES NVRAM up up
    Virtual-Access1 unassigned YES unset up up
    Virtual-Access2 unassigned YES unset up up
    Router#sh run
    Building configuration...

    Current configuration : 1551 bytes
    !
    ! No configuration change since last restart
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip dhcp excluded-address 192.168.28.140
    ip dhcp excluded-address 192.168.28.130
    ip dhcp excluded-address 192.168.28.120
    --More--  !
    ip dhcp pool LocalNetwork
    network 192.168.28.80 255.255.255.248
    default-router 192.168.28.155
    dns-server 194.72.9.34 62.6.40.178
    !
    !
    no ip domain lookup
    ip cef
    no scripting tcl init
    no scripting tcl encdir
    !
    !
    !
    !
    interface ATM0
    no ip address
    atm ilmi-keepalive 300
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    --More--  !
    interface FastEthernet0
    ip address 192.168.28.23 255.255.255.0
    ip nat inside
    speed auto
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    keepalive 18000
    ppp chap hostname bthomehub@btbroadband.com
    ppp chap password 0 password
    ppp pap sent-username bthomehub@btbroadband.com password 0 password
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static tcp 192.168.28.10 7609 interface Dialer1 7609
    ip nat inside source static udp 192.168.28.10 7609 interface Dialer1 7609
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    --More--  !
    access-list 1 permit 192.168.28.16 0.0.0.7
    !
    control-plane
    !
    !
    line con 0
    password cisco
    login
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    no scheduler allocate
    !
    end

    Router#sh int
    ATM0 is up, line protocol is up
    Hardware is DSLSAR (with Alcatel ADSL Module)
    MTU 4470 bytes, sub MTU 4470, BW 448 Kbit, DLY 1140 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ATM, loopback not set
    Encapsulation(s): AAL5 AAL2, PVC mode
    23 maximum active VCs, 256 VCs per VP, 1 current VCCs
    VC Auto Creation Disabled.
    VC idle disconnect time: 300 seconds
    Last input never, output 00:00:17, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3
    Queueing strategy: Per VC Queueing
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    47764 packets input, 51459277 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    32102 packets output, 2957928 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    --More--  Dialer1 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Internet address is 86.162.16.10/32
    MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    DTR is pulsed for 1 seconds on reset
    Interface is bound to Vi2
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 10:09:52
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    47487 packets input, 51455205 bytes
    31833 packets output, 2826015 bytes
    Bound to:
    Virtual-Access2 is up, line protocol is up
    Hardware is Virtual Access interface
    --More--   MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Listen: CDPCP
    Open: IPCP
    PPPoATM vaccess, cloned from Dialer1
    Vaccess status 0x44
    Bound to ATM0 VCD: 1, VPI: 0, VCI: 38, loopback not set
    DTR is pulsed for 5 seconds on reset
    Interface is bound to Di1 (Encapsulation PPP)
    Last input 00:01:14, output never, output hang never
    Last clearing of "show interface" counters 10:09:26
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    47764 packets input, 51459277 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    32105 packets output, 2830130 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    --More--   0 carrier transitions
    --More--  FastEthernet0 is up, line protocol is up
    Hardware is PQUICC_FEC, address is 000f.8f94.4508 (bia 000f.8f94.4508)
    Internet address is 192.168.28.14/29
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 100Mb/s, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:58, output 00:00:02, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    23721 packets input, 2784187 bytes
    Received 511 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    41847 packets output, 51656325 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    --More--   0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    --More--  Virtual-Access1 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Closed
    Base PPPoATM vaccess
    Vaccess status 0x40, loopback not set
    DTR is pulsed for 5 seconds on reset
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 10:09:57
    Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    --More--  Virtual-Access2 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Listen: CDPCP
    Open: IPCP
    PPPoATM vaccess, cloned from Dialer1
    Vaccess status 0x44
    Bound to ATM0 VCD: 1, VPI: 0, VCI: 38, loopback not set
    DTR is pulsed for 5 seconds on reset
    Interface is bound to Di1 (Encapsulation PPP)
    Last input 00:01:19, output never, output hang never
    Last clearing of "show interface" counters 10:09:32
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    47764 packets input, 51459277 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    32105 packets output, 2830130 bytes, 0 underruns
    --More--   0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    Router#sh ip int
    ATM0 is up, line protocol is up
    Internet protocol processing disabled
    --More--  Dialer1 is up, line protocol is up
    Internet address is 86.162.160.100/32
    Broadcast address is 255.255.255.255
    Address determined by IPCP
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is enabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Feature Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    --More--   IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain outside
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled
    --More--  FastEthernet0 is up, line protocol is up
    Internet address is 192.168.28.1
    Broadcast address is 255.255.255.255
    Address determined by non-volatile memory
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Feature Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    --More--   IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain inside
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled
    --More--  Virtual-Access1 is up, line protocol is up
    Internet protocol processing disabled
    --More--  Virtual-Access2 is up, line protocol is up
    Peer address is 216.46.205.156
    Dialer interface is Dialer1
    Router#

    Any comments welcome.
    Cheers,
    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+
  2. ASRsystems Andrew

    ASRsystems Andrew New Member

    7
    0
    18
    Hi

    Can you post the output from 'sho dsl int atm0' please

    I am interested in lookin at the noise/attenuation/activations

    Whole output appreciated

    Regards

    Andrew
    http://www.asrsystems.co.uk
     
    Certifications: CCIE
    WIP: CCVP
  3. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37

    Hello mate.
    Here it is mate.

    sh dsl int atm0
    Alcatel 20150 chipset information
    ATU-R (DS) ATU-C (US)
    Modem Status: Showtime (DMTDSL_SHOWTIME)
    DSL Mode: ITU G.992.1 (G.DMT) Annex A
    ITU STD NUM: 0x01 0x1
    Vendor ID: 'ALCB' 'P '
    Vendor Specific: 0x0000 0x0000
    Vendor Country: 0x00 0xB5
    Capacity Used: 100% 55%
    Noise Margin: 11.0 dB 21.0 dB
    Output Power: 20.0 dBm 12.0 dBm
    Attenuation: 26.5 dB 14.5 dB
    Defect Status: None None
    Last Fail Code: None
    Selftest Result: 0x00
    Subfunction: 0x15
    Interrupts: 1333 (0 spurious)
    PHY Access Err: 0
    Activations: 1
    LED Status: ON
    LED On Time: 100
    LED Off Time: 100
    Init FW: embedded
    Operation FW: embedded
    --More--  SW Version: 3.8131
    FW Version: 0x1A04

    Interleave Fast Interleave Fast
    Speed (kbps): 5248 0 448 0
    Cells: 989787 0 1291040 0
    Reed-Solomon EC: 0 0 0 0
    CRC Errors: 0 0 0 0
    Header Errors: 0 0 0 0
    Bit Errors: 0 0
    BER Valid sec: 0 0
    BER Invalid sec: 0 0

    LOM Monitoring : Disabled

    DMT Bits Per Bin
    00: 0 0 0 0 0 0 0 2 3 5 6 7 7 8 7 7
    10: 8 8 8 8 7 7 6 7 6 6 6 5 5 5 0 0
    20: 0 0 0 0 0 0 4 4 5 5 6 6 7 7 7 7
    30: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 8
    40: 0 8 8 8 8 8 8 8 8 8 8 2 8 8 8 8
    50: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
    60: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
    --More--  70: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
    80: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
    90: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 7
    A0: 7 6 7 7 7 7 7 7 7 7 7 7 7 7 7 7
    B0: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7
    C0: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7
    D0: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7
    E0: 7 7 7 7 7 7 7 7 6 6 6 6 6 6 6 6
    F0: 6 6 6 6 5 6 6 6 6 6 5 5 5 4 4 4

    DSL: Training log buffer capability is not enabled
    Router#

    I am happy that someone has replyd to my post, this is killing me. It is not only with the cisco router but the same happens with my bt home hub.

    Cheers for your help mate
    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+
  4. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    Is your router connected to the master socket in your house? If not I would try connecting into that first and see if the situation improves. If it does then it may be the extension cabling/socket that's causing the issue, if not then it will probably be a problem with the ISP.

    HTH8)
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  5. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello mate.

    There is only one socket here at home and I have also changed the filter by a new one.
    The line is also a bit noise when over the phone and I have experienced that while on the phone the connection does drops.
    I have had BT checking the line and they say that there is nothing wrong with the line. Inclusive, I had a certforums colege that works for BT and he also performed a line checked and found it to be working fine.
     
    Certifications: CCNA
    WIP: 220-701 - A+
  6. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    Does BT provide your internet or just your phone line?
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  7. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    could well be isp is down
     
  8. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Yes mate, they provide phone line and bt broadband
     
    Certifications: CCNA
    WIP: 220-701 - A+
  9. ASRsystems Andrew

    ASRsystems Andrew New Member

    7
    0
    18
    Hi, sorry for taking so long getting back to you

    Re the sho dsl interface command output, I cant see anything obviously wrong :-(

    Config looks OK

    DSL stats good

    Activations: 1
    Noise Margin: 11.0 dB 21.0 dB
    Attenuation: 26.5 dB 14.5 dB
    (I have put some more detailed infor re these stats FYI, sorry if its telling you to suck eggs)

    I would recommend you try replacing the WIC-1ADSL as they are pretty cheap on ebay, and if it is not that you can always sell it back on ebay anyway

    Hope thats helpful



    Activations
    How many times the ISP CCT has reset between the DSLAM and your router. It is normal to get this 2 - 3 per week as the ISP will

    Noise Margin (AKA Signal to Noise Margin or Signal to Noise Ratio)
    Relative strength of the DSL signal to Noise ratio. The higher the number the better for this measurement. In some instances interleaving can help raise the noise margin to an acceptable level.

    6dB or below is bad and will experience no synch or intermittent synch problems
    7dB-10dB is fair but does not leave much room for variances in conditions
    11dB-20dB is good with little or no synch problems
    20dB-28dB is excellent
    29dB or above is outstanding

    Line Attenuation
    Measure of how much the signal has degraded between the DSLAM and the modem. This is largely a function of the distance from the exchange. The lower the dB the better for this measurement.

    20dB and below is outstanding
    20dB-30dB is excellent
    30dB-40dB is very good
    40dB-50dB is good
    50dB-60dB is poor and may experience connectivity issues
    60dB or above is bad and will experience connectivity issues
     
    Certifications: CCIE
    WIP: CCVP
  10. Teebor

    Teebor Nibble Poster

    61
    0
    23
    I had a problem recently with a line that when you were on the phone you could hear lots of noise in the background, also when the phone rang the ADSL connection dropped out. Also if you were browsing the internet you could hear the noise on the phone changing.

    After replacing the filter I still had the same problem, it turned out that the BT master socket (there was only one socket) was at fault and had to be replaced. I managed to get BT to do that but by god was it hard work to get them to come out.
     
    Certifications: A+, Network +, MCSA, CCNA, Coupla MCP's
    WIP: CCNP BCMSN, CVOICE, ITIL
  11. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    And that is the key point. There *shouldn't* be any noise on the line when using the phone. It sounds as if you have a duff joint somewhere between you and the exchange, or it may be in your house wiring.

    Is your 'master socket' a NTE5? (i.e. the front panel split into two). If so remove the lower plate and you will discover another socket. This also disconnects your house wiring. Try seeing if you have noise on this socket. If there is none then the problem is in your house wiring. Otherwise get BT to fix the line.

    Er - IMHO they didn't test very well. Line noise is normally grounds for a repair these days.

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  12. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello.

    Yeah, finally BT engineer came round the house and found that there was a problem with the line just outside my house. The line now is clear of all that crackling and faxing noise that also in my opinion was crashing my Cisco router 1721. It has been 2 days since and my router hasn't crashed since.

    The broadband on the other hand is still slow as ****. I am on BT option 3, the BT engineer said that the exchange is right round the corner which even pissed me off more and said that my line now supports a total of 7.5MBps connection and where I used to download Norton antivirus definitions file at an average speed of 200KBps I am now having only 58KBps. I was told that the exchange performs some sort of test for the next few days to establish my line speed and that it should improve in about 4 to 5 days, so far no improvement took place.

    Today as I went to my router to check the sh flash for any crashinffiles it displayed this;

    %% Low on memory; try again later

    %% Low on memory; try again later

    %% Low on memory; try again later

    %% Low on memory; try again later

    Had to restart it to get access to it, anyone any ideas as to why did/does this happens?

    Cheers,
    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+
  13. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    219 search results await!
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!

Share This Page

Loading...