1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem CISCO 877W configuration

Discussion in 'Networks' started by Globis, Oct 8, 2009.

  1. Globis

    Globis New Member

    6
    0
    1
    Hey everyone,

    I am every new to this router configure, and my boss just asked me to configure this CISCO 877W for the office network. I have tried my best to get codes from everywhere and put them together. However, it doesnt work, please could anyone point out the mistakes please. Thank you so much for your help.

    I put the router on the DSL line, the PCs can get IPs from the router, and also I could log into the router. But there is no interenet connection, also I cant ping anything from the router.

    We are using BT ADSL2+ connection, PPPoA.


     
  2. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Are you using SDM to configure or just cli? Can you telnet to the router and enter

    sh dsl int amt0 and post the firmware version
     
    Last edited: Oct 9, 2009
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  3. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    As you say you copied your config from elsewhere, are you sure you used your own details in the areas you needed to, such as the PVC 0/38 part.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  4. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    8,871
    167
    256
    I don't know squat about Cisco routers, but the date is a smile away.. :biggrin

     
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  5. Globis

    Globis New Member

    6
    0
    1
    Hey guys,

    Thank you so much for your replies. I have double checked with BT, and they are saying we are using:

    ATM Circuit Identifier: VPI:0 VCI:38
    Connection Type: PPPoA

     
  6. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Are you using the SDM(Security Devices Manager)?
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  7. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    access-list 1 permit ip 192.168.1.0 0.0.0.255 any

    ^ thats what i use for my NAT source list.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  8. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    What about

    Code:
    show pppatm session
    
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  9. Globis

    Globis New Member

    6
    0
    1
    ThomasMc, Thank you so much for your replies & help, and I am sorry the late reply for the post. :(

    anyway, I have had a look at the Security Device Manager from CISCO. It would be a very handy tool to have for stupid people like me. :) I will contract CISCO to see if I could get it somehow.

    anyway, back to the problem, I have checked the pppatm session, but at the time, the boardband phone line was not connected. Not sure if this will affect the trouble shooting.

    Thank you so much for your help.

     
  10. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    yes it affects the command output.

    Have you tried changing your NAT statement to the one i posted?
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  11. Globis

    Globis New Member

    6
    0
    1
    danielno8, thank you for your reply. Do you mean:

    HTML:
    ip nat inside source list 1 interface Dialer0 overload
    
    change to ==>
    
    ip nat inside source list 1 ip 192.168.1.0 0.0.0.255 overload
    
    ?
    
    Thank you.
     
  12. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    No this line:

    access-list 1 permit 192.168.1.0 0.0.0.255

    change to:

    access-list 1 permit ip 192.168.1.0 0.0.0.255 any
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  13. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    You should get SDM with this router, did you get any CDs in the box? Also any update on what Danny is suggesting?
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  14. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    danielno8,

    Are you sure that change is going to help?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  15. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    nope, but it definately won't do any harm!
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  16. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    danielno8,

    What kind of access list is "access-list 1?"
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  17. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    aren't you the one with the CCNA?
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  18. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    Globis, i just re-checked my config and i have the same line as you, so no need to change out that line i suggested!
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  19. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Ok so if its ok with r.h.lee then could you connect the line to the cisco877 and then re-run the show pppatm session
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  20. Globis

    Globis New Member

    6
    0
    1
    Hey everyone,

    thank you so much for all the help and advise, the router now is able to get the broadband connection, and it works fine for all wired connections. However the wireless doesnt work, it looks like the PCs couldnt get an IP from the router, but the wired ones can. Is there any suggestion why the router is doing this?

    Thank you so much for all your help guys.

    the current running code on the router:
    HTML:
    !
    ! Last configuration updated on 13/10/2009
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname CISCOrouter
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200 debugging
    logging console critical
    enable secret cisco
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    no ip source-route
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool G4S-pool1
    import all
    network 192.168.1.1 255.255.255.0
    default-router 192.168.1.1 
    dns-server 194.72.9.34 194.72.9.38
    !
    !
    ip tcp synwait-time 10
    no ip bootp server
    no ip domain lookup
    ip domain name yourdomain.com
    ip ssh time-out 60
    ip ssh authentication-retries 2
    !
    !
    crypto pki trustpoint TP-self-signed-633710060
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-633710060
    revocation-check none
    rsakeypair TP-self-signed-633710060
    !
    !
    crypto pki certificate chain TP-self-signed-633710060
    certificate self-signed 01
    3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
    30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274 
    69666963 6174652D 36333337 31303036 30301E17 0D303630 37313831 32353433 
    365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F 
    532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3633 33373130 
    30363030 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100 
    AA7E0863 1E016995 7504E293 F1657305 038E1541 E3DDC119 D2ABDB92 4FE9BEB6 
    9C209590 926C9815 0B264D4D 164160E0 AA2B0174 E7D762FB C26EF9E1 70069858 
    3FF684A6 69B2146F 408CEBA5 58C1E2DB D82DE653 C739268F C00138CD 97BCDB25 
    6123FA2A 298A8362 8F0210EF EF555863 5EAB79C6 D7391AD4 204BB01E D677FD95 
    02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D 
    11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F 
    0603551D 23041830 16801471 AF934650 7D2ACCFA 3F914931 0D98CA52 A6FB4D30 
    1D060355 1D0E0416 041471AF 9346507D 2ACCFA3F 9149310D 98CA52A6 FB4D300D 
    06092A86 4886F70D 01010405 00038181 003D7256 7B2874F5 B6428DDC 95139A92 
    B8764E65 6D01527A 09E90068 6084B420 BCC41F7B 49A2A950 6C0D7C2D F4E0C7A7 
    A3145256 E702D88F 25C95302 7F94F6B9 9D97F4F3 A3C11AD2 44B4F426 46B3D7BF 
    82CCBDC6 A0DCA3E5 656140F8 59B284CB 8CD9D6B1 D20D12D1 63A42919 7807D655 
    CC395D16 4CAFE02D D70D772D 72DAF1B7 4B
    quit
    username cisco privilege 15 secret 0 cisco
    !
    ! 
    !
    !
    !
    !
    interface ATM0
    no ip address
    no shutdown
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto 
    !
    interface ATM0.1 point-to-point
    description BT ADSL2+ connection
    no ip address
    no shutdown
    no snmp trap link-status
    pvc 0/38 
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    no shutdown
    !
    encryption mode ciphers tkip
    !
    world-mode dot11d country GB indoor
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0
    rts threshold 2312
    channel 2462
    station-role root
    bridge-group 1
    bridge-group 1 spanning-disabled
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    no shutdown
    !
    ssid CISCOW877
    dot11 ssid CISCOW877
    authentication open
    authentication key-management wpa
    guest-mode!!!
    wpa-psk ascii cisco
    !
    interface Vlan1
    description DHCP-LAN
    ip address 192.168.1.1 255.255.255.0
    no shut
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    ip tcp adjust-mss 1452
    !
    interface Dialer0
    ip address negotiated
    no shut
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname <BT username>
    ppp chap password <BT password>
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    ip nat inside source list 1 interface Dialer0 overload
    !
    logging trap debugging
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    !
    !
    control-plane
    !
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end 
    
     
    Last edited: Oct 14, 2009

Share This Page

Loading...