1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco 877 no wan IP

Discussion in 'Routing & Switching' started by Peteratabb, Apr 10, 2008.

  1. Peteratabb

    Peteratabb New Member

    4
    0
    1
    Hello everyone!

    I have a new Cisco 877 router which does'nt want to get an IP address from our ADSL provider, if anyone can check my config below that would be great!
    The ATM says its UP, and line is UP, but no IP address from our ISP .
    I've tryed IP address as 'Negotiated' and 'Dynamic IP' but no joy.

    Current configuration : 4480 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname yourname
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    !

    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool sdm-pool
    import all
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    lease 0 2
    !
    !
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    no ip domain lookup
    ip domain name yourdomain.com
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname info_xyz
    ppp chap password 0 info_xyz
    !
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface Dialer0 overload
    !
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.10.0 0.0.0.7
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    !
    control-plane
    !
    line con 0
    login local
    no modem enable
    line aux 0
    line vty 0 4
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    end

    If you need any debug info let me know, i'm still learning the IOS commands but will give it a try!
    Thanks!!
     
  2. Peteratabb

    Peteratabb New Member

    4
    0
    1
    Hello Everyone!
    I've pasted the results from the "show dsl interface atm 0" command, seems to show the line speed is ok...

    Alcatel 20190 chipset information
    ATU-R (DS) ATU-C (US)
    Modem Status: Showtime (DMTDSL_SHOWTIME)
    DSL Mode: ITU G.992.1 (G.DMT) Annex A
    ITU STD NUM: 0x03 0x2
    Vendor ID: 'STMI' 'TSTC'
    Vendor Specific: 0x0000 0x0000
    Vendor Country: 0x0F 0xB5
    Chip ID: C196 (0)
    DFE BOM: DFE3.0 Annex A (1)
    Capacity Used: 100% 67%
    Noise Margin: 5.0 dB 16.0 dB
    Output Power: 16.5 dBm
    Attenuation: 61.0 dB 30.5 dB
    Defect Status: None None
    Last Fail Code: None
    Watchdog Counter: 0x21
    Watchdog Resets: 0
    Selftest Result: 0x00
    Subfunction: 0x00
    Interrupts: 8252 (0 spurious)
    PHY Access Err: 0
    Activations: 1
    LED Status: ON
    LED On Time: 100
    LED Off Time: 100
    Init FW: init_AMR-3.0.014_no_bist.bin
    Operation FW: AMR-3.0.014.bin
    FW Source: embedded
    FW Version: 3.0.14

    Interleave Fast Interleave Fast
    Speed (kbps): 2816 0 448 0
    Cells: 1342 0 6785100 0
    Reed-Solomon EC: 62551 0 19 1
    CRC Errors: 143 0 3 0
    Header Errors: 130 0 6 3
    Total BER: 2975E-9 0E-0
    Leakage Average BER: 2703E-9 0E-0

    ATU-R (DS) ATU-C (US)
    Bitswap: enabled enabled
    Bitswap success: 0 0
    Bitswap failure: 0 0


    I’m getting abit worried that I’m stuck on getting an IP address , as this router will also manage all traffic and VPN connections for our company.

    Any hints, tips and help would be much appreciated!
     
  3. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    I'm no expert but here goes :D

    How did you confirm that your not getting an ip address? have you tested the connection via the SDM? also wheres you default route and DNS

    ip name-server a.b.c.d
    0.0.0.0 0.0.0.0 Dialer0

    Who is your provider BTW, may be an encapsulation problem
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  4. Peteratabb

    Peteratabb New Member

    4
    0
    1
    I've been useing the SDM for all the configuration, and the 'Test Connection' gets as far as checking DNS settings and fails - presumably as the router has been unable to obtain the IP & DNS setings from the ISP.

    Regarding the name server and default route, i thought the SDM would take care of things like that? but if not then let me know the commands and i'll type them in.

    The Provider we're useing is Eclipse who assign us an IP.
     
  5. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    I would follow the troubleshooting steps on this page and make sure you are talking to the ISP.

    Do they definitely provide you with IP information via DHCP?
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  6. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    either telnet and then type conf t followed by the above commands(exit with ctrl+z) and then type reload or in the SDM(Full not Express)

    Goto Routing to setup default route and then visit Additional tasks -> DNS

    [added]
    Just looked at your ISP's website and there dns server are so replace a.b.c.d with these(enter 1 at a time)

    212.104.130.9
    212.104.130.65
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  7. Peteratabb

    Peteratabb New Member

    4
    0
    1
    Success!
    Thank you Stoney & ThomasMC for your comments!

    In particular the Cisco PPPoa troubleshooting guide showed me the 'debug ppp neg' command, and i saw the router authenticate and get an IP.

    Next step was to manually add the DNS servers to both the router and my laptop,
    add the default route on Dialer0 (ticking the 'make as default route' tick box)
    Setup the basic firewall
    Check the basic NAT settings
    and I’m online.

    Interestingly, the SDM 'Edit interface/connection' view still shows ATM0.1 IP="no IP address" even though its all working, and i think this was stopping me looking further into the problem.

    Next step is to get the router to pass the DNS settings automatically to its DHCP clients, and setup the VPN access, but i'll look at these later.

    Thanks again for your helps!
     
  8. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    I'm sure the sdm will only display static ip's on the interface, i would also suggest looking at your config for something along the lines of
    Code:
    strict-http action reset alarm 
    
    if you find this line i would change it to
    Code:
    strict-http action allow alarm
    
    infomation thanks to the Spicey_One :D
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)

Share This Page

Loading...