Problem Cisco 877 no t'internet - help!

Discussion in 'Internet, Connectivity and Communications' started by markyzno, Apr 7, 2010.

  1. markyzno

    markyzno New Member

    6
    0
    1
    Hi Chaps,

    Firstly i'm new here so a big hello to all! :D

    Secondly, have been thrown in at the deep end with a Cisco 877 and cant for the life figure out why the router isnt getting an IP from the BT DHCP pool.

    Any help would be MUCHLY appreciated.

    Heres my config.....


    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname <hostname>
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    no logging buffered
    enable secret 5 <password>
    !
    no aaa new-model
    !
    crypto pki trustpoint TP-self-signed-1186632268
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1186632268
    revocation-check none
    rsakeypair TP-self-signed-1186632268
    !
    !
    crypto pki certificate chain TP-self-signed-1186632268
    certificate self-signed 02 nvram:IOS-Self-Sig#6.cer
    dot11 syslog
    ip source-route
    ip dhcp excluded-address 192.168.0.254
    !
    ip dhcp pool <DHCP POOL>
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.254
    dns-server <isp dns servers>
    !
    !
    ip cef
    ip name-server <dns1>
    ip name-server <dns2>
    ip name-server <internal dns>
    ip ddns update method sdm_ddns1
    DDNS both
    !
    ip ddns update method sdm_ddns2
    DDNS both
    !
    !
    !
    !
    !
    username <me> privilege 15 secret 5 <password>
    username <colleague> privilege 15 secret 5 <password>
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    description WAN interface to BT using DHCP
    mtu 1500
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip route-cache policy
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description WAN OUTSIDE
    ip nat outside
    ip virtual-reassembly
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    description LAN Inside Interface
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    !
    interface Dialer1
    ip ddns update hostname <isp hostname>
    ip ddns update sdm_ddns2
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username <username from ISP> password 0 <ISP password>
    !
    interface Dialer0
    ip address <Public IP> <Subnet>
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username <ISP Username> password 0 <ISP Password>
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http access-class 3
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    !
    ip nat pool BTPUBLIC <Public IP range>
    ip nat inside source list 1 interface Dialer0 overload
    !
    ip access-list standard VTY-ACL
    permit 192.168.0.0 0.0.0.255
    !
    access-list 1 permit any
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 3 remark HTTP Access-class list
    access-list 3 remark SDM_ACL Category=1
    access-list 3 permit 192.168.0.0 0.0.0.255
    access-list 3 deny any
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY-ACL in
    password <password 4 Telnet>
    login local
    transport input telnet
    !
    scheduler max-task-time 5000
    end
     
  2. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    Hi markyzno,

    I notice you have two dialer interfaces configured, and you have an atm subinterface but you are not using it. I would suggest some changes to the configuration:

    Remove the atm0.1 subinterface.

    no ip route 0.0.0.0 0.0.0.0 Dialer0
    no interface Dialer0

    int dialer1
    dialer-group 1

    int atm0
    ip nat outside

    dialer-list 1 protocol ip permit

    no ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source list 1 interface Dialer1 overload

    You might want to try setting the atm0 mtu to 1478 - this is slightly more efficient, but not needed.

    Also, your dhcp pool default-router and excluded address don't match the router's internal ip address.

    And of course check all the usual stuff, username, password vpi/vci, make sure interfaces are not shutdown, etc.


    Spice_Weasel
     
    Last edited: Apr 8, 2010
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  3. markyzno

    markyzno New Member

    6
    0
    1
    Many thanks for the heads up, changing the conf as we speak and when the office is quiet will unleash the new conf and hopefully t-internet, will keep you posted

    :D
     
  4. markyzno

    markyzno New Member

    6
    0
    1
    So, new conf looks like this........ Thoughts (havent tested as yet)?

    Using 2963 out of 131072 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname <hostname>
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    no logging buffered
    enable secret 5 <password>
    !
    no aaa new-model
    !
    crypto pki trustpoint TP-self-signed-1186632268
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1186632268
    revocation-check none
    rsakeypair TP-self-signed-1186632268
    !
    !
    crypto pki certificate chain TP-self-signed-1186632268
    certificate self-signed 01 nvram:IOS-Self-Sig#6.cer
    dot11 syslog
    ip source-route
    ip dhcp excluded-address 192.168.0.254
    !
    ip dhcp pool <pool name>
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.254
    dns-server <name servers>
    !
    !
    ip cef
    ip name-server <dns 1 from BT>
    ip name-server <dns 2 from BT>
    ip name-server <dns 3 Internal DNS server>>
    ip ddns update method sdm_ddns1
    DDNS both
    !
    ip ddns update method sdm_ddns2
    DDNS both
    !
    !
    !
    !
    !
    username <my name> privilege 15 secret 5 <password>
    username <my name 2> privilege 15 secret 5 <password>
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    description WAN interface to BT using DHCP
    mtu 1478
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    ip route-cache policy
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    description LAN Inside Interface
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    !
    interface Dialer1
    ip ddns update hostname <BT gateway hostname>
    ip ddns update sdm_ddns2
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username <BT log in> password 0 <BT password>
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http access-class 3
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    !
    ip nat pool BTPUBLIC <public IP range> netmask 255.255.255.240
    ip nat inside source list 1 interface Dialer1 overload
    !
    ip access-list standard VTY-ACL
    permit 192.168.0.0 0.0.0.255
    !
    access-list 1 permit any
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 3 remark HTTP Access-class list
    access-list 3 remark SDM_ACL Category=1
    access-list 3 permit 192.168.0.0 0.0.0.255
    access-list 3 deny any
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY-ACL in
    password <Telnet password>
    login local
    transport input telnet
    !
    scheduler max-task-time 5000
    end
     
  5. craigie

    craigie Terabyte Poster

    3,020
    174
    155
    I would also recommend disabling http server as well.
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  6. markyzno

    markyzno New Member

    6
    0
    1
    still no joy..... :cry:

    Am starting to think that BT Business Broadband might be the issue here.

    Will run various debugs later.
     
  7. markyzno

    markyzno New Member

    6
    0
    1
    starting to pull my hair out now :eek:

    latest conf...

    CD light is green, rx and tx lights flutter and shes trying to connect to BT but its not picking up an IP address from BT....

    Any ideas much appreciated, have kept in ip http server so i can quickly cross check things on the GUI.

    I know theres a couple of entries for internal DHCP but its Internet facing i am concerned with....

    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname <name>
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    no logging buffered
    enable secret 5 <password>
    !
    no aaa new-model
    !
    crypto pki trustpoint TP-self-signed-1186632268
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1186632268
    revocation-check none
    rsakeypair TP-self-signed-1186632268
    !
    !
    crypto pki certificate chain TP-self-signed-1186632268
    certificate self-signed 01 nvram:IOS-Self-Sig#6.cer
    dot11 syslog
    ip source-route
    ip dhcp excluded-address 192.168.0.0 192.168.0.254
    !
    ip dhcp pool <name>
    dns-server 192.168.0.2
    default-router 192.168.0.254
    !
    !
    ip cef
    ip ddns update method sdm_ddns1
    DDNS both
    !
    ip ddns update method sdm_ddns2
    DDNS both
    !
    ip address-pool dhcp-pool
    ip dhcp-server 192.168.0.2
    !
    !
    !
    !
    username <me> privilege 15 secret 5 <password>
    username <company> privilege 15 secret 5 <password>
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    description BT using DHCP
    mtu 1478
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    ip route-cache policy
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    description LAN Inside Interface
    ip address 192.168.0.254 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    no ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname <BT username>
    ppp chap password 0 <Bt Password>
    ppp pap sent-username <Bt username> password 0 <password>
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http access-class 3
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    ip access-list standard VTY-ACL
    permit 192.168.0.0 0.0.0.255
    !
    access-list 1 permit any
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 3 remark HTTP Access-class list
    access-list 3 remark SDM_ACL Category=1
    access-list 3 permit 192.168.0.0 0.0.0.255
    access-list 3 deny any
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY-ACL in
    password <telnet password>
    login local
    transport input telnet
    !
    scheduler max-task-time 5000
    end


    cheers chaps.
     
  8. DanFogler

    DanFogler New Member

    8
    0
    1
    You should run a debugger, if that does not help contact a Cisco service provider :)
     
    Last edited by a moderator: Aug 22, 2011
  9. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    172
    211
    Braaaiiiiinnnnmssssss!!!!!!


    This thread is over a year old. Just a guess, but I think the problem has been solved one way or another.
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.