1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco 877 ADSL problem connecting

Discussion in 'Routing & Switching' started by gastonp50, Mar 30, 2008.

  1. gastonp50

    gastonp50 New Member

    1
    0
    1
    Hello,

    I’ve been trying to configure the Cisco 877 ADSL for access to Internet . The fact is that, although I’ve been able to connect it to my ISP, the router cannot connect after it is rebooted. I haven’t configured a Cisco router before and so I would be grateful if someone could help me find out what I’ve been doing wrong.

    The problem is the following. The only way I’m able to connect to Internet is starting with a blank startup-config and using the Security Device Manager (SDM). However, when I copy the configuration into the NVRAM using the command-line "write memory" or "copy running-config nvram:" in a Hyper Terminal session and I reboot, the router appears to be unable to establish a physical connection to my ISP. The router keeps hanging-up and trying again while the ADSL CD led keeps blinking. There is also an intermittent beep sound indicating the router hanging-up.

    Specifically what I do is the following. I start a Hyper Terminal session with a blank startup-config. At the prompt “Router>” I use the command-lines "enable", "configure terminal" and "ip http server" to be able to access the SDM in the router. And finally, I give the router an IP address in the same subnet or LAN where my computer is connected by using the command-line "interface vlan1 192.168.01 255.255.255.0". Now I’m able to configure the router by using the http protocol following the menu in the SDM. The following is the output obtained by the command-line show running-config:

    Building configuration...

    Current configuration : 1387 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxxxxxxxxx@xxxxxxxx.xxx
    ppp chap password 0 xxxxxxxx
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    ip http server
    no ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    !
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.0.0 0.0.0.255
    dialer-list 1 protocol ip permit
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    !
    scheduler max-task-time 5000
    !
    webvpn context Default_context
    ssl authenticate verify all
    !
    no inservice
    !
    end

    This works fine as long as I don’t reboot the router as explained above.

    On the other hand, when I enter all the above commands manually using the command-line in a Hyper Terminal session instead of using the SDM, there is an error that it didn’t appear before. Each time I enter the command-line "ip nat inside" and "ip nat outside" for the interfaces "vlan1" and "dialer0" respectively, there is the following error: “NAT: Error activating CNBAR on the interface vlan1” and “NAT: Error activating CNBAR on the interface dialer0" corresponding to the interfaces "vlan1" and "dialer0” respectively. This error appears when rebooting the router as well. However I’ve noticed that it doesn’t appear when using the SDM and checking the output obtained in the Hyper Terminal session. I wonder whether this error is relevant or can give any clue to resolve the problem.

    In conclusion, the fact is that the router works since it is able to connect to my broadband account …at least when using the SDM and starting from a blank startup-config. This suggests this could just be a trivial problem of configuration. Therefore I hope somebody could help me to find out a solution for the rebooting-internet-connection problem.

    Best regards,
    gapadi
     
  2. MacAllan

    MacAllan Byte Poster

    249
    6
    30
    Do you mean after getting it to work with SDM ( and the running-config is that which you have given us above), you ran
    'copy running-config nvram:startup-config'?

    After you've done this, and do 'show startup-config', is the startup-config listed the same as the running config that SDM created (that works)? After a reboot, what does the startup-config look like? - is it the same?

    Do a 'show version' - what is the config register?

    I suspect the config register is telling the router to boot from a different (or default) file.

    Reading that back, I haven't explained it very well have I... ho hum. Ask if it isn't clear.
     
    Certifications: A+, N+, CCNA
    WIP: CCNP, Linux+
  3. jake.b

    jake.b New Member

    1
    0
    1
    Please post the output of debug ppp authentication and debug atm events, after performing a shut then no shut on the atm interface.
     
  4. Thedon

    Thedon New Member

    2
    0
    1
    Concerning the physical connection problem, try changing the dsl operating mode.

    From a cli enter the following commands:

    en
    conf t
    int atm0
    dsl operating-mode ansi-dmt
    wr mem



    Try that to see if it keeps your internet connection alive.
     
  5. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    You may want to look at updating the DSL Firmware for the router. I know there have been problems with the 800 series routers not communicating with DSLAM's properly. The latest FW updates should resolve that problem.

    When you reboot your router are you able to view the configuration you saved previously? It could be that the config is not saving for some reason?
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  6. Bobbin1975

    Bobbin1975 New Member

    8
    0
    20
    Hi,

    Here's my config that I generally use for all the router's....

    My need a bit of tweeking but should do the job....

    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Test
    !
    !
    ip subnet-zero
    ip name-server xxx.xxx.xxx.xx
    ip name-server xxx.xxx.xxx.x
    !
    !
    !
    !
    !
    interface ATM0/0/0
    no shutdown
    no ip address
    ip nat outside
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface fa0/0
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    speed auto
    no shutdown
    !
    interface Dialer0
    ip address negotiated
    ip accounting output-packets
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxxx@xxxx.xxxx.co.uk
    ppp chap password 0 xxxxxxxx
    !
    ip nat inside source list 122 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    !
    access-list 122 permit ip 10.10.10.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    no scheduler allocate
    end

    Hope this helps.:biggrin

    Bobbin
     
    Certifications: NVQ Level 3 IT, HND Computer Studies
    WIP: CCNA

Share This Page

Loading...