1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CISCO 857 Setup problem with Pipex

Discussion in 'Routing & Switching' started by Haiden John, Nov 29, 2008.

  1. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    Trying to get a Cisco 857 router to connect with my existing Pipex ADSL connection but having problems with config. At the moment using a Belkin modem which serves a workgroup and been fine for the last 9 months but recently installed a server to handle files etc. The intention of using the Cisco was to provide users with access to the server when working off site.

    Originally had the Cisco connected to server and tried to set up config that way but kept getting too many errors in SDM so it is now just connected to my PC and the ADSL line.

    In the end I reset the router back to its factory default and put basic config back in using SDM. This got me to the point where the CD light was fixed on and TX/RX showed traffic but failed at IP Domain lookup. Then following other posts on this site, pasted in what I thought was missing to the config file and managed to get to the last part of the SDM test which was the ping, that failed.

    The message was:-

    Ping to the destination host(s) failed. The possible reason may be one of the following, 1. The detected DNS servers or the IP address or hostname specified are unreachable or not responding. 2. In case of DSL interfaces, this may be due to mismatch of encapsulation at the remote end. 1. Contact your WAN administrator or ISP and check the DNS server configuration, or retry with a different IP address / hostname. 2. Contact your WAN administrator or ISP and verify the encapsulation.

    I have attached my config file and would really appreciate it if someone could point me in the right direction as I have lost nearly 4 days on this now and at the point of buying a different router. I know from reading the manual that there is still a lot to do to set up the rest of my config for external access and use with the server, nightmare!

    Thanks

    John
     

    Attached Files:

    Certifications: C.Eng
  2. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    I can ping the fixed address given by Pipex but cannot ping any other address such as Google, just get timed out error.
     
    Certifications: C.Eng
  3. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    I am *NOT* a Cisco person, but here are some random thoughts.

    Does the Belkin not have the capability for a DMZ or port-forwarding? This would allow you to log into your 'server'.

    What is the server? What OS? How set up?

    One possible reason that you had trouble when connecting the server is that you may have had a DHCP server running on it, and as your routers also have this running this will cause problems.

    What IP address does your PC have when connected to the Cisco?

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  4. onoski

    onoski Terabyte Poster

    3,120
    51
    154
    Hi John,

    Looking at your default gateway address on the config text file you attached it's set to 10.x.x.x is this what your ISP uses? I believe it needs to be your current ISP's ip address for the default gate i.e. 192.168.x.x.
     
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  5. onoski

    onoski Terabyte Poster

    3,120
    51
    154
    Hi John, it would be nice to formally introduce yourself to the CF forums and lets know what interest you about IT or vice versa.

    Sorry just noticed you haven't done this yet but asking for assistance instead so no offence intended.
     
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  6. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Im no Cisco expert but is that not the LAN gateway? Therefore the 10.x.x.x IP is ok.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  7. onoski

    onoski Terabyte Poster

    3,120
    51
    154

    So where is the default gateway on the config?
     
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  8. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    default-router 10.10.10.1

    The actual Cisco router itself loosk like LAN gateway on this setup, the other interface (with the Pipex details) looks to be the WAN interface onto the Belkin router.

    It may be a NAT issue or the interfaces (between the Belkin and Cisco) are not configured correctly.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  9. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    The Belkin router is no longer connected when trying to get the Cisco up and running, all I have is my desk PC Lan cable to Cisco Router and then Cisco router to the ADSL connection. The belkin modem, other computers, switch, server etc are all disconnected.

    We asked Pipex for a gateway address but they said that they would change every time we connected so there was no point in specifying one. Noticed that when teh Belkin is connected it gives a gateway address so guess could make a note of it and try it on the Cisco unit but not sure how to specify it in config.

    Will put additional personel info in later on as just going out now

    Thanks John
     
    Certifications: C.Eng
  10. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Ahhh, I see.

    Do you have a dynamic IP for your ADSL connection? If so you may have to configure the WAN interface on the Cisco to be dynamic so it picks up the new IP each time.

    If you have a static IP then Pipex should give you static gateway as well so you can configure the WAN interface correctly.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  11. onoski

    onoski Terabyte Poster

    3,120
    51
    154

    Alright sparky, that clears things up and thanks for your valid input.
     
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  12. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    Thanks for input.

    Looks like the Cisco is going into the bin. Got a fixed IP from Pipex but they still say after telephone call thsi evening (business ADSL so 24/7) no such thing as a fixed Gateway, so not much I can do as they are the ISP.

    Tried the Gateway that the Belkin was picking up and managed to work out where it went in the config file but still no result. No idea what to try now so the simplest option and most cost effective regarding time I think is to buy a different make that is simpler config. Netgear here we come!
     
    Certifications: C.Eng
  13. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    The gateway address is usually supplied in the PPP setup - most routers do this, and I'd be surprised if the Cisco doesn't.

    And why not use the Belkin to get things going?

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  14. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    Hi Harry

    The Belkin modem has been an excellent unit and had it for over 5 years now but the last few monthes been having problems with the voltage regulator inside overheating and shutting down. Replaced with external power supply (do electronics and automation for a living so ok with this fix) but in the long term wanted to change whole unit.

    I thought that I had to have a fixed IP address from my ISP to gain external access to my server and not dynamic. If that's correct and I have to have fixed IP then from info supplied by Pipex I can't have a fixed gateway and from what has been said here the Cisco cannot work without one so conclusion I have come to is the Cisco is limited in its application.

    After looking around other sites it looks like the IOS I have for the Cisco unit is an early development one version 12.3 and unstable, Cisco have upgraded it since then several times. This unit was brought second hand (the unit came out of a large commercial network that was being upgraded, so known working) and after looking on their web site it appears that unless you buy a service contract from them you cannot get the later IOS.

    Thanks John
     
    Certifications: C.Eng
  15. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    Er - I may be wrong (as I said - I'm not a Cisco person) but the line
    Code:
    ip route 0.0.0.0 0.0.0.0 Dialer0
    should mean that you don't need to know the gateway address?

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  16. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    Hi Haiden,

    The problem is nat - although you have specified in the interfaces that will participate in nat, you have not defined what you want to nat - so you can ping your own interface, but everything else is unreachable.

    You'll need to add something like this:

    access-list 125 permit ip 10.10.10.0 0.0.0.255 any
    route-map NAT permit 10
    match ip address 125
    ip nat inside source route-map NAT interface Dialer0 overload

    I would also strongly recommend adding the following as well:

    access-list 20 per 10.10.10.0 0.0.0.255 log
    access-list 20 deny any log

    ip http access-class 20
    line vty 0 4
    access-class 20 in

    This will limit access to the router to only hosts with source ip addresses from your network.

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  17. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    Hi Spice_Weasel

    Thanks for info and sorry for late reply, but only back in this afternoon to try out.

    Pasted the extra part of your code into config file and also had to add the DNS entries because SDM test failed after recognising the external IP address, but still get the same result with it failing at ping test in SDM, I have attached the modified file.

    Had a look at the other post's you have answered on similar question and my config looks the same, tottaly stumped.

    Thanks John
     

    Attached Files:

    Certifications: C.Eng
  18. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    What are you attempting to ping? An IP address, or a domain name?

    I *assume* the bogus entries for the DNS servers are you obfuscating private settings - if not then the correct entries need to be made.

    I've seen the line "ppp ipcp dns request" on other settings files.

    Without DNS set correctly you should be able to ping a site using it's IP address.

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  19. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    Hi Harry

    Yes DNS server entries have been changed from the ones given by my provider as has the providers fixed IP address.

    I can ping the fixed IP for pipex but cannot ping google on 74.125.77.104 using the Cisco modem. Fine with our other ADSL modem though, so know its correct IP address for Google.

    I will try "ppp ipcp dns request" in the config file and let you know what happens.

    Thanks John
     
    Certifications: C.Eng
  20. Haiden John

    Haiden John Bit Poster

    15
    0
    21
    Harry

    Sorry for delay in reply but only just managed to get back in office and reload files, :D success!! Router is running fine so now need to set up the VPN for external access to network. I have afew questions on this but think it would be best to start a new thread,

    Thanks all for your help it has been greatly appreciated,

    John
     
    Certifications: C.Eng

Share This Page

Loading...