1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco 2620 not receiving routing updates

Discussion in 'Routing & Switching' started by GC, Feb 23, 2009.

  1. GC

    GC New Member

    6
    0
    1
    Hi,

    In the process of setting-up a two router (C2620 & C2503) lab in
    prepartion for CCNA study. Have connected via DCE/DTE crossover.
    Probleming with C2620 in that it appears it does not receive any
    routing updates.

    C2503#show run
    Building configuration...

    Current configuration:
    !
    version 11.2
    no service password-encryption
    no service udp-small-servers
    no service tcp-small-servers
    !
    hostname C2503
    !
    enable secret 5 $1$7LOG$AH3gZ1sgy6BlVlXCqwcxQ/
    enable password no
    !
    !
    interface Ethernet0
    ip address 192.168.3.254 255.255.255.0
    no mop enabled
    !
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    ip address 192.168.2.2 255.255.255.0
    no keepalive
    clockrate 64000
    !
    interface BRI0
    no ip address
    shutdown
    !
    router igrp 1
    network 192.168.2.0
    network 192.168.3.0
    !
    no ip classless
    !
    line con 0
    line aux 0
    line vty 0 4
    password yes
    login
    !
    end

    C2503#
    IGRP: received update from 192.168.2.20 on Serial1
    IGRP: Update contains 0 interior, 1 system, and 0 exterior routes.
    IGRP: Total routes in update: 1
    IGRP: sending update to 255.255.255.255 via Ethernet0 (192.168.3.254)
    IGRP: Update contains 0 interior, 2 system, and 0 exterior routes.
    IGRP: Total routes in update: 2
    IGRP: sending update to 255.255.255.255 via Serial1 (192.168.2.2)
    IGRP: Update contains 0 interior, 1 system, and 0 exterior routes.
    IGRP: Total routes in update: 1
    IGRP: received update from 192.168.2.20 on Serial1
    IGRP: Update contains 0 interior, 1 system, and 0 exterior routes.
    IGRP: Total routes in update: 1

    C2503#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
    BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
    candidate default
    U - per-user static route, o - ODR

    Gateway of last resort is not set

    I 192.168.1.0/24 [100/8486] via 192.168.2.20, 00:00:50, Serial1
    C 192.168.2.0/24 is directly connected, Serial1
    C 192.168.3.0/24 is directly connected, Ethernet0

    C2620#show run
    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname C2620
    !
    enable secret 5 $1$hER3$LXK9tA9hGnNHlWSewM/dG1
    enable password password
    !
    clock timezone GMT 0
    clock summer-time gmt recurring
    ip subnet-zero
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.245 255.255.255.0
    no ip directed-broadcast
    full-duplex
    no mop enabled
    !
    interface Serial0/0
    no ip address
    no ip directed-broadcast
    shutdown
    !
    interface Serial0/1
    ip address 192.168.2.20 255.255.255.0
    no ip directed-broadcast
    no keepalive
    !
    router igrp 1
    network 192.168.1.0
    network 192.168.2.0
    !
    ip classless
    ip http server
    !
    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password passw0rd
    login
    !
    no scheduler allocate
    end

    C2620#
    07:54:49: IGRP: sending update to 255.255.255.255 via FastEthernet0/0
    (192.168.1.245)
    07:54:49: IGRP: Update contains 0 interior, 1 system, and 0 exterior
    routes.
    07:54:49: IGRP: Total routes in update: 1
    07:54:49: IGRP: sending update to 255.255.255.255 via Serial0/1
    (192.168.2.20)
    07:54:49: IGRP: Update contains 0 interior, 1 system, and 0 exterior
    routes.
    07:54:49: IGRP: Total routes in update: 1
    07:56:06: IGRP: sending update to 255.255.255.255 via FastEthernet0/0
    (192.168.1.245)
    07:56:06: IGRP: Update contains 0 interior, 1 system, and 0 exterior
    routes.
    07:56:06: IGRP: Total routes in update: 1
    07:56:06: IGRP: sending update to 255.255.255.255 via Serial0/1
    (192.168.2.20)
    07:56:06: IGRP: Update contains 0 interior, 1 system, and 0 exterior
    routes.
    07:56:06: IGRP: Total routes in update: 1

    C2620#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
    BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
    candidate default
    U - per-user static route, o - ODR
    T - traffic engineered route

    Gateway of last resort is not set

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    C 192.168.2.0/24 is directly connected, Serial0/1

    The above output shows both routers sending routing packets, and that
    C2503 receives and processes, but C2620 does not appear to receive
    even though the serial link is working.

    Can anyone offer an explanation?

    TIA,

    GC
     
  2. GC

    GC New Member

    6
    0
    1
    Forgot to mention that the same behaviour is observed when the routers were config'd to use RIP instead of IGRP. The routers have two (2) serial ports and the DCE/DTE cable has been used in all four possible setups, i.e. S0/S0, S0/S1, S1/S0/ S1/S1, and with both routers config'd to provide the clock timing, i.e. clock rate 64000.
     
  3. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    Do you have anything plugged in to the Ethernet 0 interface of the 2503? If not, I assume you do have something plugged into the Fa0/0 interface of the 2620, right?
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  4. GC

    GC New Member

    6
    0
    1
    Hi Boson,

    Thank you kindly for your reply.

    Yes, both routers are plugged into a C2900XL which is, normally, configured for two VLANs (1, 2) with a router attached to each.

    C2900>show int status
    Port Name Status Vlan Duplex Speed Type
    ------- ------------------ ------------ -------- ------ ------- ----
    Fa0/16 connected 1 A-Full A-100 100BaseTX/FX
    Fa0/18 connected 2 A-Half A-10 100BaseTX/FX

    When both routers are attached to the same VLAN, both report receiving updates from invalid source:

    C2620#
    00:18:00: IGRP: received update from invalid source 192.168.3.254 on FastEthernet0/0

    C2503#
    IGRP: received update from invalid source 192.168.1.245 on Ethernet0
    IGRP: received update from 192.168.2.20 on Serial1

    This behaviour is, as I understand it, normal. The C2503 also reports receiving a valid update via the serial link.

    C2503#show int serial 0
    Serial0 is administratively down, line protocol is down
    C2503#show int serial 1
    Serial1 is up, line protocol is up

    C2620#show int serial 0/0
    Serial0/0 is administratively down, line protocol is down
    C2620#show int serial 0/1
    Serial0/1 is up, line protocol is up

    GC
     
  5. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    When you've got things attached in a ring like that, you're likely going to have a looped condition, which will shut down an interface. What's the interface status on your Ethernet interfaces?
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  6. GC

    GC New Member

    6
    0
    1
    C2503#show int ethernet 0
    Ethernet0 is up, line protocol is up

    C2620#show int fast 0/0
    FastEthernet0/0 is up, line protocol is up

    There shouldn't be a ring, as the routers are normally attached to different VLANs. So unless there is a fault with the C2900XL there is no way for a ring to form. Attaching to the same VLAN was simply a test to check on whether routing packets were being sent/received via the ethernet connection.
     
  7. GC

    GC New Member

    6
    0
    1
    Further testing with the use of a 2611 router I have discovered that the issue appears to be that 2600 series routers do not like receiving routing updates via the serial link from a 2500 series router, i.e. 2620/2503 would result in only the 2503 updating its routing table, 2611/2503 would result in only the 2503 updating its routing table while 2620/2611 would result in both routers updating their routing table.

    Is this a known issue? If so, does anyone know what the resolution for this problem is?

    TIA.
     
  8. GC

    GC New Member

    6
    0
    1
    Discussions via another forum have lead me to believe the C2503 router if faulty in that the transmitters in both serial ports (Serial 0 and Serial 1) are not functioning properly, as the C2620 router never reports in-bound packets even though the C2503 reports out-bound packets.
    ------------------------------------------------------------
    C2620#show run
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname C2620
    !
    enable secret 5 $1$piko$206K96vv/wzg.g1K8XJuN.
    !
    ip subnet-zero
    no ip routing
    !
    interface FastEthernet0/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    shutdown
    !
    interface Serial0/0
    ip address 192.168.254.1 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    no keepalive
    clockrate 2000000
    !
    ip classless
    no ip http server
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password passw0rd
    login
    !
    no scheduler allocate
    end

    C2620#show int serial 0/0
    Serial0/0 is up, line protocol is up
    Hardware is PowerQUICC Serial
    Internet address is 192.168.254.1/24
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    reliablility 255/255, txload 1/255, rxload 1/255
    Encapsulation HDLC, loopback not set, keepalive not set
    Last input never, output 00:00:28, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0 (size/max/drops); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    13 packets output, 4300 bytes, 0 underruns
    0 output errors, 0 collisions, 11 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    DCD=up DSR=up DTR=up RTS=up CTS=up

    C2620#ping 192.168.254.3

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.254.3, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
    ------------------------------------------------------------
    C2503#show run
    Building configuration...

    Current configuration:
    !
    version 11.2
    no service password-encryption
    no service udp-small-servers
    no service tcp-small-servers
    !
    hostname C2503
    !
    enable secret 5 $1$XemE$Gix6jnPHk8AWHIgsMr17z/
    !
    interface Ethernet0
    no ip address
    shutdown
    !
    interface Serial0
    ip address 192.168.254.3 255.255.255.0
    no keepalive
    !
    interface Serial1
    ip address 192.168.254.4 255.255.255.0
    no keepalive
    !
    interface BRI0
    no ip address
    shutdown
    !
    no ip classless
    !
    line con 0
    line aux 0
    line vty 0 4
    password passw0rd
    login
    !
    end

    C2503#show ip int brief
    Interface IP-Address OK? Method Status Protocol
    BRI0 unassigned YES unset administratively down down
    BRI0:1 unassigned YES unset administratively down down
    BRI0:2 unassigned YES unset administratively down down
    Ethernet0 unassigned YES unset administratively down down
    Serial0 192.168.254.3 YES NVRAM up up
    Serial1 192.168.254.4 YES NVRAM down down

    C2503#show int serial 0
    Serial0 is up, line protocol is up
    Hardware is HD64570
    Internet address is 192.168.254.3/24
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
    Encapsulation HDLC, loopback not set, keepalive not set
    Last input 00:00:05, output 00:00:09, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0 (size/max/drops); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    6 packets input, 3106 bytes, 0 no buffer
    Received 6 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    2 packets output, 562 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 output buffer failures, 0 output buffers swapped out
    13 carrier transitions
    DCD=up DSR=up DTR=up RTS=up CTS=up

    C2503#ping 192.168.254.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.254.1, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
    ------------------------------------------------------------
    C2620#show ip int brief
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    Serial0/0 192.168.254.1 YES NVRAM up up

    C2620#show int serial 0/0
    Serial0/0 is up, line protocol is up
    Hardware is PowerQUICC Serial
    Internet address is 192.168.254.1/24
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
    reliablility 255/255, txload 1/255, rxload 1/255
    Encapsulation HDLC, loopback not set, keepalive not set
    Last input never, output 00:00:05, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0 (size/max/drops); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    9 packets output, 4117 bytes, 0 underruns
    0 output errors, 0 collisions, 11 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    DCD=up DSR=up DTR=up RTS=up CTS=up

    C2620#ping 192.168.254.4

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.254.4, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
    ------------------------------------------------------------
    C2503#show ip int brief
    Interface IP-Address OK? Method Status Protocol
    BRI0 unassigned YES unset administratively down down
    BRI0:1 unassigned YES unset administratively down down
    BRI0:2 unassigned YES unset administratively down down
    Ethernet0 unassigned YES unset administratively down down
    Serial0 192.168.254.3 YES NVRAM down down
    Serial1 192.168.254.4 YES NVRAM up up

    C2503>show int serial 1
    Serial1 is up, line protocol is up
    Hardware is HD64570
    Internet address is 192.168.254.4/24
    MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
    Encapsulation HDLC, loopback not set, keepalive not set
    Last input 00:00:11, output 00:00:48, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0 (size/max/drops); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    8 packets input, 3780 bytes, 0 no buffer
    Received 8 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    13 packets output, 1883 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 output buffer failures, 0 output buffers swapped out
    19 carrier transitions
    DCD=up DSR=up DTR=up RTS=up CTS=up

    C2503#ping 192.168.254.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.254.1, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
     
  9. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    Where did you buy it from? Counterfeit Cisco gear often has ports that don't work quite right. You could call Cisco to see if the serial number is in their database and not registered to someone else...
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!

Share This Page

Loading...