1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco 1841 with DSL

Discussion in 'Routing & Switching' started by andywt, Feb 3, 2009.

  1. andywt

    andywt New Member

    3
    0
    1
    I am helping a buddy trying to instal a Cisco 1841 in his business. The router has two FE ports plus a T1 inertface that we are not using at this time. We have DSL service and an external DSL modem that we will operate in bridged mode.

    We are trying to use FE0/0 as the local network that will be feeding a Switch. We are using FE0/1 as the PPPOE interface to the DSL modem.

    All of the examples I have seen seem to use a VLAN port that we don't have installed on our switch. Is this mandatory or can we use the FE port?

    I have been using SDM to configure (and using CLI as well) and it appears to configure properly but when it goes to test the PPOE circuit, I am getting an error "However, "there is no configured route to any of the DNS servers through the selected interface".

    Based on some similar posts I did go back and configure NAT and have even tried to use PAT (in SDM) to bridgethe two FE ports together.

    Unfortunately, Nothing seems to work.

    Here is my config. Any advise is appreciated.


    S2SMarketing#show config
    Using 1914 out of 196600 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname S2SMarketing
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 52000 debugging
    enable secret 5 $1$LUr2$t8fSl/hAUSY9q5ACKB1gI0
    enable password tom
    !
    no aaa new-model
    !
    resource policy
    !
    no ip routing
    no ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.20.1 10.10.20.99
    ip dhcp excluded-address 10.10.20.251 10.10.20.254
    !
    ip dhcp pool sdm-pool1
    network 10.10.20.0 255.255.255.0
    default-router 10.10.20.1
    !
    !
    ip name-server 68.94.156.1
    ip name-server 151.164.8.201
    username admin privilege 15 password 0 ****
    username andy privilege 15 password 0 ****
    !
    !
    !
    !
    interface FastEthernet0/0
    description $ETH-LAN$
    ip address 192.168.1.252 255.255.255.0
    ip nat inside
    no ip route-cache
    ip tcp adjust-mss 1412
    speed auto
    full-duplex
    no mop enabled
    !
    interface FastEthernet0/1
    description $ETH-WAN$
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Serial0/0/0
    no ip address
    no ip route-cache
    shutdown
    !
    interface Dialer0
    ip address negotiated
    ip mtu 1452
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname marketingcat@sbcglobal.net
    ppp chap password 0 ***
    ppp pap sent-username marketingcat@sbcglobal.net password 0 magical06
    !
    !
    ip http server
    ip http authentication local
    ip nat inside source list 1 interface Dialer0 overload
    !
    access-list 1 remark INSIDE_IF=FastEthernet0/0
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    snmp-server community public RO
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    privilege level 15
    password *****
    login local
    transport input telnet
    !
    scheduler allocate 20000 1000
    end
     
  2. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    First, you should edit your post - far to much sensitive info in the config! Change your passwords right away.

    The reason you can't reach any external hosts is that you don't have a default route, e.g.:

    ip route 0.0.0.0 0.0.0.0 Dialer0

    The router should be secured. Autosecure is a good way to start, just run "auto secure" from the command prompt (but not config mode) and answer the questions. After autosecure has run you can further tweak the config if needed, e.g. remove the dhcp pool, restrict snmp, etc.

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  3. andywt

    andywt New Member

    3
    0
    1
    Opps, I thought I *'d out all the passwords. well i will fix that! Thanks! I tried to add the ip route but it wouldn't take unless I added an extra space and 1:
    ip route 0.0.0.0 0.0.0.0 Dialer0 1

    I'm not sure what that is for. Thanks Spice!
     
  4. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    try ip route 0.0.0.0 0.0.0.0 Dialer 0 mate, it should work
     
    Certifications: CCNA
    WIP: 220-701 - A+

Share This Page

Loading...