1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BT broadband setup on cisco 1721

Discussion in 'Networks' started by albertc30, Sep 14, 2008.

  1. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello everybody.

    I have a cisco router 1721 and I am trying to set it up on the internet with bt broadband but it seems a never endding problem.
    I have no problem in configuring the network locally.
    I have a wic adsl card (ATM0 interface).

    How can I get this done, what's the configuration?

    Any help really appreciated.

    cheers
    Arruda
     
    Certifications: CCNA
    WIP: 220-701 - A+
  2. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    8,871
    167
    256
    Moved from T&D to Networking forum
     
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  3. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,191
    299
    319
    Might help to post what you have tried so far mate, any error message etc.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  4. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    That's the thing guys, I don't even know where to start.

    I have got an ideia of ATM0, as in router>enable, conf t, int atm0 and then work my way in there but I would be lying if I'd say I know what I am doing. I even tryid smd software and can't get it to work.

    In my CCNA study so far I haven't yet been through this, just wan connections using serial links with PPP encap, RIP and EIGRP or IGRP, etc...

    Here it is my start conf...

    Router#sh run
    Building configuration...

    Current configuration : 1763 bytes
    !
    ! Last configuration change at 21:17:08 UTC Sun Sep 14 2008
    ! NVRAM config last updated at 20:28:49 UTC Sun Sep 14 2008
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    no logging buffered
    !
    username carlos privilege 15 password 0 arru
    no aaa new-model
    ip subnet-zero
    !
    !
    ip dhcp excluded-address 192.168.28.6
    !
    ip dhcp pool care
    import all
    network 192.168.28.0 255.255.255.248
    dns-server 194.72.9.34 62.6.40.178
    !
    !
    ip name-server 194.72.9.34
    ip name-server 62.6.40.178
    ip cef
    no scripting tcl init
    no scripting tcl encdir
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    ip address 192.168.28.6 255.255.255.248
    speed auto
    !
    interface Dialer0
    ip address dhcp
    ip access-group 1 in
    ip access-group 1 out
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname bthomehub@btbroadband.com
    ppp chap password 0 home
    ppp pap sent-username bthomehub@btbroadband.com password 0 home
    !
    router rip
    version 2
    passive-interface ATM0
    passive-interface ATM0.1
    passive-interface Dialer0
    passive-interface FastEthernet0
    network 10.0.0.0
    network 192.1
    no auto-summary
    !
    ip classless
    ip http server
    ip http authentication local
    !
    !
    access-list 1 remark any
    access-list 1 remark SDM_ACL Category=1
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    !
    no scheduler allocate
    !
    end

    Router#


    Any help well appreciated...

    Cheers
    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+
  5. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    you have typed in your username and password correct haven't you? or is it set as whats listed above?
     
  6. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    well in the BT home hub there is no user password never ever has been one but the sdm wasn't allowing me to go without one so I just typed home which apparently can be anything if required by the devices software so I was told along time ago by BT....


    help please

    Just want to see this great piece of kit working...

    thanks for everybodys help

    cheers
    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+
  7. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    that username only works with homehubs, I'm pritty certain you should be using the primary account(something@btinternet.com) details on other modem/routers. Also look at your nat.
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  8. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    So with BT on an ADSL line, were you given a username / password at any point, as far as my understanding with ADSL, all ISP provide their user with some sort of credentials, username/password, so they "dial in", especially with those shi77y usb modems that were shipped out FOC.

    Now-a-days, people buy decent ADSL modem/routers and enter their credentials one-off on their setup page when they configure their device for the first time.

    I am thinking along the same way here, unless your device does not support ADSL connections
     
  9. Gaz 45

    Gaz 45 Kilobyte Poster

    404
    4
    39
    When I changed to a non-BT router (around 6 months ago), you simply needed to enter your BT email address which you should have set up when you first signed up with BT, and no password required.
    Pretty sure the bthomehub one won't work when not using a home hub though :)

    Are there any entries on the original router you can copy/check with?
    Cheers
     
    Certifications: MCP (70-229, 70-228), MBioch
    WIP: MCDBA (70-290)
  10. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Done some changes guys but to no luck.

    I have changed username and password to bt username <username>@btinternet.com and the password they provided but no luck.

    I am totally lost as I have never tryid before to setup an adsl wic card so I am lost.

    Any help welcome,

    Cheers
    Albert, C

    Router#sh run
    Building configuration...

    Current configuration : 1869 bytes
    !
    ! Last configuration change at 06:26:14 UTC Mon Sep 15 2008
    ! NVRAM config last updated at 06:26:24 UTC Mon Sep 15 2008
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    no logging buffered
    !
    username carlos privilege 15 password 0 arruda
    no aaa new-model
    ip subnet-zero
    !
    !
    ip dhcp excluded-address 192.168.28.6
    !
    ip dhcp pool care
    import all
    network 192.168.28.0 255.255.255.248
    dns-server 194.72.9.34 62.6.40.178
    !
    !
    ip name-server 194.72.9.34
    ip name-server 62.6.40.178
    ip cef
    no scripting tcl init
    no scripting tcl encdir
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    ip address 192.168.28.6 255.255.255.248
    ip nat
    speed auto
    !
    interface Dialer0
    ip address dhcp
    ip access-group 1 in
    ip access-group 1 out
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname racheled50@btinternet.com
    ppp chap password 0 SILVE799
    ppp pap sent-username racheledw758@btinternet.com password 0 SILVE799
    !
    router rip
    version 2
    passive-interface ATM0
    passive-interface ATM0.1
    passive-interface Dialer0
    passive-interface FastEthernet0
    network 10.0.0.0
    network 192.168.28
    no auto-summary
    !
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip http server
    ip http authentication local
    !
    !
    access-list 1 remark any
    access-list 1 remark SDM_ACL Category=3
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    !
    no scheduler allocate
    !
    end

    Router#

    Any ideias please?

    Maybe clear the start up file and start a clean one step by step?

    Cheers
     
    Certifications: CCNA
    WIP: 220-701 - A+
  11. BrizoH

    BrizoH Byte Poster

    243
    6
    25
    Can't help on the cisco config side I'm afraid - but with regards to the username/password when I used BT Broadband they mentioned that from their end only the username was required but some routers would require a password to be entered, if this is the case they said to use "bt" (minus quotations)
     
    Certifications: CCNA, CCNA Security
    WIP: CCNP
  12. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    albertc30,

    Does BT provide you with a pre-configured networking device such as a modem or router?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  13. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Hears what I've got

    [snip 1]
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no snmp trap link-status
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    [/snip 1]

    and

    [snip 2]
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip inspect SDM_MEDIUM out
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname something@btinternet.com
    ppp chap password 7 YOUR_PASSWORD
    ppp pap sent-username something@btinternet.com password 7 YOUR_PASSWORD
    crypto ipsec client ezvpn Head_Office
    service-policy input sdmappfwp2p_SDM_MEDIUM
    service-policy output sdmappfwp2p_SDM_MEDIUM
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0 2
    [/snip 2]

    This is from an 877Sec+ so just takeaway the bits you don't need and you should be cooking with gas
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  14. negseven

    negseven New Member

    7
    0
    1
    at what level is it failing ? your going to have to run some debugs
    i.e. is the ADSL synching ok ? then it sounds like a PPP problem
     
  15. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Well, I don't quite know yet. What I do know is that I have bt broadband and it works fine in my bt home hub.
    I have setup hundreds of adsl internet connections in the past using the GUI and always have been successful but never did I setup an adsl internet connection on a Cisco router.

    What I will do is I will erase the start up file and have it done from scratch. I'll use the information that you guys already provided me with and we'll see how it goes.
    I am just getting prepaired to take my final exam module 2 on CCNA. Haven't yet talked about how to setup adsl lines or internet connections and we just have mentioned once about the debug mode.

    I'll keep you guys posted.

    Fingers crossed.

    Thanks to you all.

    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+
  16. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Good luck bud, nothing worthwhile is ever easy :D

    you could try debug ppp (i think that correct) if your interface is up.

    [added]
    i found this on the net

    Code:
     no service pad  
     service tcp-keepalives-in  
     service tcp-keepalives-out  
     service timestamps debug uptime  
     service timestamps log uptime  
     service password-encryption  
     !  
     hostname router  
     !  
     logging buffered 4096 debugging  
     !  
     !  
     ip subnet-zero  
     no ip source-route  
     no ip domain-lookup  
    ip domain-name local  
     ip dhcp excluded-address 192.168.0.1 192.168.0.99  
     ip dhcp excluded-address 192.168.0.1  
     !  
     ip dhcp pool dhcppool  
      import all  
      network 192.168.0.0 255.255.255.0  
      default-router 192.168.0.1  
      update arp  
      exit  
     !  
     !  
     no ip bootp server  
     ip inspect name firewall tcp  
     ip inspect name firewall udp  
     ip inspect name firewall cuseeme  
     ip inspect name firewall h323  
     ip inspect name firewall rcmd  
     ip inspect name firewall realaudio  
     ip inspect name firewall streamworks  
     ip inspect name firewall vdolive  
     ip inspect name firewall sqlnet  
     ip inspect name firewall tftp  
     ip inspect name firewall ftp  
     ip inspect name firewall icmp  
     ip inspect name firewall realaudio  
     ip inspect name firewall sip  
     ip inspect name firewall esmtp  
     ip inspect name firewall fragment  
     ip inspect name firewall netshow  
     ip inspect name firewall rtsp  
     ip inspect name firewall skinny  
     ip audit name intrusion info action alarm  
     ip audit name intrusion attack action alarm drop reset  
     !  
     interface Ethernet0  
      ip address 192.168.0.1 255.255.255.0  
      ip access-group 102 in  
      ip nat inside  
      no ip directed-broadcast  
      exit  
     !  
     interface ATM0  
      dsl operating-mode auto  
      exit  
     !  
     interface ATM0.1 point-to-point  
      pvc 0/100  
       encapsulation aal5mux ppp dialer  
       dialer pool-member 1  
      !  
      exit  
     !  
     interface Dialer0  
      ip address negotiated  
      ip inspect firewall out  
      ip audit intrusion in  
      ip access-group 101 in  
      no ip redirects  
      no ip unreachables  
      ip nat outside  
      encapsulation ppp  
      dialer pool 1  
      dialer-group 1  
      ppp pap sent-username [email]user@broadband.com[/email] password password  
      ppp ipcp dns request  
      no cdp enable  
      exit  
     !  
     ip nat inside source list 1 interface Dialer0 overload  
     ip classless  
     ip route 0.0.0.0 0.0.0.0 Dialer0  
     no ip http server  
     !  
     !  
     line vty 0 4  
      access-class 2 in  
      transport input telnet ssh  
      transport output none  
      exit  
     !  
     access-list 1 remark The local LAN.  
     access-list 1 permit 192.168.0.0 0.0.0.255  
     !  
     access-list 2 remark Where management can be done from.  
     access-list 2 permit 192.168.0.0 0.0.0.255  
     !  
     access-list 101 remark Traffic allowed to enter the router from the Internet  
     access-list 101 deny ip 0.0.0.0 0.255.255.255 any  
     access-list 101 deny ip 10.0.0.0 0.255.255.255 any  
     access-list 101 deny ip 127.0.0.0 0.255.255.255 any  
     access-list 101 deny ip 169.254.0.0 0.0.255.255 any  
     access-list 101 deny ip 172.16.0.0 0.15.255.255 any  
     access-list 101 deny ip 192.0.2.0 0.0.0.255 any  
     access-list 101 deny ip 192.168.0.0 0.0.255.255 any  
     access-list 101 deny ip 198.18.0.0 0.1.255.255 any  
     access-list 101 deny ip 224.0.0.0 0.15.255.255 any  
     access-list 101 deny ip any host 255.255.255.255  
     access-list 101 permit tcp any any eq 1723  
     access-list 101 permit gre any any  
     access-list 101 deny icmp any any echo  
     access-list 101 deny ip any any log  
     !  
     access-list 102 remark Traffic allowed to enter the router from the Ethernet  
     access-list 102 permit ip any host 192.168.0.1  
     access-list 102 deny ip any host 192.168.0.255  
     access-list 102 deny udp any any eq tftp log  
     access-list 102 deny ip any 0.0.0.0 0.255.255.255 log  
     access-list 102 deny ip any 10.0.0.0 0.255.255.255 log  
     access-list 102 deny ip any 127.0.0.0 0.255.255.255 log  
     access-list 102 deny ip any 169.254.0.0 0.0.255.255 log  
     access-list 102 deny ip any 172.16.0.0 0.15.255.255 log  
     access-list 102 deny ip any 192.0.2.0 0.0.0.255 log  
     access-list 102 deny ip any 192.168.0.0 0.0.255.255 log  
     access-list 102 deny ip any 198.18.0.0 0.1.255.255 log  
     access-list 102 deny udp any any eq 135 log  
     access-list 102 deny tcp any any eq 135 log  
     access-list 102 deny udp any any eq 137 log  
     access-list 102 deny udp any any eq 138 log  
     access-list 102 deny tcp any any eq 445 log  
     access-list 102 permit ip 192.168.0.0 0.0.0.255 any  
     access-list 102 permit ip any host 255.255.255.255  
     access-list 102 deny ip any any log  
     !  
     dialer-list 1 protocol ip permit  
     |  
     !  
     interface Ethernet0  
      no shutdown  
      exit  
     interface ATM0  
      no shutdown  
      exit
    
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  17. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello everybody...
    I am in trouble indeed...
    Have been trying some settings I have been given but with no luck..

    Here is my startup

    sh run
    Building configuration...

    Current configuration : 1609 bytes
    !
    ! Last configuration change at 19:50:12 UTC Mon Sep 15 2008
    ! NVRAM config last updated at 19:50:17 UTC Mon Sep 15 2008
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CR1721
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$HS9E$ykE1YBDJVpHvLlvnBjLUE0
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    --More-- ip dhcp pool local
    network 192.168.28.0 255.255.255.248
    default-router 192.168.28.6
    dns-server 194.72.9.34
    !
    !
    no ip domain lookup
    ip cef
    no scripting tcl init
    no scripting tcl encdir
    password encryption aes
    !
    !
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    encapsulation aal5mux ppp dialer
    --More-- dialer pool-member 1
    !
    !
    interface FastEthernet0
    description Local Network
    ip address 192.168.28.6 255.255.255.248
    speed auto
    !
    interface Dialer0
    no ip address
    !
    interface Dialer1
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp pap sent-username racheled578@btinternet.com password 0 bt
    ppp ipcp dns request
    !
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    --More-- no ip http server
    !
    !
    !
    control-plane
    !
    banner motd ^CThis should be a secure site. Authorized access only.
    Accessing this site with no permission will lead to prosecution. If not authorized get out
    as this connection is monitored and it can be traced.^C
    !
    line con 0
    password cisco
    login
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    no scheduler allocate
    !
    end

    CR1721#

    *******************************************************************

    CR1721#sh atm traffic
    56 Input packets
    266 Output packets
    0 Broadcast packets
    0 Packets received on non-existent VC
    0 Packets attempted to send on non-existent VC
    0 OAM cells received
    F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
    F5 InEndcc: 0, F5 InSegcc: 0,
    F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
    0 OAM cells sent
    F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
    F5 OutEndcc: 0, F5 OutSegcc: 0,
    F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
    0 OAM cell drops
    CR1721#

    ******************************************************************
    At the back of the router in the adsl card there is three lights the ones on are CD and OK the LP is off, hope this helps.

    Anybody please help...
    Cheers
     
    Certifications: CCNA
    WIP: 220-701 - A+
  18. negseven

    negseven New Member

    7
    0
    1
    Your going to have to get your hands dirty and work it out
    as usual Google is your best mate etc...do a search on debug cisco adsl connections
    1st debug the ATM0 connection to prove layer 1 , then if thats successfull go on to layer 2 - PPP
    I had to upgrade my adsl firmware on a 851 adsl router to get the ATM0 to come up, but you have a WIC
    card in there.... this is where your troubleshooting skills get developed
     
  19. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    albertc30,

    FOR THE SECURITY OF YOUR FRIEND/CLIENT, YOU MIGHT WANT TO EDIT THE EMAIL ADDRESS @BTINTERNET.COM IN THE ABOVE CONFIG.
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  20. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello everybody.

    Hello Negseven, I can see you are a new member so welcome to certforums.
    I appreciate what you have said and I must agree with you but you see, it's just that I don't even know if the setup is correct. I can do the first one, debug the ATM0 to check layer 1 which I am pretty sure I don't have any problems here as I do have internet through a BT Home Hub.
    Now as for the layer two PPP, shouldn't the connection be done properly first? I do not know it and to be totally honest like I have, I have got no idea of what I am doing here. I have never ever done it. I am confused with all the ATM0.1 and dialer0 and dialer1, where did these all come from??? I am definitely at an obstacle and I need to overcome it and most of all, learn from it. But still, you are right negseven. Once again welcome to certforums.


    Hello R.H.Lee,
    About your comment not to worry as the username in the post is not our real e-mail address. Thanks for the concern.

    To everybody,
    I would like to do here is to learn on how to setup the ATM0 interface for my ADSL connection steep by steep as I have mentioned above, I am totally and utterly lost with ATM0.1 and Dialer0 and Dialer1 and what I don't really want is to be copying lines here and there and just pasting it into my routers configuration without having a clue of what they do or what do they mean.
    I am happy to have found this website as it is of the utmost importance to allot people as it sure is a great help to all of us. To all of you that have shed some light into to this my much appreciated thank you.
    Hope to learn allot more with you all and hope to be able to help as well.

    Cheers,
    Albert, C
     
    Certifications: CCNA
    WIP: 220-701 - A+

Share This Page

Loading...