1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Basic OSPF Problem

Discussion in 'Routing & Switching' started by splat78423, Oct 21, 2014.

  1. splat78423

    splat78423 New Member

    5
    0
    1
    It's a simple point to point serial link between two routers that I can't get OSPF to neighbor up on. I have added the sh run for each router below. Any help is greatly appreciated.

    Current configuration : 1012 bytes
    !
    version 15.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Orlando
    !
    !
    !
    enable secret 5 $1$mERr$GvDaTJK9lhdXRUPWKA74O0
    enable password cisco
    !
    !
    !
    !
    no ip cef
    no ipv6 cef
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX152419T4
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address 10.2.2.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/3/0
    ip address 192.168.1.2 255.255.255.0
    clock rate 2000000
    !
    interface Serial0/3/1
    no ip address
    clock rate 2000000
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 10
    log-adjacency-changes
    network 0.0.0.0 0.0.0.0 area 10
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    password password
    login
    !
    !
    !
    end



    Building configuration...

    Current configuration : 1010 bytes
    !
    version 15.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Miami
    !
    !
    !
    enable secret 5 $1$mERr$GvDaTJK9lhdXRUPWKA74O0
    enable password cisco
    !
    !
    !
    !
    no ip cef
    no ipv6 cef
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX1524QP2E
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address 10.1.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/3/0
    ip address 192.168.1.1 255.255.255.0
    clock rate 2000000
    !
    interface Serial0/3/1
    no ip address
    clock rate 2000000
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 10
    log-adjacency-changes
    network 0.0.0.0 0.0.0.0 area 10
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    password password
    login
    !
    !
    !
    end
     
  2. rocdamike

    rocdamike Byte Poster Gold Member

    235
    21
    72
    Check your OSPF network statements. Will the wildcard mask you have used enable OSPF on the interfaces you want? :)
     
    Certifications: CCNA R&S, CCENT, F5 101 Application Delivery Fundamentals, ITIL Foundation (2011), CompTIA (A+, Network+), MTA (Windows OS, Networking, HTML5)
    WIP: CCNA Security
  3. splat78423

    splat78423 New Member

    5
    0
    1
    The wildcard is suppose to enable advertising of every network on the router in OSPF so I think I have that right.....
     
  4. rocdamike

    rocdamike Byte Poster Gold Member

    235
    21
    72
    On both routers try replacing 'network 0.0.0.0 0.0.0.0 area 10' with 'network 0.0.0.0 255.255.255.255 area 10' and see if that works.
     
    Certifications: CCNA R&S, CCENT, F5 101 Application Delivery Fundamentals, ITIL Foundation (2011), CompTIA (A+, Network+), MTA (Windows OS, Networking, HTML5)
    WIP: CCNA Security
  5. splat78423

    splat78423 New Member

    5
    0
    1
    Worked like a charm! I don't know how I overlooked that.Thanks bro.
     
  6. rocdamike

    rocdamike Byte Poster Gold Member

    235
    21
    72
    No worries. Glad I could help :)
     
    Certifications: CCNA R&S, CCENT, F5 101 Application Delivery Fundamentals, ITIL Foundation (2011), CompTIA (A+, Network+), MTA (Windows OS, Networking, HTML5)
    WIP: CCNA Security
  7. splat78423

    splat78423 New Member

    5
    0
    1
    Ran into another basic OSPF problem today in my lab studies that maybe you or someone else can help me with..... Basically Router0 is not adding to it's routing table an ospf enabled Loopback on router2 like it does perfectly for Router1. I have pasted the sh run output for all three routers below. Thanks in advance.

    Router0 sh run

    Router#sh run
    Building configuration...

    Current configuration : 947 bytes
    !
    version 15.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    no ip cef
    no ipv6 cef
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX1524NUE7
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address 10.50.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/3/0
    ip address 192.168.1.5 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/3/1
    ip address 192.168.1.1 255.255.255.252
    clock rate 2000000
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 10
    log-adjacency-changes
    network 0.0.0.0 255.255.255.255 area 10
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end

    ALSO here is the Router0 routing table.....

    Router#sh ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.50.1.0/24 is directly connected, GigabitEthernet0/0
    L 10.50.1.1/32 is directly connected, GigabitEthernet0/0
    172.16.0.0/24 is subnetted, 1 subnets
    O 172.16.1.0/24 [110/65] via 192.168.1.2, 01:36:58, Serial0/3/1
    192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
    C 192.168.1.0/30 is directly connected, Serial0/3/1
    L 192.168.1.1/32 is directly connected, Serial0/3/1
    C 192.168.1.4/30 is directly connected, Serial0/3/0
    L 192.168.1.5/32 is directly connected, Serial0/3/0

    ROUTER1 sh run

    Router#sh run
    Building configuration...

    Current configuration : 1046 bytes
    !
    version 15.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    no ip cef
    no ipv6 cef
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX15242VNT
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface Loopback1
    ip address 172.16.1.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/3/0
    no ip address
    clock rate 2000000
    shutdown
    !
    interface Serial0/3/1
    ip address 192.168.1.2 255.255.255.252
    clock rate 2000000
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 10
    log-adjacency-changes
    network 192.168.1.0 0.0.0.3 area 10
    network 172.16.1.0 0.0.0.255 area 10
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end

    ROUTER2

    Router#sh run
    Building configuration...

    Current configuration : 1046 bytes
    !
    version 15.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    no ip cef
    no ipv6 cef
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX1524AYUC
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface Loopback1
    ip address 172.26.1.1 255.255.255.0
    ip ospf network point-to-point
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/3/0
    ip address 192.168.1.6 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/3/1
    no ip address
    clock rate 2000000
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 10
    log-adjacency-changes
    network 172.26.1.0 0.0.0.255 area 10
    network 192.168.1.0 0.0.0.3 area 10
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end


    I guess it should be easy enough to figure out for someone who knows exactly what they are doing. I am only a couple weeks into my self studies and can really use the help cause I dont have an instructor, just forums....
     
  8. rocdamike

    rocdamike Byte Poster Gold Member

    235
    21
    72
    Do you have a network diagram or a packet tracer file for this lab?
     
    Certifications: CCNA R&S, CCENT, F5 101 Application Delivery Fundamentals, ITIL Foundation (2011), CompTIA (A+, Network+), MTA (Windows OS, Networking, HTML5)
    WIP: CCNA Security
  9. splat78423

    splat78423 New Member

    5
    0
    1
    I tried to attach the packet tracer lab .pkt file but I get an error saying that it is an invalid file for some reason. MAP.jpg


    I'm having the issue between routers 0 - 2 and once I can figure it out (or get the right consultation) and will then hop over to the department routers and get ospf working for those networks.
     
  10. rocdamike

    rocdamike Byte Poster Gold Member

    235
    21
    72
    Your OSPF network statement on router 2 is incorrect. Change 'network 192.168.1.0 0.0.0.3 area 10' to 'network 192.168.1.4 0.0.0.3 area 10'

    You need to practice your OSPF troubleshooting skills. Use verification commands such as 'show ip ospf neighbor' and 'sh ip ospf interface' to check whether you have an adjacency formed and whether the interface is OSPF enabled.
     
    Certifications: CCNA R&S, CCENT, F5 101 Application Delivery Fundamentals, ITIL Foundation (2011), CompTIA (A+, Network+), MTA (Windows OS, Networking, HTML5)
    WIP: CCNA Security

Share This Page

Loading...