1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ATI drivers in debian

Discussion in 'Linux / Unix Discussion' started by Theprof, Dec 10, 2007.

  1. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Hello,

    I finally got the sound to work so my next task is to get the video drivers installed. Here is my problem. I downloaded the ATI drivers from ati website, created the proper debian etch package, installed the kernel, driver control panel and thus far no luck.

    When I type fglrxinfo I get the following:

    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

    which from what I can see the driver is not loaded.

    when I type lspci I get the following:

    00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
    00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f3)
    00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
    00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
    00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
    00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
    00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
    00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
    00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
    00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
    00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev f3)
    00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
    00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
    00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
    00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    05:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 7244
    05:00.1 Display controller: ATI Technologies Inc Unknown device 7264

    as you can see I highlighted the vga controller and it displays the device as unknown.

    I don't know where to go from here. Please let me know what I am doing wrong here or if any other feedback is needed I will do my best to provide it.

    Thanks
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  2. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    You are not using the fglrx driver. You're still using the open source driver. If you were using the fglrx driver you wouldn't be getting the "Mesa GLX Indirect" message.

    Did you run aticonfig --initial to get it to modify the /etc/X11/xorg.conf file after rebooting so the fglrx module was loaded and then restart the xserver? You can do that by running, as root, /etc/init.d/gmd stop. Then log into the console as your regular user, su to root, and then run /etc/init.d/gdm start. That will restart the xserver and bring you back to the log in page for Gnome where you once again log into the gui. This step will tell you whether or not your change of drivers has actually worked
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  3. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Freddy thank you so much it worked.

    Here is the output from the fglrxinfo:

    Debian:/home/andrey# fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1950 Series
    OpenGL version string: 2.1.7059 Release

    I've spent a whole day trying to get it to work. Thanks again I really appreciate it.

    I have one last question when I ran the lspci I still the get:

    05:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 7244
    05:00.1 Display controller: ATI Technologies Inc Unknown device 7264

    Is that normal? or should be saying the name of my video type like it is in fglrxinfo?
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  4. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    I'm not sure why lspci is still showing some "unknown" stuff, but you're definitely running the fglrx driver now. I don't know if compiz will run with your model of ATI graphics card, but you can try it.

    Try Googling for "compiz X1950" and see what comes up. If you're very lucky you will only have to make a couple of mods to the /etc/X11/xorg.conf file to get it to work. If you're in the same boat with most of us ATI card owners you won't be able to get compiz running.

    Let me know how things go and I can help you through some of the stuff. I may not be around today as I'm supposed to go up to Spokane today, but it dumped a few inches of snow last light and it's too dark to see anything of the road conditions from the traffic cameras out on the highway yet this morning. If the roads are too bad I'll be staying home as the highway between here and Spokane become wreck-o-rama when it gets slick because of all the Californian's who have moved up here and don't know how to drive in snow.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  5. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Thanks freddy, I will definitly attempt the compiz although from reading online on forums and stuff it's not that easy to set it up with my video card and they are asking for a 512MB video card which makes sense but mine is only 256MB.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  6. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    Prof,

    My Nvidia card is only 256 megs and compiz runs fine on it. If your ATI card supports the necessary technologies then it should run compiz too.

    My card is several years old technology-wise so you should be fine.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  7. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Really? a lot of people were saying that it will be an issue running with a 256MB card and that it might work but lag a lot so I was somewhat hesitant, however I'll just go ahead and try. I've got nothing to lose really.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  8. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    I installed compiz and it looks really nice, however it is slow in a sense that it takes time to open applications and my wallpaper disappears for some reason. Is there any tweaks that I sould be aware of by any chance?

    I looked online but I couldn't find much.

    Thanks.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  9. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    Hmmm.... What are the specs for the rest of your system?

    One thing you might try that will speed compiz up is to start it with the --fast-filter option. I use it and my old 1800+ Athlon XP with a Geforce 6200 with 256 megs of ram running on a 4x AGP slot isn't doggy at all.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  10. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    One more thing you might try. I get my compiz packages from shame. He's a compiz and a Debian developer, and always has the latest.

    Here's the url to add to your /etc/apt/sources.list file.

    http://download.tuxfamily.org/shames/debian-etch/desktopfx/stable/ ./ Be sure you add the "space ./" at the end of the url. The url line-wrapped on me and didn't complete because of it.

    Once you add it and run apt-get update run the following command to add the gpg keys for his repositories or apt will squawk every time you use his repositories.

    wget http://download.tuxfamily.org/shames/A42A6CF5.gpg -O- | apt-key add -


    Once you've added his key run "apt-get install compiz-fusion-all". That will allow you to run compiz under both Gnome and KDE, and should install the ccsm package. ccsm is the compizconfiguration settings manager. It gives you a point and click interface for configuring compiz. Also check to see that the compiz fusion icon package is installed too. It will appear under Applications -> System Tools.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  11. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    The specs of my system are:

    Asus M2N4-SLI
    AMD 64 3800+
    2GB of ram DDR2 667Mhz
    Sapphire X1950XT PCI-E 256MB
    150GB HD western digital

    I will install what you recommended and let you know how it goes from there.

    I found it kind of wierd that is slow on my system because from reading on other forums users got it working well with a lower end systems which is why I was kind of curious as to why it didn't work with my setup. Got me thinking that there are probably tweaks and different mini apps that could help with the slow downs.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  12. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    Compiz should run pretty well on that system. The only thing that could be a problem is the ATI card. Their drivers are just so bad that they could be the entire problem.

    I'll do some research into it and let you know what I find.

    Post your /etc/X11/xorg.conf file and the results from running glxgears.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  13. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    Prof,

    After doing some research your performance problem is caused by the ATI drivers. I found quite a few people complaining about very poor performance using that card with the proprietary drivers. It seems as if ATI's Linux drivers give about 50% of the performance their Windows drivers do.

    Looks like you have two options under Linux. Move to an NVidia card, or wait until ATI comes out with their promised open source drivers. Then performance will get better quickly as there will be experienced Linux developers working on them.

    The --fast-filter option may help some, but that card will be slow until the driver issues are fixed.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  14. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Thanks for looking into that Freddy, I appreciate it. I too was looking around and found pretty much the same response. Hopefully soon they will have something. In the mean while I can just uninstall compiz and wait until the new drivers are available.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  15. ffreeloader

    ffreeloader Terabyte Poster

    3,661
    106
    167
    You don't even have to uninstall if you don't want to. If you have compiz set up to start when you log into your Gnome session, you can just go to System -> Preferences -> Sessions and disable compiz from starting up when you log in.
     
    Certifications: MCSE, MCDBA, CCNA, A+
    WIP: LPIC 1
  16. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    For some reason under KDE when I ran the fglrxinfo I get the mesa drivers displaying again. It's not showing ati anymore even after the reboot. Thats weird. I tried doing the aticonfig --initial under KDE and it didn't do anything. It jus says this:

    Debian:/home/andrey# fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

    Debian:/home/andrey# aticonfig --initial
    Found fglrx primary device section
    Nothing to do, terminating.
    Debian:/home/andrey#

    Any ideas?

    Also because of that I can't login into gnome any more it just crashes because of compiz is starting up.
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  17. Theprof

    Theprof Petabyte Poster Forum Leader

    4,570
    68
    196
    Freddy, here is the config you were asking about:


    Section "ServerLayout"
    Option "AIGLX" "true"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "Files"

    # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/100dpi:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/local/share/fonts"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Monitor"
    Identifier "QL-711V"
    Option "DPMS"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Option "AllowGLXWithComposite" "true"
    Option "RenderAccel" "true"
    Identifier "Generic Video Card"
    Driver "vesa"
    BusID "PCI:5:0:0"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Option "XAANoOffscreenPixmaps"
    Option "AddARGBGLXVisuals" "true"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "QL-711V"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection
     
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
    WIP: VCAP5-DCA/DCD | EMCCA
  18. time2die

    time2die New Member

    1
    0
    1
    I have do all what you say but dont get the resault =(
    this my xorg.conf
    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "Files"

    # path to defoma fonts
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/X11R6/lib/X11/fonts/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Monitor"
    Identifier "SyncMaster"
    Option "DPMS"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "ATI Technologies Inc ATI Default Card"
    Driver "vesa"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies Inc ATI Default Card"
    Monitor "SyncMaster"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection
     

Share This Page

Loading...