1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Any Squid gurus out there?

Discussion in 'Software' started by zebulebu, Nov 22, 2006.

  1. zebulebu

    zebulebu Terabyte Poster

    I've installed Squid on one of my boxes at home, but am having a problem with logging.

    I know the box is proxying requests properly - I've configured a browser with the IP address of the box and the port I'm running Squid on (default, port 3128). The cache is filling up and, if I check out the cache.log file I can see oodles of things being cached.

    However, there isn't a single entry in the access.log logfile. I'm not running any authentication, but my understanding is that proxy accesses should still be logged regardless - is this not correct? I'd rather not have to piss around setting up an authentication mechanism when all I really want to do is log all web browsing activity on my LAN - I think my wife would get the hump if I started asking her to authenticate to a proxy server - it'd be too much like being at work for her :twisted:

    I've checked every newsgroup I can find and the only mention of a similar problem is from someone who has installed Squid on a Linux box and obviously not given the correct permissions on the directory that the access.log file resides in.


    Certifications: A few
    WIP: None - f*** 'em
  2. JonnyMX

    JonnyMX Petabyte Poster

    Bit of lemon juice and a touch of chopped chilli?
    Certifications: MCT, MCTS, i-Net+, CIW CI, Prince2, MSP, MCSD
  3. twizzle

    twizzle Gigabyte Poster


    I find fried with noodles better. :p

    Other than that i have no idea!
    Certifications: Comptia A+, N+, MS 70-271, 70-272
    WIP: Being a BILB,
  4. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    I was running squid some years ago - but it was on a NetBSD box - so I'm not sure I am going to be much help! :eek:

    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  5. zebulebu

    zebulebu Terabyte Poster

    Cheers Harry - I figured it out in the end. The access log parameter in the config file was enclosed in quotes and shouldn't have been.

    All sorted now - now I can get down to ACLs and blocking!
    Certifications: A few
    WIP: None - f*** 'em

Share This Page