1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Allow access to anonymous users

Discussion in 'Windows Server 2003 / 2008 / 2012 Exams' started by lifeisshortmove, Aug 28, 2011.

  1. lifeisshortmove

    lifeisshortmove Bit Poster

    42
    0
    19
    Hi,
    I want to allow access to a shared folder on a server for anonymous users (No need to enter username and password). I made a research on this and MS says it can be done by enabling these GP settings:

    Administrative Tools\Security Policy\Security Settings\Local Policies\Security Options
    and then Enable "Network access: Let Everyone permissions apply to anonymous users"

    As stated in MS knowledge base article Anonymous user cannot access a shared folder

    I have also tried to add Anonymous Logon to "Access this computer from the network" setting under
    Administrative Tools\Security Policy\Security Settings\Local Policies\User right assignment

    But it did not work either. It always shows Username/ password window. server's OS runs windows sever 2003 and client computers run windows XP pro SP2. Any idea how to solve this problem?
     
  2. jiggy

    jiggy Nibble Poster

    96
    6
    27
    did you remember to set the share and security permissions on the folder to include anon?
     
    Certifications: MCSE
    WIP: ABC's
  3. lifeisshortmove

    lifeisshortmove Bit Poster

    42
    0
    19
    Yes, I added anonymous Logon to ACL of the shared folder and setup share and NTFS permissions. But again that's not the problem because permissions control weather you can view, open, write, or change permissions on a resource. On the other hand, I still get the username/password window when I try to connect to any shared resource on the server.

    If I am mistaken any expert on the forums can correct me.
     
    Last edited: Aug 29, 2011
  4. westernkings

    westernkings Gigabyte Poster

    1,432
    60
    107
    You need to actually define the shares (unless I'm mistaken).


    Capture.PNG

    cappture_2.PNG
     
    Certifications: MCITP:VA, MCITP:EA, MCDST, MCTS, MCITP:EST7, MCITP:SA, PRINCE2, ITILv3
  5. lifeisshortmove

    lifeisshortmove Bit Poster

    42
    0
    19
    I have tried that too and it did not work. What I found is that the only solution is to enable the "Guest" account without setting up a password. This way users can connect to shared folders anonymously.

    Anyway, thanks guys for your replies and if anyone has explanation why MS recommendation of configuring GP to allow anonymous access does not work, I'll be happy to understand it.
     
  6. derkit

    derkit Gigabyte Poster

    1,479
    54
    112
    How about adding Everyone group to the ACL?
     
    Certifications: MBCS, BSc(Hons), Cert(Maths), A+, Net+, MCDST, ITIL-F v3, MCSA
    WIP: 70-293
  7. lifeisshortmove

    lifeisshortmove Bit Poster

    42
    0
    19
    Of course, that does not solve the problem because everyone does not include anonymous logon and that's what I have did by adding anonymous logon to everyone but it did not work as it should be. Anyway, as I said it works fine just by enable the guest account without password and without changing any group policy settings.

    Anyway, thanks for your reply
     
  8. derkit

    derkit Gigabyte Poster

    1,479
    54
    112
    You're right - I was think of 2000.
    :oops:

    I wonder if there is a user right assignment somewhere......
     
    Last edited: Sep 7, 2011
    Certifications: MBCS, BSc(Hons), Cert(Maths), A+, Net+, MCDST, ITIL-F v3, MCSA
    WIP: 70-293
  9. frankcastle

    frankcastle Bit Poster

    21
    0
    36
    either you add a group using folder security permissions
    or change group policy settings and enable anonymous users to log in to computer without password.
     
    Certifications: MCSE
    WIP: CCNA

Share This Page

Loading...