1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ADSL on Cisco Router 877

Discussion in 'Routing & Switching' started by alfwro, Oct 28, 2010.

  1. alfwro

    alfwro New Member

    4
    0
    1
    Hi Folks

    I hope you can help. i'm struggling with BT ADSL setup on Cisco 877. My lab setup is: got another box with DHCP, all hosts on the inside (172.31.12.0/24) can communicate but not able to access internet.

    Here is my config:
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    no service dhcp
    !
    hostname cleeve-rd-backup
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096 debugging
    logging console critical
    enable secret 5 PASSWORD
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone London 0
    clock summer-time London date Mar 30 2003 1:00 Oct 26 2003 2:00
    no ip source-route
    ip cef
    !
    !
    !
    !
    ip tcp synwait-time 10
    no ip bootp server
    ip name-server 194.74.65.69
    ip ssh time-out 60
    ip ssh authentication-retries 2
    ip inspect name DEFAULT100 cuseeme
    ip inspect name DEFAULT100 ftp
    ip inspect name DEFAULT100 h323
    ip inspect name DEFAULT100 icmp
    ip inspect name DEFAULT100 netshow
    ip inspect name DEFAULT100 rcmd
    ip inspect name DEFAULT100 realaudio
    ip inspect name DEFAULT100 rtsp
    ip inspect name DEFAULT100 esmtp
    ip inspect name DEFAULT100 sqlnet
    ip inspect name DEFAULT100 streamworks
    ip inspect name DEFAULT100 tftp
    ip inspect name DEFAULT100 tcp
    ip inspect name DEFAULT100 udp
    ip inspect name DEFAULT100 vdolive
    !
    !
    crypto pki trustpoint TP-self-signed-1201972750
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1201972750
    revocation-check none
    rsakeypair TP-self-signed-1201972750
    !
    !
    crypto pki certificate chain TP-self-signed-1201972750
    certificate self-signed 01
    BLABLA CERT INFO

    username admin privilege 15 secret 5 PASSWORD
    !
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description $ES_WAN$$FW_OUTSIDE$
    no snmp trap link-status
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0
    no cdp enable
    !
    interface FastEthernet1
    no cdp enable
    !
    interface FastEthernet2
    no cdp enable
    !
    interface FastEthernet3
    no cdp enable
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
    ip address 172.31.12.12 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    no ip virtual-reassembly
    !
    interface Dialer0
    description $FW_OUTSIDE$
    ip address STATIC_PUBLIC_IP 255.255.255.254
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname USERNAME
    ppp chap password 7 PASSWORD
    ppp pap sent-username USERNAME password 7 PASSWORD
    !
    !
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    ip nat inside source list 100 interface Dialer0 overload
    !
    logging trap debugging
    access-list 100 permit ip 172.31.12.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    !
    !
    control-plane
    !
    banner login ^CCAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    --More-- line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    transport output all
    line vty 5 15
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    !
    webvpn context Default_context
    ssl authenticate verify all
    !
    no inservice
    !
    end



    As far i can see i'm connected to internet:
    #sh dsl int atm 0
    ATM0
    Alcatel 20190 chipset information
    ATU-R (DS) ATU-C (US)
    Modem Status: Showtime (DMTDSL_SHOWTIME)
    DSL Mode: ITU G.992.5 (ADSL2+) Annex A
    ITU STD NUM: 0x03 0x2
    Chip Vendor ID: 'STMI' 'IFTN'
    Chip Vendor Specific: 0x0000 0x71B9
    Chip Vendor Country: 0x0F 0xB5
    Modem Vendor ID: 'CSCO' ' '
    Modem Vendor Specific: 0x0000 0x0000
    Modem Vendor Country: 0xB5 0x00
    Serial Number Near: FHK09292232
    Serial Number Far:
    Modem Version Near: 12.4(6)T7
    Modem Version Far:
    Capacity Used: 100% 100%
    Noise Margin: 11.0 dB 6.0 dB
    Output Power: 20.5 dBm 13.0 dBm
    Attenuation: 35.0 dB 11.0 dB
    Defect Status: None None
    Last Fail Code: None
    Watchdog Counter: 0xE8
    Watchdog Resets: 0
    Selftest Result: 0x00
    Subfunction: 0x00
    Interrupts: 7673 (0 spurious)
    PHY Access Err: 0
    Activations: 1
    LED Status: ON
    LED On Time: 100
    LED Off Time: 100
    Init FW: embedded
    Operation FW: embedded
    FW Version: 2.5.42

    --More-- DS Channel1 DS Channel0 US Channel1 US Channel0
    Speed (kbps): 0 8391 0 1067
    Cells: 0 534 0 501
    Reed-Solomon EC: 0 18123 0 0
    CRC Errors: 0 0 0 0
    Header Errors: 0 0 0 0
    Total BER: 0E-0 0E-0
    Leakage Avarage BER: 0E-0 0E-0
    Interleave Delay: 0 8 0 6


    Problems:
    1. cannot ping anything on the internet
    2. hosts on my internal network cannot access internet

    any help would be appreciated.
     
  2. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Just had a quick look so I could be wrong but I couldn't spot a default route.
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  3. alfwro

    alfwro New Member

    4
    0
    1
    Doh...

    added:

    ip route 0.0.0.0 0.0.0.0 Dialer0 permanent

    but no change
    still unable to access Inet :(
     
  4. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Can you ping the next-hop WAN router from the router itself?
    Are you using a static IP on the WAN side, or is it DHCP assigned by your ISP?

    Btw: could be me that isn't that far into cisco DSL configuration yet, but is this subnet correct?

    interface Dialer0
    description $FW_OUTSIDE$
    ip address STATIC_PUBLIC_IP 255.255.255.254
    no ip redirects
    no ip unreachables
    no ip proxy-arp
     
    Last edited: Oct 28, 2010
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  5. alfwro

    alfwro New Member

    4
    0
    1
    Static IP supplied by ISP

    hmm how would I find out what the next WAN hop is?
     
  6. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Look at your subnet and ping all possible other hosts?
     
    Last edited: Oct 28, 2010
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  7. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    That subnet will be correct, it will just be the way the ISP does their addressing.

    What exactly are you doing to get on the internet? Just opening a web browser?

    try pinging a web address from your host (does it resolve the name)
    Try doing an extended ping from the router CLI, and use the WAN interface address as the source.
    Also, do a 'show ip nat translations' to see if your hosts address is getting NAT'd to the dialer interface address.

    Also, do a 'show ip route' to make sure your default route is being added to the route table.

    although the modem shows to be synced with the exchange, it may still not be connected to the internet, in that username/password could be wrong.
     
    Last edited: Oct 28, 2010
    Certifications: CCENT, CCNA
    WIP: CCNP
  8. alfwro

    alfwro New Member

    4
    0
    1
    found it -- wrong adsl password :rolleyes:
     
  9. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    Glad your all sorted now
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)

Share This Page

Loading...